Author Topic: Code::Blocks running wrong program  (Read 9156 times)

Offline CDB

  • Single posting newcomer
  • *
  • Posts: 2
Code::Blocks running wrong program
« on: April 16, 2013, 09:51:14 pm »
Im pretty new to code blocks and I have a major issue, whenever I try to run one of my new programs it will only run the first program I coded in code blocks. I am unsure whether this is my own error or a bug. Please help.
Thanks

Offline Jenna

  • Administrator
  • Lives here!
  • *****
  • Posts: 7255
Re: Code::Blocks running wrong program
« Reply #1 on: April 16, 2013, 09:59:05 pm »
I'm pretty sure, it's your error, not a bug.
It never ever happens to me in years of using C::B.

To be able to help you, you should post some more information, like the versikon of C::B, your OS, probably your compiler and exact steps to reproduce your issue.

Offline CDB

  • Single posting newcomer
  • *
  • Posts: 2
Re: Code::Blocks running wrong program
« Reply #2 on: April 16, 2013, 10:33:29 pm »
I seemed to have fixed it by deleting the project that was causing the issue. Thanks for your help anyway  :)

fardin8

  • Guest
Re: Code::Blocks running wrong program
« Reply #3 on: July 23, 2023, 10:03:24 pm »
I am also facing the same problem. When i try to build and run the 2nd file of my project it executes the first file. Can anyone help?

Offline stahta01

  • Lives here!
  • ****
  • Posts: 7625
    • My Best Post
Re: Code::Blocks running wrong program
« Reply #4 on: July 23, 2023, 10:19:43 pm »
Please post a full re-build log if you still have the problem?
NOTE: Re-build is needed! You *need* to use re-build or clean followed by build otherwise you are the cause of the problem.

Tim S.
C Programmer working to learn more about C++ and Git.
On Windows 7 64 bit and Windows 10 64 bit.
--
When in doubt, read the CB WiKi FAQ. http://wiki.codeblocks.org