Author Topic: Problem using debugger with Mac os in code blocks  (Read 5932 times)

Offline aarielvacon

  • Single posting newcomer
  • *
  • Posts: 3
Problem using debugger with Mac os in code blocks
« on: March 21, 2013, 06:17:42 pm »
Hi everyone , i have problems when i try to use the debugger in code blocks. The problem is the next ; i set a breakpoint and when i run the debugger appears two console that says : "Last login: Thu Mar 21 14:12:26 on ttys000
MacBook-Pro-de-Ariel:~ ..."
and  the debugger log says : "Setting breakpoints
Can't launch console (osascript -e 'tell app "Terminal"' -e 'activate' -e 'do script ""' -e 'end tell' sleep 80000255)
Debugger name and version: GNU gdb 6.3.50-20050815 (Apple version gdb-1824) (Wed Feb  6 22:51:23 UTC 2013)
At /Users/arielcohen/Documents/Ejercicio1.3/main.c:57" so i can't use the debugger . I have a MacBook Pro version : OS X 10.8.3 . Anyone could help me to solve this problem ? Because it's very difficult to program without debugger. Thanks for all.

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 13438
    • Travis build status
Re: Problem using debugger with Mac os in code blocks
« Reply #1 on: March 21, 2013, 06:53:43 pm »
Try to execute this:
Code
osascript -e 'tell app "Terminal"' -e 'activate' -e 'do script ""' -e 'end tell' sleep 80000255
in a terminal and tell me what is the result.

Probably they've changed something in 10.8. I don't know and I don't have OSX to try it.

p.s. gdb 6.3 is extremely old and probably won't work correctly. You need at least 6.8 and preferably 7.4/5.
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Offline aarielvacon

  • Single posting newcomer
  • *
  • Posts: 3
Re: Problem using debugger with Mac os in code blocks
« Reply #2 on: March 21, 2013, 07:59:07 pm »
Sorry about my ignorance , but where i can find the "Terminal" . With respect to gdb i have to download from code blocks website ?
Thanks for answering .

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 13438
    • Travis build status
Re: Problem using debugger with Mac os in code blocks
« Reply #3 on: March 21, 2013, 08:02:03 pm »
In your /Applications folder of course (you are running OSX not I so you should know better) :)

C::B project doesn't ship compiler binaries for anything else but windows. And we just package them there, we don't build or maintain them.
So I don't know how and where you can find newer gdb. Google should be your friend, search for it or switch to a better OS :)
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Offline aarielvacon

  • Single posting newcomer
  • *
  • Posts: 3
Re: Problem using debugger with Mac os in code blocks
« Reply #4 on: March 21, 2013, 08:19:03 pm »
Sorry im new with this new OS . Its the first time that i have something like this. With respect to the terminal i put that command and says : tab 1 of window id 616
MacBook-Pro-de-Ariel:~ ariel$ and it open a new window like the terminal window.