Author Topic: Install Code::Blocks with wxWidgets  (Read 11593 times)

Offline Diazepam

  • Single posting newcomer
  • *
  • Posts: 6
Install Code::Blocks with wxWidgets
« on: December 20, 2012, 04:52:47 pm »
Let's go again over the steps.

1. Install Code::Blocks
2. Install VS2010 Express to get the compiler
2.1 Chec of Code::Blocks actually has the location of the compiler at build options.
3. Install Microsoft SDK
3.1 Pray you don't get bugs.
4. Install wxWidgets 2.9 or 2.8.
5. Compile wxWidgets
5.1 Right click on My Computer go to Properties --> Advanced  --> Env Variables
5.2 Find "Path" and add ";C:\Program Files\CodeBlocks\MinGW\bin"
5.3 Open the command promt.
5.4 Type "C:\wxWidgets-2.8.12\build\msw" and press Enter
5.5 Type "mingw32-make.exe -f makefile.gcc USE_XRC=1 SHARED=1 MONOLITHIC=1 BUILD=release UNICODE=0"
5.6 Get a coffee. This will take some time.
6. Open Code::Blocks
7. Make a new Project, Select WxWidgets, select the version, type a project name
8. Select wxSmith or wxFormBuilder & Frame-based
9. type "C:\wxWidgets-2.8.12" at wxWidgets location
10. Select MS2010 compiler. Select Release, DON'T select debug.
11. Select all wxWidgets library settings. (i personally tryed every possible combination in this frame.

12. Compile & Run ?


This is what I did. When I make the project, I get a warning telling me that "a matching release configuration cannot be found in the wxwidgets directory you specified". If I ignore that, the project is created, but when I try to build, an error pops telling me "Execution of rc.exe failed".

Please tell me what I did wrong and PLEASE make a decent guide for this.
VS CLI is not supported any more and you don't get auto-complete. Dev-C++ is so bugged you don't have Undo. All C++ GUI builder plugins from eclipse have no support.
Right now, WxWidgets on Code::Blocks seems be the only way to make C++ programs with GUI, but setting up the IDE is so user-friendly that it reminds me of the old Dacia 1300 cars from Romania.

Offline stahta01

  • Lives here!
  • ****
  • Posts: 7174
    • My Best Post
Re: Install Code::Blocks with wxWidgets
« Reply #1 on: December 20, 2012, 05:34:56 pm »
YOU need to compile wxWidgets using the SAME compiler as you want to use in your project!!!

DO NOT USE TWO DIFFERENT COMPILERS!!!

NOTE: I do NOT use wxSmith; so, I have no idea if it works with Visual Studio as the Compiler.

Tim S.
« Last Edit: December 20, 2012, 05:39:20 pm by stahta01 »
C Programmer working to learn more about C++ and Git.
On Windows 7 64 bit and Windows 10 32 bit.
On Debian Stretch, compiling CB Trunk against wxWidgets 3.0.
--
When in doubt, read the CB WiKi FAQ. http://wiki.codeblocks.org

Offline Diazepam

  • Single posting newcomer
  • *
  • Posts: 6
Re: Install Code::Blocks with wxWidgets
« Reply #2 on: December 20, 2012, 05:55:31 pm »
Hmm. Thank you. I will do some testing and I will come back.
Please add: "DO NOT USE TWO DIFFERENT COMPILERS!!!" in an the wxwidgets guide. :D

Offline stahta01

  • Lives here!
  • ****
  • Posts: 7174
    • My Best Post
Re: Install Code::Blocks with wxWidgets
« Reply #3 on: December 20, 2012, 06:09:40 pm »
Hmm. Thank you. I will do some testing and I will come back.
Please add: "DO NOT USE TWO DIFFERENT COMPILERS!!!" in an the wxwidgets guide. :D

We can NOT add all the things that are obvious to a good computer programmer.

Tim S.
C Programmer working to learn more about C++ and Git.
On Windows 7 64 bit and Windows 10 32 bit.
On Debian Stretch, compiling CB Trunk against wxWidgets 3.0.
--
When in doubt, read the CB WiKi FAQ. http://wiki.codeblocks.org

Offline Diazepam

  • Single posting newcomer
  • *
  • Posts: 6
Re: Install Code::Blocks with wxWidgets
« Reply #4 on: December 20, 2012, 06:33:29 pm »
I have no ideea what a good computer programmer is. If someone programmed 2 years in android (java), php and mysql, he will have absolutely no ideea how to run code::blocks with the information you provide.

Offline Diazepam

  • Single posting newcomer
  • *
  • Posts: 6
Re: Install Code::Blocks with wxWidgets
« Reply #5 on: December 20, 2012, 06:56:21 pm »
Great. I used the GNU GCC compiler and everything went smooth. This means I don't have to install VS2012 in order to work with wxWidgets, right ?
Do you recomand any other GUI builder for C++ ?

Offline jens

  • Administrator
  • Lives here!
  • *****
  • Posts: 7255
Re: Install Code::Blocks with wxWidgets
« Reply #6 on: December 20, 2012, 07:09:00 pm »
I suggest using wxWidgets, TDM's MinGW, C::B with wxSmith and "UNICODE=1" if you configure wxWidgets.
If you do not plan to use win98 or so, it does not make senseto use an ansi-build in my eyes.
You might also run in trouble with newer wxWidgets if you try to use ansi-build (if I remember correctly).