Author Topic: How to configure GDB, failed with minGW  (Read 4429 times)

Offline havefun

  • Single posting newcomer
  • *
  • Posts: 6
How to configure GDB, failed with minGW
« on: September 01, 2012, 09:55:14 am »
Many months ago, I installed the stable edtion 10.05 along with cygwin, so everything had been configured ok.
but that one has some bugs in my computer.

Today, I install the newest one "Build 8248" in WinXP.
After I unzip CB, mingwm10 and wxmsw28u, program can be complier and built to run.
because I installed python(x,y) 2.7.2.1 before and the minGW32 4.5.2.1 has been installed, the CB detect that gcc 4.5.2-1 in minGW's install path and run correctly.

however, CB don't detect the gdb 7.3, though i find there is "gdb.exe" in the same path as gcc.
it does not work, even i configure the path in debugger settings.

Thanks for any advice!
« Last Edit: September 02, 2012, 11:53:17 am by havefun »

Offline ollydbg

  • Developer
  • Lives here!
  • *****
  • Posts: 5377
  • OpenCV and Robotics
    • Chinese OpenCV forum moderator
Re: How to configure GDB, failed with minGW
« Reply #1 on: September 04, 2012, 02:02:01 am »
however, CB don't detect the gdb 7.3, though i find there is "gdb.exe" in the same path as gcc.
it does not work, even i configure the path in debugger settings.
What does "it does not work" mean? Give use detailed information please.
If some piece of memory should be reused, turn them to variables (or const variables).
If some piece of operations should be reused, turn them to functions.
If they happened together, then turn them to classes.

Offline havefun

  • Single posting newcomer
  • *
  • Posts: 6
Re: How to configure GDB, failed with minGW
« Reply #2 on: September 05, 2012, 09:12:21 am »
thanks for your reply.
when i prepare the images for my configuration to you, i suddenly remember that the reason for failing to debug may be on the build way.
I didn't create a project! just created a file and built to run it.
 :-[so embarrassed.

Offline havefun

  • Single posting newcomer
  • *
  • Posts: 6
Re: How to configure GDB, failed with minGW
« Reply #3 on: September 05, 2012, 09:16:52 am »
however, CB don't detect the gdb 7.3, though i find there is "gdb.exe" in the same path as gcc.
it does not work, even i configure the path in debugger settings.
What does "it does not work" mean? Give use detailed information please.

though  I make a naive mistake, but these is in fact a situation.
the CB did not detect the gdb, i add the path manually in "setting->debugger".