Author Topic: debug with my own makefile  (Read 3080 times)

Offline 84matte84

  • Single posting newcomer
  • *
  • Posts: 2
debug with my own makefile
« on: March 26, 2012, 12:03:58 pm »
Hi guys,
I'm new to codeblocks.

I'm having a problem with a project. I would like to use my personal makefile created with cmake so I set "This is a custom Makefile" in Menu->Project->Properties->Project Settings.

Then because of in my makefile I have no "rules" but only one rule that compile everything I change the "Build Project Target" in "make" in Menu->Project->Properties->Project's build options->Make commands.

So now the build exetution goes well and codeblock is able to compile it but when I run the debugger I have this output in the debug log

Command-line: /usr/bin/gdb -nx -fullname  -quiet -args bin/Debug/SOII-SMTP
Working dir : /home/matteo/Desktop/SOII-Project/SOII-SMTP/
bin/Debug/SOII-SMTP: No such file or directory.
> set prompt >>>>>>cb_gdb:
Executing: xterm -T 'Program Console' -e sleep 85629
> show version
GNU gdb (Ubuntu/Linaro 7.3-0ubuntu2) 7.3-2011.08
Copyright (C) 2011 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "i686-linux-gnu".
For bug reporting instructions, please see:
> set confirm off
> set width 0
> set height 0
> set breakpoint pending on
> set print asm-demangle on
> set unwindonsignal on
> set disassembly-flavor intel
> catch throw
No symbol table is loaded.  Use the "file" command.
Catchpoint 1 (throw)
> source /usr/share/codeblocks/scripts/stl-views-1.0.3.gdb
> directory /home/matteo/Desktop/SOII-Project/SOII-SMTP/
> directory /home/matteo/Desktop/SOII-Project/
Executing: ps x -o tty,pid,command
PS result: ?        30117 skype
PS result: ?        28754 /usr/lib/gvfs/gvfsd-afp-browse --spawner :1.1 /org/gtk/gvfs/exec_spaw/8
PS result: ?        28472 /usr/lib/gvfs/gvfsd-dnssd --spawner :1.1 /org/gtk/gvfs/exec_spaw/6
PS result: ?        28463 /usr/lib/gvfs/gvfsd-smb-browse --spawner :1.1 /org/gtk/gvfs/exec_spaw/4
PS result: ?        28459 /usr/lib/gvfs/gvfsd-network --spawner :1.1 /org/gtk/gvfs/exec_spaw/3
PS result: ?        24494 /usr/lib/gvfs/gvfsd-http --spawner :1.1 /org/gtk/gvfs/exec_spaw/2
PS result: ?        24241 /usr/lib/firefox-11.0/plugin-container /usr/lib/flashplugin-installer/ -greomni /usr/lib/firefox-11.0/omni.ja 24121 true plugin
PS result: ?        24121 /usr/lib/firefox-11.0/firefox
PS result: pts/1    24058 bash
PS result: pts/0    23306 ssh [email protected]
PS result: ?        19321 ps x -o tty,pid,command
PS result: pts/4    19317 sleep 85629
TTY is[/dev/pts/4]
> tty /dev/pts/4
Queued:[tty /dev/pts/4]
> run
No executable file specified.
Use the "file" or "exec-file" command.
> quit

And I can't find the configuration options to change the settings in order to fix this problem....obviously in my make file I have inserted the -g flag infact if I run gdb from the console gdb is able to debug it correctly so I think is a problem related to codeblock

please help me
thank you in advance


Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 13305
    • Travis build status
Re: debug with my own makefile
« Reply #1 on: March 26, 2012, 01:41:31 pm »
Project->Properties->Build targtes->Output filename
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]