Author Topic: Issue with config codeblock to build file (.so)  (Read 5168 times)

Offline console

  • Single posting newcomer
  • *
  • Posts: 3
Issue with config codeblock to build file (.so)
« on: March 10, 2012, 02:07:52 pm »
Hi all,
I try config code block to build file (.so) but not successful with some error.
I use android-ndk-r7.
This is log:
Code
-------------- Build: Android-Debug in jni ---------------

[ 20.0%] Compiling: ..\android-receiver.cpp
[ 40.0%] Compiling: ..\app-android.cpp
[ 60.0%] Compiling: ..\app-quake3.cpp
[ 80.0%] Compiling: ..\CIrrDeviceAndroid.cpp
[100.0%] Linking dynamic library: ..\..\libs\armeabi\libjni.so
C:/DevTools/android-ndk-r7/toolchains/arm-linux-androideabi-4.4.3/prebuilt/windows/bin/../lib/gcc/arm-linux-androideabi/4.4.3/../../../../arm-linux-androideabi/bin/ld.exe: unrecognized option '--output-def=..\..\libs\armeabi\libjni.so.def'
C:/DevTools/android-ndk-r7/toolchains/arm-linux-androideabi-4.4.3/prebuilt/windows/bin/../lib/gcc/arm-linux-androideabi/4.4.3/../../../../arm-linux-androideabi/bin/ld.exe: use the --help option for usage information
collect2: ld returned 1 exit status
Process terminated with status 1 (0 minutes, 4 seconds)
0 errors, 0 warnings
Hope to receive help from peoples
Thanks all. :)

Offline MortenMacFly

  • Administrator
  • Lives here!
  • *****
  • Posts: 9614
Re: Issue with config codeblock to build file (.so)
« Reply #1 on: March 10, 2012, 03:05:34 pm »
Why don't you first READ what you post? Especially this:
Code
ld.exe: unrecognized option '--output-def=..\..\libs\armeabi\libjni.so.def'
ld.exe: use the --help option for usage information
Compiler logging: Settings->Compiler & Debugger->tab "Other"->Compiler logging="Full command line"
C::B Manual: http://www.codeblocks.org/docs/main_codeblocks_en.html
C::B FAQ: http://wiki.codeblocks.org/index.php?title=FAQ

Offline console

  • Single posting newcomer
  • *
  • Posts: 3
Re: Issue with config codeblock to build file (.so)
« Reply #2 on: March 10, 2012, 03:24:22 pm »
I don't know how to fix this error. What I must be config to build file (.so) by codeblock  :( ?
Thanks.
« Last Edit: March 10, 2012, 03:28:18 pm by console »

Offline MortenMacFly

  • Administrator
  • Lives here!
  • *****
  • Posts: 9614
Re: Issue with config codeblock to build file (.so)
« Reply #3 on: March 10, 2012, 03:31:30 pm »
I don't know how to fix this bug. What I must be config to build file (.so) by codeblock  :( ?
Thanks.
I don't know what compiler you've selected, hopefully an ARM based one. If so, go to the global compiler options -> select your compiler -> switch to tab "other settings" -> click on  "Advanced options" -> On the tab "commands" select "Link object files to dynamic library" -> remove the option "-Wl,--output-def=$def_output".

Notice that this is ONLY A WILD GUESS! Consult the compiler documentation how to do it properly. Ask in the compiler forum (not the C::B forum) for additional help.
Compiler logging: Settings->Compiler & Debugger->tab "Other"->Compiler logging="Full command line"
C::B Manual: http://www.codeblocks.org/docs/main_codeblocks_en.html
C::B FAQ: http://wiki.codeblocks.org/index.php?title=FAQ

Offline console

  • Single posting newcomer
  • *
  • Posts: 3
Re: Issue with config codeblock to build file (.so)
« Reply #4 on: March 10, 2012, 03:58:04 pm »
I don't know how to fix this bug. What I must be config to build file (.so) by codeblock  :( ?
Thanks.
I don't know what compiler you've selected, hopefully an ARM based one. If so, go to the global compiler options -> select your compiler -> switch to tab "other settings" -> click on  "Advanced options" -> On the tab "commands" select "Link object files to dynamic library" -> remove the option "-Wl,--output-def=$def_output".

Notice that this is ONLY A WILD GUESS! Consult the compiler documentation how to do it properly. Ask in the compiler forum (not the C::B forum) for additional help.
Thank you very much. :)