Developer forums (C::B DEVELOPMENT STRICTLY!) > Development

Running (debugging) codeblocks inside codeblocks?


I've found something interesting. When I use codeblocks to debug itself, the "debuggeD" main.cpp's routines etc do NOT get executed - instead, the "debuggeR" main.cpp's are.

And I think it's because codeblocks is compiled as DLL. Isn't there a way to prevent this from happening? Thanks! :)

Here's a weird one:

I compiled C::B, did update, and tried to run it inside C::B (using wx2.6.0: I know--unsupported).
Whenever I tried to run the program (Run button), the program would never start--Windows gave me an illegal memory error :x .  I even did a recompile (including CVS), update, run.  Still no luck :evil: .
Then I used the debugger (Debug with no breakpoint) and the program started fine :? .  I opened files, resized the windows, closed files, etc., and closed the debugged program--no problems :) .  The only thing was that the open files min,restore,close button triplet wasn't present.  I'm assuming this is related to the wx2.6.0 problem (BTW, there are three small patches to the wx2.6.0 code)
Then I tried to run the program (Run button) and THE PROGRAM STARTED. What's up with that!?! :?:

Is this related to the above?


--- Quote ---Then I tried to run the program (Run button) and THE PROGRAM STARTED. What's up with that!?! Question

Is this related to the above?
--- End quote ---

No. It must have to do with a bug that exists in the "working dir" target setting. The debugger set it correctly. That's why it could run afterwards...
I 'll work on it.


Thats odd. I have debugged codeblocks inside codeblocks inside codeblocks (when I was working with the fix for debugger dirs). That was horribly slow, but it worked for me.

Although I seem to remember issues with the wrong dll being used, but I can't remember what they were. Oh well *shrug*. I will get back to you on it if I remember.


[0] Message Index

Go to full version