Author Topic: 'Run' appears to do nothing.  (Read 2516 times)

Tasogare

  • Guest
'Run' appears to do nothing.
« on: June 11, 2011, 11:19:56 pm »
[Edit: I managed to work around this but I'm leaving the post in case someone else finds it helpful.]

Hi, community.

I had a drive crash recently. New drive came in. Windows reinstall, codeblocks reinstall. My current project and all its source is on a separate drive, so nothing important was lost, yay. So I get things set up, reopen the project and get ready to get back to work.

The 'run' button does nothing; it doesn't even generate an error, though it does clear the build log and build messages windows.

I can build and rebuild the project. I can run it via the 'debug' button and it works. No code has changed since it last ran (before the drive crash). The working directory (which carries certain necessary dlls and external files) is outside the project directory, but the 'debug' button finds it fine. Renaming that directory makes things fail, so I know I haven't accidentally pointed it somewhere else. Renaming the executable (inside the project directory) prompts a rebuild, so I know the build and run process is looking in the correct place.

I can copy the executable to the appropriate working directory, run it there (outside of codeblocks) and that works fine too.

I can only assume I configured something *really, really wrong* when I was setting up the new CB installation. But I can't for the life of me figure out what. Any suggestions?

OS: Windows 7 64-bit (same version as before the dead drive)
CB: 10.05. (I believe the same version as on the old drive, though I'm not 100% sure.)

If it's relevant, all project and source files are stored in a shared folder on another system. No source has been changed since it last worked, and the only change in the project file was pointing it to a different compiler install directory. I assume that part didn't cause the problem because I can rebuild it successfully.

[edit: I tried creating a new console project from scratch and had the same issue, so it's not something in my project configuration.]
[edit 2: Also tried renaming the codeblocks folder under appdata, in the hopes it would force it to regenerate my settings. This didn't work either, though it did reset everything visible.]
[edit 3: Tried uninstalling/reinstalling codeblocks, still no joy.]
[edit 4: Removed codeblocks and installed the version with mingw included. Now it works, even though I'm not even using that compiler and did not recompile the program. O_o WTF?]
« Last Edit: June 12, 2011, 02:43:07 am by Tasogare »