Author Topic: wxsmith missing controls  (Read 4543 times)

Offline wxf54318

  • Single posting newcomer
  • *
  • Posts: 8
wxsmith missing controls
« on: March 16, 2011, 08:44:54 am »
Hi buddys! I encounter a problem!
I created a wxwidgets project with CB.In my frame window,the wxchartctrl,wxflatnotebook,wxcustombuton can be found in the "contrib",the wxmenu,wxtimer,wxsingelinstancecheaker,wxstopwatch can be found in the "Tools",but when I create a dialog or a frame in this project, these controls are missing!
Can anybody help me out and tell me why?

Offline wxf54318

  • Single posting newcomer
  • *
  • Posts: 8
Re: wxsmith missing controls
« Reply #1 on: March 17, 2011, 02:05:24 am »
I am using codeblocks-10.05mingw-setup.exe
 in the winxp os!

Offline MortenMacFly

  • Administrator
  • Lives here!
  • *****
  • Posts: 9662
Re: wxsmith missing controls
« Reply #2 on: March 17, 2011, 07:28:10 am »
...see image attached.
Compiler logging: Settings->Compiler & Debugger->tab "Other"->Compiler logging="Full command line"
C::B Manual: https://www.codeblocks.org/docs/main_codeblocks_en.html
C::B FAQ: https://wiki.codeblocks.org/index.php?title=FAQ

Offline wxf54318

  • Single posting newcomer
  • *
  • Posts: 8
Re: wxsmith missing controls
« Reply #3 on: March 17, 2011, 04:02:46 pm »
These are the images!

Offline MortenMacFly

  • Administrator
  • Lives here!
  • *****
  • Posts: 9662
Re: wxsmith missing controls
« Reply #4 on: March 17, 2011, 05:32:49 pm »
These are the images!
Weird. There is no reason for that to happen and (in fact) it works for me just fine. Did you do anything special with your C::B? Can you try a clean install (e.g. temporarily having the C::B config file "default.conf" removed) and with a clean (new) dummy project?

...could you also try a nightly?
Compiler logging: Settings->Compiler & Debugger->tab "Other"->Compiler logging="Full command line"
C::B Manual: https://www.codeblocks.org/docs/main_codeblocks_en.html
C::B FAQ: https://wiki.codeblocks.org/index.php?title=FAQ

Offline wxf54318

  • Single posting newcomer
  • *
  • Posts: 8
Re: wxsmith missing controls
« Reply #5 on: March 18, 2011, 01:54:49 am »
I only configed "project->build options->liner setting " \"project->build options->Search directories "\"Settings-> compiler and debugger->search directories".

Offline MortenMacFly

  • Administrator
  • Lives here!
  • *****
  • Posts: 9662
Re: wxsmith missing controls
« Reply #6 on: March 18, 2011, 07:32:13 am »
I only configed "project->build options->liner setting " \"project->build options->Search directories "\"Settings-> compiler and debugger->search directories".
...that doesn't answer my questions / requests.
Compiler logging: Settings->Compiler & Debugger->tab "Other"->Compiler logging="Full command line"
C::B Manual: https://www.codeblocks.org/docs/main_codeblocks_en.html
C::B FAQ: https://wiki.codeblocks.org/index.php?title=FAQ

Offline wxf54318

  • Single posting newcomer
  • *
  • Posts: 8
Re: wxsmith missing controls
« Reply #7 on: March 20, 2011, 01:21:14 pm »
I've tried the latest nightly bulid,but the same thing hanpped.

Offline wxf54318

  • Single posting newcomer
  • *
  • Posts: 8
Re: wxsmith missing controls
« Reply #8 on: March 26, 2011, 03:08:33 pm »
I used wxmsw.Is it related to wxwidgets.