Author Topic: mingw64/opengl problem  (Read 5178 times)

Offline yaykittyeee

  • Single posting newcomer
  • *
  • Posts: 2
mingw64/opengl problem
« on: October 20, 2010, 03:10:24 am »
I used to have MinGW 4.5.0(i think, it was whatever the lastest version is) as my codeblocks compiler. I remember i set it up without much trouble a few months ago. I also set up opengl using the levelbylevel tutorial with codeblocks and mingw. everything worked just fine until last week when i installed a java ide and all the stuff to go with it and i changed the path variable for that instead of just adding it to the one i already had in there. :(  i was in a bit of a hurry and i figured i could just fix it later. so I tried to fix it and put the C:\MinGW\bin in the path variable too but it didn't work. none of my c++ or opengl programs would compile. So after trying several different directories for the path it still didn't work and i decided to ask google for help. I found the MinGW-w64 and decided to give it a try. So now all my c++ programs work but my opengl ones still won't compile. I keep getting the error (ld.exe cannot find -lglut32). i googled again and found something that said MinGW-w64 is not compatible with opengl. So i want to switch back to the old version of MinGW but I still don't know what to use for my path variable. It worked before, I don't think I used C:\MinGW\bin for the path. Is there anyone who might have some advice about what else I could use. I'll keep googleing but I have homework due in less than two days for my opengl class so any help would be appreciated.

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 13161
    • Travis build status
Re: mingw64/opengl problem
« Reply #1 on: October 20, 2010, 08:26:58 am »
Most of the times the correct path is without the /bin part...

Also if you have two versions of Mingw, don't put either of them in X:\mingw (x is any drive letter)
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Offline jens

  • Administrator
  • Lives here!
  • *****
  • Posts: 7255
Re: mingw64/opengl problem
« Reply #2 on: October 20, 2010, 08:44:20 am »
Most of the times the correct path is without the /bin part...

Partly right, the system path needs the bin, but it's not needed for C::B's compiler installation dir (in the Toolchain executables tab).

Offline yaykittyeee

  • Single posting newcomer
  • *
  • Posts: 2
Re: mingw64/opengl problem
« Reply #3 on: October 21, 2010, 03:59:30 am »
oh yay!  it's working now.  i'm not really sure what i did though.  thanks for all the help