User forums > Help

"Command execution failed..."

(1/2) > >>

First, thanks to developers for great IDE.

Second, problem:
I'm truing to compile wxWidgets from codeblocks, using Microsoft Visual C++ Toolkit 2003 compiler. I imported project, changed secttings apporiately, etc, it mostly compiles. But:
After compiling quite many files (but not all), i get  "Command execution failed..." error

I tried starting compiling again, and got that:

--- Code: ---
Project   : wxWindows
Compiler  : Microsoft Visual C++ Toolkit 2003 (called directly)
Directory : C:\wxWindows-2.4.2\src\
Switching to target: default
Command execution failed...

--- End code ---

What exactly it means, and what to do with it? Seems that it's codeblocks-related thing.

in Setting/Configure Plugins/Compiler
select the correct compiler,
click on the "Other" tab and
set "Compiler Logging" combo to "Full Command Line"
than post again the compiler log

tnx, walter

Fixed it... rc wasn't in path. Thanks for "full command line" tip.

When "Command execution failed" appears, switch to the "Code::Blocks Debug" message tab. It contains the failed command line.
To display this tab, if it is not visible, go to Settings/Environment (you will have to restart CB to show it).


Another thing: I wanted to create a project file for wx compilation but haven't found the time yet. If you succeed and you want to contribute, send me the working project file you created so that I can put it on a web page (along with project files for other compilers). I was planning on putting together a small HOWTO for wx compilation, but this would simplify things a lot...

Today I created the GCC project file for wx :)



[0] Message Index

[#] Next page

Go to full version