Author Topic: C++0x supported in default compiler under CB 10.05  (Read 3142 times)

Offline er

  • Multiple posting newcomer
  • *
  • Posts: 34
C++0x supported in default compiler under CB 10.05
« on: August 16, 2010, 11:00:07 pm »
Hello,

My understanding is that CB comes with a pre-installed compiler. I though I had read it is GCC4.4 under CB 10.05. However, I enable c++0x in the compiler settings > Compiler flags, and here's what I get:

Compiling: main.cpp
cc1plus: error: unrecognized command line option "-std=c++0x"

Some help would be appreciated. Thanks.
Code::Blocks 10.05/ Mac OS X 10.6.4/GCC

Offline stahta01

  • Lives here!
  • ****
  • Posts: 7090
    • My Best Post
Re: C++0x supported in default compiler under CB 10.05
« Reply #1 on: August 17, 2010, 03:39:10 pm »
You are likely using an Compiler that is too old.

I just used the Compiler that is sometimes packaged with CB 10.05 and the option "-std=c++0x" worked.

Tim S.
C Programmer working to learn more about C++ and Git.
On Windows 7 64 bit and Windows 10 32 bit.
On Debian Stretch, compiling CB Trunk against wxWidgets 3.0.
--
When in doubt, read the CB WiKi FAQ. http://wiki.codeblocks.org

Offline er

  • Multiple posting newcomer
  • *
  • Posts: 34
Re: C++0x supported in default compiler under CB 10.05
« Reply #2 on: August 17, 2010, 05:22:50 pm »
You are likely using an Compiler that is too old.

I just used the Compiler that is sometimes packaged with CB 10.05 and the option "-std=c++0x" worked.

Tim S.

Thanks. Yes, I know, it's using the compiler that already resides on my machine, GCC 4.2 probably.

Under Mac OS X?

How can I make sure it is packaged with the right compiler?

Code::Blocks 10.05/ Mac OS X 10.6.4/GCC

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 13194
    • Travis build status
Re: C++0x supported in default compiler under CB 10.05
« Reply #3 on: August 17, 2010, 06:36:09 pm »
Find your gcc/g++ executable and execute "gcc --version/g++ --version" in a terminal
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]