Author Topic: Running into RC file problems  (Read 3886 times)


  • Guest
Running into RC file problems
« on: November 05, 2005, 04:38:28 am »
I'm trying to make a mod for a game (Jedi Academy, if it matters). It says to use Microsoft Visual C++ v7.00, which I don't have, but I found Microsoft's free command line compiler and was hoping for it would work. Then, however, I found myself unable to work with their cryptic '.sln files'. Soo, after some searching, I happened upon this CodeBlocks IDE. I was able to import the sln file and tried to compile. It went all the way from AnimalNPC.c to w_saber.c, but then came up with

Execution of 'rc.exe    -fo..\Release\JK2cgame\codemp\win32\JK2cgame.res ..\win32\JK2cgame.rc' in 'C:\projects\JEDI_Academy_SDK\codemp\cgame' failed.

I searched for rc.exe on my computer, but found nothing. In a thread on this forum (,1261.0.html), I read that the MS Platform SDK is required so downloaded and installed it. I went to Settings->Compiler->Programs and chose the newly-there RC.exe for the appropriate slot. I tried compiling again and got the same problem (although it was RC instead of rc, so I know it's looking at the new path). So, I am now stuck.

Thanks for reading/any help.

Offline Bill

  • Single posting newcomer
  • *
  • Posts: 4
Re: Running into RC file problems
« Reply #1 on: November 05, 2005, 06:19:03 am »
I think you need the .NET 1.1 stuff (.NET Framework SDK Version 1.1   and    Microsoft .NET Framework Version 1.1 Redistributable Package). Once you get that installed I think you will find the rc.exe in C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322.  So add that to your path, restart Code::Blocks, and you're good to go.    I think....

[Edit]  I was a very tired when I wrote the above (at least that's my excuse). The RC.Exe file is actually in the Platform SDK \Bin directory. When you installed the platform SDK you probably did not opt to have it alter the environment variables (the default). The easy thing to do is to uninstall the Platform SDK and reinstall and have it alter the environment variables. Or you can add "C:\Program Files\Microsoft Platform SDK\Bin" to the path manually. I figured there would be other environment variables that needed to be setup as well so I just did the reinstall.

Adding the .NET framework path fixes the problem:
LINK : fatal error LNK1158: cannot run 'cvtres.exe'
« Last Edit: November 05, 2005, 08:22:04 pm by Bill »

Offline mandrav

  • Project Leader
  • Administrator
  • Lives here!
  • *****
  • Posts: 4315
    • Code::Blocks IDE
Re: Running into RC file problems
« Reply #2 on: November 05, 2005, 09:59:26 am »
Just press "Auto-detect" in the "Programs" page of the MS compiler options and it 'll set up the additional paths that are needed.
Be patient!
This bug will be fixed soon...


  • Guest
Re: Running into RC file problems
« Reply #3 on: November 06, 2005, 04:19:41 am »
Thanks for the help. I installed the .NET stuff and moved RC.exe to my C++ Toolkit's bin directory. It spat out some errors from the .rc file, but I just commented stuff out and then it compiled. ( :D ) So, thanks.