Author Topic: Multi-monitor problems. Toolbars disappeared and can't get them back!  (Read 19854 times)

Offline 1gpman

  • Single posting newcomer
  • *
  • Posts: 4
Hi all,

I've recently started using Code::Blocks with a second monitor on Windows XP and have come across many problems trying to position the Messages panel among others on the second screen.  It's difficult to place them near the top of the screen without them trying to dock with the main window on the first screen.  And when i do manage to position them where I want, under certain situations they leap out of place.  I mention this as it may in some way cause a more serious problem that just happened:

The "Code Completion", "Compiler", "Incremental Search" and "Thread Search" toolbars all disappeared without warning.  At the moment they disappeared, I was coding, not adjusting toolbars or window positions.  I managed to "find" the Code Completion and Compiler toolbars by restoring the main window and stretching it across both screens.  I then found the two toolbars way off to the right.  But I cant find the other two toolbars.

So my biggest problem right now is that I'd like to get the Incremental Search and Thread Search toolbars back again.  I've tried moving things around, expanding windows, enabling/disabling other toolbars, and even manually editing "default.conf" inside Application Data\codeblocks.

Other than reinstalling the whole thing, I'm out of ideas.  Any advice?  Thanks very much.

Codie

Offline jens

  • Administrator
  • Lives here!
  • *****
  • Posts: 7255
You can delete the current perspective under "View -> Perspectives -> Delete current".

Offline 1gpman

  • Single posting newcomer
  • *
  • Posts: 4
The problem is there on the default profile too unfortunately so I doubt deleting my custom profiles will help.

To give you an update, all the toolbars have magically appeared on one of my view profiles (not the default one) and I have no idea what made them re-appear.  Again, at the time I wasn't adjusting toolbars or windows, it may have happened as a result of me simply minimising and re-maximising Code::Blocks though.  It's completely inconsistent and bizzare.

Offline 1gpman

  • Single posting newcomer
  • *
  • Posts: 4
Where I say "profile" I meant "perspective"

Offline jens

  • Administrator
  • Lives here!
  • *****
  • Posts: 7255
You can also delete the default profile (a new one will be created from scratch) or look int "View -> Toolbars" whether the missing toolbars are unchecked accidently.

Offline 1gpman

  • Single posting newcomer
  • *
  • Posts: 4
Thanks jens.

I can imagine that deleting all perspectives would have done the trick.

I actually solved it by essentially copying the perspective that corrected itself to the others, then re-doing their adjustments.