Author Topic: _ZTI17wxScrollingDialog undefined from build of r6187  (Read 5949 times)

Offline sschlesier

  • Single posting newcomer
  • *
  • Posts: 3
_ZTI17wxScrollingDialog undefined from build of r6187
« on: March 11, 2010, 11:29:23 pm »
I just built C::B for the first time today.  Building from the svn HEAD would complete without errors but when running codeblocks it would immediately exit with an error complaining of undefined symbol _ZTI17wxScrollingDialog.

It seems one of the paths in src/src/Makefile.am has a '\' where it should have a '/'.  The patch below allowed me to make a functioning build of codeblocks.

--- src/src/Makefile.am   (revision 6187)
+++ src/src/Makefile.am   (working copy)
@@ -5,7 +5,7 @@
          -I$(top_srcdir)/src/include \
          -I$(top_srcdir)/src/include/scripting/include \
          -I$(top_srcdir)/src/include/scripting/sqplus \
-         -I$(top_srcdir)/src/include\mozilla_chardet
+         -I$(top_srcdir)/src/include/mozilla_chardet
 
 if CODEBLOCKS_LINUX
 AM_CPPFLAGS = -DENABLE_BINRELOC -DAPP_PREFIX="\"@prefix@\""



Offline killerbot

  • Administrator
  • Lives here!
  • *****
  • Posts: 5506
Re: _ZTI17wxScrollingDialog undefined from build of r6187
« Reply #1 on: March 11, 2010, 11:32:51 pm »
applied the fix, thanks for the feedback :-)

Offline sschlesier

  • Single posting newcomer
  • *
  • Posts: 3
Re: _ZTI17wxScrollingDialog undefined from build of r6187
« Reply #2 on: March 12, 2010, 01:18:59 am »
Hmmm,

On further inspection that patch does not fix my problem(it seemed odd that it would), though I am still confident that the backslash was incorrect.

What I have found is after completing a make,

The shell script src/src/codeblocks and the program src/src/.libs/lt-codeblocks can launch C::B succesfully, but src/src/.libs/codeblocks and /usr/share/bin/codeblocks both complain of the undefined wxScrollingDialog symbol.

I haven't figured this out yet.  Any hints would be appreciated.

Offline Jenna

  • Administrator
  • Lives here!
  • *****
  • Posts: 7255
Re: _ZTI17wxScrollingDialog undefined from build of r6187
« Reply #3 on: March 13, 2010, 02:46:15 pm »
What's the output of ldd <prefix>/bin/codeblocks | grep libcodeblocks ?
Replace <prefix> with the prefix you used when running ./configure .

Please post the output and the prefix.

Offline sschlesier

  • Single posting newcomer
  • *
  • Posts: 3
Re: _ZTI17wxScrollingDialog undefined from build of r6187
« Reply #4 on: March 15, 2010, 07:36:18 am »
I removed everything and rebuilt following the instructions from the wiki instead of the BUILD file.  It worked this time, though I'm not sure what the difference is.

It is probably a good idea to mention the wiki instructions in the BUILD file as the wiki is much more thorough.