Author Topic: Compiler not found  (Read 7218 times)

the_drow

  • Guest
Compiler not found
« on: May 24, 2009, 05:08:09 am »
I configured MinGW to Code::Blocks correctly.
I also checked that it works using the command line.
I for some reason can't compile with any compiler at all.
Not even with VC++.
Is this a known issue?
Does anyone knows how to solve it?
This is the error I'm getting:

    Static library - MinGW RELEASE" uses an invalid compiler [YOUR ANSWER IS ALREADY THERE. SEARCH THE FORUMS!]. Skipping... Nothing to be done.


Offline MortenMacFly

  • Administrator
  • Lives here!
  • *****
  • Posts: 9613
Re: Compiler not found
« Reply #1 on: May 25, 2009, 07:07:33 am »
I configured MinGW to Code::Blocks correctly.
[...]
Static library - MinGW RELEASE" uses an invalid compiler [YOUR ANSWER IS ALREADY THERE. SEARCH THE FORUMS!]. Skipping... Nothing to be done.
Both cannot be true. C::B complains like that if it cannot find the compiler's executables. So you did one of the following wrong:
1.) You did not setup the tool chain path's correctly
2.) You did not setup the names of the executables correctly
3.) You did forget to e.g. install the G++ compiler for MinGW/GCC. Notice that this compiler suite is splitted into many parts: One for C, one for C++, one for Fortran, one for binutils etc...

(Btw: in newer versions the error message is more  more descriptive.)

Anyways: Please: next time search the forums before you post. This has been answered many times. We are usually locking such topics as they violate our forum rules. But as you have posted the first time I gave you this hint.
Compiler logging: Settings->Compiler & Debugger->tab "Other"->Compiler logging="Full command line"
C::B Manual: http://www.codeblocks.org/docs/main_codeblocks_en.html
C::B FAQ: http://wiki.codeblocks.org/index.php?title=FAQ

Offline flem

  • Single posting newcomer
  • *
  • Posts: 2
Re: Compiler not found
« Reply #2 on: January 31, 2010, 07:47:09 pm »
i have searched the forums and i can't find anything like this. the FAQs aren't any better. can u give me a link or something to go off of? Please?
« Last Edit: January 31, 2010, 07:57:37 pm by flem »
my friends call me
 /-------------------------\
| ###  #      ###  #      #  |
| #      #      #      ##  ##  |
| ##    #      ##    #  #  #  |
| #      #      #      #      #  |
| #      ###  ###  #      #  |
 \-------------------------/

Offline koso

  • Multiple posting newcomer
  • *
  • Posts: 58
Re: Compiler not found
« Reply #3 on: January 31, 2010, 08:08:32 pm »
Check, if compiler executables are set properly: http://www.ogre3d.org/wiki/index.php/Code_Blocks_Compiler_Setup
And try to test it with some "hello world" program, so you eliminate problems with project target settings.

Offline flem

  • Single posting newcomer
  • *
  • Posts: 2
Re: Compiler not found
« Reply #4 on: February 02, 2010, 12:38:14 am »
that worked thank you!
my friends call me
 /-------------------------\
| ###  #      ###  #      #  |
| #      #      #      ##  ##  |
| ##    #      ##    #  #  #  |
| #      #      #      #      #  |
| #      ###  ###  #      #  |
 \-------------------------/