Author Topic: Invaild Compiler.  (Read 2980 times)

NorthNinja

  • Guest
Invaild Compiler.
« on: October 25, 2009, 07:42:57 am »
I just recently decided to start learning C++ for fun, and so I bought the "C++ All-In-One For Dummies" book. Inside it told me to download the Code::Blocks program. After doing this and running the program, I created a Console Application. I kept all the settings default, and proceed to press the build button.

Thats when I got this message:

Code
"Hello - Debug" uses an invalid compiler [YOUR ANSWER IS ALREADY THERE. SEARCH THE FORUMS!]. Skipping...
Nothing to be done.

(P.S. Hello is the file name I was using)

Since, I am literally new at this, I was wondering how I would get past this. The example and directions in the book told me I would get a message saying: ""0 Warnings 0 Errors" in the build log.

Any suggestions? Thanks in advance.

Offline jens

  • Administrator
  • Lives here!
  • *****
  • Posts: 7255
Re: Invaild Compiler.
« Reply #1 on: October 25, 2009, 08:05:17 am »
Any suggestions? Thanks in advance.

Search the forum for "invalid compiler [YOUR ANSWER IS ALREADY THERE. SEARCH THE FORUMS!]" and you get the answer (no compiler installed or incorrect toolchain).

In generally search before asking, if you do not learn to try to find solutions for your problems yourself, you will never be able to do any programming seriously.

To learn how and where to ask you should read this site carefully.

Offline darvon

  • Single posting newcomer
  • *
  • Posts: 6
Re: Invaild Compiler.
« Reply #2 on: October 25, 2009, 05:30:19 pm »
Hello NorthNinja.

I am also on Dummies book and am about 12 hours in front of you.

I had exact same problem.  I then made the problem more complicated and someone here solved it.



First search for the file:

mingw32-g++.exe

it should be in a bin folder


Next go into CodeBlocks and go to

Settings
Compiler and Debugger
Toolchain executables Tab


Set the Compiler Installation Directory to the folder in which the above bin folder is located.


For me that was

C:\Program Files\CodeBlocks\MinGW

OK it and that should change your settings to find your compiler.

Good Luck.


« Last Edit: October 25, 2009, 06:03:28 pm by darvon »