Author Topic: It says libgmp-3.dll is missing when creating/opening a project  (Read 8858 times)

Divider

  • Guest
Hi everybody,

I have troubles using code::blocks, I installed the MinGW Version of cb but when I create a new project or load an existing one, then i get a MessageBox,

title : cc1plus.exe - Component not found

content: The application couldnt run because libgmp-3.dll wasn't found.

I already tried to put this dll everywhere but it seems not to work. I tried to reinstall cb but still no chance. Anybody knows how to fix that? I didnt do anything except reinstalling it once or twice.

Thanks a lot.

Offline stahta01

  • Lives here!
  • ****
  • Posts: 7070
    • My Best Post
Re: It says libgmp-3.dll is missing when creating/opening a project
« Reply #1 on: July 06, 2009, 11:02:23 pm »
The problem is almost defiantly in the MinGW Compiler.
What is your OS?
Which version of MinGW?
GCC Version?

If using Vista, you need to upgrade to an newer version of 3.4.5 MinGW GCC; the one shipped with Code::Blocks is NOT Vista Compatible.

Tim S
C Programmer working to learn more about C++ and Git.
On Windows 7 64 bit and Windows 10 32 bit.
On Debian Stretch, compiling CB Trunk against wxWidgets 3.0.
--
When in doubt, read the CB WiKi FAQ. http://wiki.codeblocks.org

Divider

  • Guest
Re: It says libgmp-3.dll is missing when creating/opening a project
« Reply #2 on: July 06, 2009, 11:44:29 pm »
Thank you really much, didnt notice that so i just copied the newest version that i already had on the computer into the cb folder, now it works.