Author Topic: rsh cmds to Unix  (Read 2519 times)

Offline srins

  • Single posting newcomer
  • *
  • Posts: 8
rsh cmds to Unix
« on: June 18, 2009, 12:17:43 am »
I have a rather unusual problem.  I am hoping someone can point me right direction resolving the issue.

CB 8.02 REV 5602 running on WIN XP
The C++ source code repository is mounted on HP UX servers (Project Development is based on Unix platforms)
Unix source directories are mounted on Windows PC as “drives”
CB has a view of the “drive” and source code underneath it
A save on the file in CB editor actual saves the file on Unix server
Liked CB IDE for its versatility, plug-ins and have been using CB more than 2 years now

I would like to take my CB setup one step further and have it actually run SCCS commands on Unix and “checkout” source file from repository
I would like to be able “Bless/Delta” back into repository directly from CB

So far I have tried this:
I have tried to get shell extensions and/or Configure-Tools to do this for me.
Essentially, have the shell extension/Tools to run “rsh” to unix server and run “checkout” command with full directory name and file.
Similarly the shell extension/Tools to run “rsh” to unix server and run “Bless/Delta back” command with full directory name and file.

I quickly realized that $mpath, $file, $relfile, ${ACTIVE_EDITOR_FILENAME} & others provide the path of the file in windows format (with back slash separator – for e.g. X: \src\common\subsystem\file.C).
When Unix ‘K’ shell gets this, it evaluates back slash (“\”) and strips it completely. So, in-effect it tries run “checkout” command on  X:srccommonsubsystemfile.C.
Obviously this will not work. I am stuck at this point and running out of ideas.

Any kind of lead/assist/plug-in/enhancements would be appreciated.
If can get this to work it would be cool and really convenient.