Author Topic: [SOLVED] Debugger fails  (Read 3886 times)

Offline bmateusz

  • Single posting newcomer
  • *
  • Posts: 4
[SOLVED] Debugger fails
« on: May 30, 2009, 09:43:55 pm »
I am developing an application. It works both in Debug and Release mode perfectly, but when I want to debug, it fails to start:
Building to ensure sources are up-to-date
Build succeeded
Selecting target:
Adding source dir: C:\OpenGL\My\
Adding source dir: C:\OpenGL\My\
Adding file: bin\Debug\My.exe
Starting debugger:
Registered new type: wxString
Registered new type: STL String
Registered new type: STL Vector
Setting breakpoints
Debugger name and version: GNU gdb
Child process PID: 3868
Debugger finished with status 1
The debugger stops with error: gdb.exe has encountered a problem and needs to close. We apologize for the inconvenience.

I don't know what to do, or what causes it. I can debug other applications without any problems, only that one seems broken.
Do you have any idea?

I know that this information I gave is nothing, but I really don't know what to do with it.

Got some additional log of debugger, maybe that helps.
PATH=.;C:\CodeBlocks\MinGW\bin;C:\Program Files\PC Connectivity Solution\;C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;C:\OpenGL\Zip\Cg\bin;C:\Program Files\Common Files\Adobe\AGL;
Command-line: C:\CodeBlocks\MinGW\bin\gdb.exe -nx -fullname  -quiet -args bin/Debug/My.exe
Working dir : C:\OpenGL\My\
> set prompt >>>>>>cb_gdb:
(gdb) >>>>>>cb_gdb:
> show version
GNU gdb
Copyright (C) 2007 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "i686-pc-mingw32".
> set confirm off
> set width 0
> set height 0
> set breakpoint pending on
> set print asm-demangle on
> set unwindonsignal on
> set debugevents on
> set new-console on
> set disassembly-flavor att
> directory C:/OpenGL/My/
> run
gdb: win32_init_thread_list
« Last Edit: May 31, 2009, 03:40:08 am by bmateusz »

Offline bmateusz

  • Single posting newcomer
  • *
  • Posts: 4
Re: Debugger fails
« Reply #1 on: May 30, 2009, 10:42:23 pm »
Hmm, solved, but very strange  :?
I removed all FTGL ( codes, and the debug works. Very very strange.
But it's not CodeBlocks' fault :)

For the community. The problem was with dynamic linking, I linked FTGL statically (first ftgl_static, after that freetype), then I had no problems.  :)
« Last Edit: May 31, 2009, 03:39:41 am by bmateusz »