Author Topic: The 02 February 2009 build (5432) is out.  (Read 53047 times)

Offline jens

  • Administrator
  • Lives here!
  • *****
  • Posts: 7265
    • Jens' unofficial debian-repository for the Code::Blocks - IDE
Re: The 02 February 2009 build (5432) is out.
« Reply #30 on: February 05, 2009, 12:35:43 pm »
Hi guys,

Thank you for the efforts making the CodeBlocks perfect.

I've found one bug here, ->
The CodeBlocks can't run more than one instance even though the option (Allow only one running instance) has been removed.
Uncheck "Use an already running instance instead of starting a new one (if possible)" also, or start C::B with parameter "-ni" (linux) or "-nd" (windows).

Offline Grom

  • Almost regular
  • **
  • Posts: 206
Re: The 02 February 2009 build (5432) is out.
« Reply #31 on: February 06, 2009, 12:15:52 am »
When we are going to have a new relize with automatic update? :?
gcc+winXP+suse.

Offline jens

  • Administrator
  • Lives here!
  • *****
  • Posts: 7265
    • Jens' unofficial debian-repository for the Code::Blocks - IDE
Re: The 02 February 2009 build (5432) is out.
« Reply #32 on: February 06, 2009, 12:23:58 am »
When we are going to have a new relize with automatic update? :?

Possibly when you provide a patch for this and it get accepted.

Offline dmoore

  • Developer
  • Lives here!
  • *****
  • Posts: 1576
Re: The 02 February 2009 build (5432) is out.
« Reply #33 on: February 06, 2009, 12:38:12 am »
When we are going to have a new relize with automatic update? :?

get on a debian system and you can have automatic updates of every nightly. :)

Offline Sunyata

  • Single posting newcomer
  • *
  • Posts: 5
Re: The 02 February 2009 build (5432) is out.
« Reply #34 on: February 06, 2009, 01:59:15 am »
I didn't notice that option.... :oops: Now it works. Thank you very much ! :D

Hi guys,

Thank you for the efforts making the CodeBlocks perfect.

I've found one bug here, ->
The CodeBlocks can't run more than one instance even though the option (Allow only one running instance) has been removed.
Uncheck "Use an already running instance instead of starting a new one (if possible)" also, or start C::B with parameter "-ni" (linux) or "-nd" (windows).

Offline ollydbg

  • Developer
  • Lives here!
  • *****
  • Posts: 5230
  • OpenCV and Robotics
    • Chinese OpenCV forum moderator
Re: The 02 February 2009 build (5432) is out.
« Reply #35 on: February 06, 2009, 02:17:09 pm »
Change the management panel problem?
snap1:
If I want to view the "Symbols" panel. I should firstly press the right triangle button.

snap2:
Then, the "Projects" panel is still active below. So I should click on the "Symbols" panel stub to view it.

snap3:
The "symbols" was active.

My question: I need to press twice to change the panel. Why not just press once on right triangle button to change to the next panel directly to avoid the extra click?


[attachment deleted by admin]
If some piece of memory should be reused, turn them to variables (or const variables).
If some piece of operations should be reused, turn them to functions.
If they happened together, then turn them to classes.

Offline Grom

  • Almost regular
  • **
  • Posts: 206
Re: The 02 February 2009 build (5432) is out.
« Reply #36 on: February 06, 2009, 06:39:19 pm »
What about new relise? Do you have any road map?
gcc+winXP+suse.

Offline XayC

  • Multiple posting newcomer
  • *
  • Posts: 94
Re: The 02 February 2009 build (5432) is out.
« Reply #37 on: February 06, 2009, 08:09:07 pm »
Hi guys,

Thank you for the efforts making the CodeBlocks perfect.

I've found one bug here, ->
The CodeBlocks can't run more than one instance even though the option (Allow only one running instance) has been removed.
Uncheck "Use an already running instance instead of starting a new one (if possible)" also, or start C::B with parameter "-ni" (linux) or "-nd" (windows).

I think this should be considered as a bug.
Is it intended to have the DDE server blocking a second instance of C:B? Is there any good reason for it?

I remember it was working before the changes to the DDE server (i.e. Code::Blocks 8.02), and those changes were made to fix other problems.
Regards, XayC

Offline jens

  • Administrator
  • Lives here!
  • *****
  • Posts: 7265
    • Jens' unofficial debian-repository for the Code::Blocks - IDE
Re: The 02 February 2009 build (5432) is out.
« Reply #38 on: February 06, 2009, 09:22:25 pm »
Hi guys,

Thank you for the efforts making the CodeBlocks perfect.

I've found one bug here, ->
The CodeBlocks can't run more than one instance even though the option (Allow only one running instance) has been removed.
Uncheck "Use an already running instance instead of starting a new one (if possible)" also, or start C::B with parameter "-ni" (linux) or "-nd" (windows).

I think this should be considered as a bug.
Is it intended to have the DDE server blocking a second instance of C:B? Is there any good reason for it?

I remember it was working before the changes to the DDE server (i.e. Code::Blocks 8.02), and those changes were made to fix other problems.
Regards, XayC

The DDE-Server on windows still works as before, if you uncheck "Use an already running instance instead of starting a new one (if possible)", at least on my system.
So I think it's not a bug.

Maybe the option can be disabled by default, but that's more or less a matter of taste.

Offline XayC

  • Multiple posting newcomer
  • *
  • Posts: 94
Re: The 02 February 2009 build (5432) is out.
« Reply #39 on: February 06, 2009, 09:27:53 pm »

The DDE-Server on windows still works as before, if you uncheck "Use an already running instance instead of starting a new one (if possible)", at least on my system.
So I think it's not a bug.

Maybe the option can be disabled by default, but that's more or less a matter of taste.


Yes, you are right. I was confusing that option with the old "allow only one instance". :oops:
Thanks, for pointing that.

Regards, XayC

Offline emptymind

  • Single posting newcomer
  • *
  • Posts: 5
Re: The 02 February 2009 build (5432) is out.
« Reply #40 on: February 09, 2009, 04:43:15 pm »
In new build don't work commands from custom makefile. Bug?

Offline jens

  • Administrator
  • Lives here!
  • *****
  • Posts: 7265
    • Jens' unofficial debian-repository for the Code::Blocks - IDE
Re: The 02 February 2009 build (5432) is out.
« Reply #41 on: February 09, 2009, 05:46:16 pm »
In new build don't work commands from custom makefile. Bug?
What exactly do you try, and what does not work ?

Custom makefile using has improved a lot and output might have changed.
See this thread: http://forums.codeblocks.org/index.php/topic,9966.0.html.

You will only see the commands run by make, if you set "Compiler logging" to "full commandline", and a build is only done, if it is needed.
By default you only see messages like "Using makefile: makefile.unx" or "Nothing to be done".

Offline emptymind

  • Single posting newcomer
  • *
  • Posts: 5
Re: The 02 February 2009 build (5432) is out.
« Reply #42 on: February 09, 2009, 06:57:56 pm »
When silent build field is empty but field make build/target = make all makefile don't run
Output (using rebuid):
-------------- Clean: Release in USB_Freq ---------------

Cleaned "USB_Freq - Release"

-------------- Build: Release in USB_Freq ---------------

Using makefile: makefile
Done.

When i type in silent build make all  rebuild feature work correctly.

Offline jens

  • Administrator
  • Lives here!
  • *****
  • Posts: 7265
    • Jens' unofficial debian-repository for the Code::Blocks - IDE
Re: The 02 February 2009 build (5432) is out.
« Reply #43 on: February 09, 2009, 08:40:15 pm »
To see the makefile commands, you have to change "Settings -> Compiler and debugger... -> Global compiler settings -> <the compiler you use> -> Other settings -> Compiler logging:" to "Full command line".

Custom makefiles now have outputs like "normal" compilation.

The build without output ("Task description") is done with the silent build command.

Offline emptymind

  • Single posting newcomer
  • *
  • Posts: 5
Re: The 02 February 2009 build (5432) is out.
« Reply #44 on: February 09, 2009, 09:40:55 pm »
I see. Thank you for help.