Author Topic: Trying to Run Hello World in Debug mode  (Read 9951 times)

Offline jens

  • Administrator
  • Lives here!
  • *****
  • Posts: 7265
    • Jens' unofficial debian-repository for the Code::Blocks - IDE
Re: Trying to Run Hello World in Debug mode
« Reply #15 on: December 31, 2008, 09:55:11 pm »
Globally compiler settings are normally not needed,
project wide settings are good for things like "-Wall" or "-fexceptions" that are needed by all targets (for example debug and release),
the target settings are used to optimize targets, the "-g" or "-pg" switch only makes sense for the debug target, all optimization-switches ("-Ox") or "-s" only make sense for targets that are not debug targets.

Offline Ed997

  • Multiple posting newcomer
  • *
  • Posts: 12
Re: Trying to Run Hello World in Debug mode
« Reply #16 on: January 02, 2009, 10:32:47 pm »
3-17 pm  01-02-09

   Jens,

   I am afraid I was having a brain cramp and did not realize there was now a Page 2 to the thread   :oops: (and you had responded a couple days ago).

   Thanks, I will digest what you said later today and respond.   Tx much. Ed

Offline Ed997

  • Multiple posting newcomer
  • *
  • Posts: 12
Re: Trying to Run Hello World in Debug mode
« Reply #17 on: January 02, 2009, 11:43:18 pm »

4-30 pm  01-02-09

Ok, this makes sense.  Though I do not know where I am adding the

-Wall switch as no box is checked in "Settings/Compiler and

Debugger / Global Compiler Settings / Compiler Flags Tab ".

And the -wall box is not checked in either the Debug or Release

build targets ....... in Project / Build Options Compiler-Flag Tab.

But at this point -Wall is fine with me.

I guess I am done with this thread (new ones around the corner !).

Thanks .....All,

Regards, Ed

Offline dje

  • Lives here!
  • ****
  • Posts: 683
Re: Trying to Run Hello World in Debug mode
« Reply #18 on: January 03, 2009, 10:53:17 am »
Hi Ed,

do you think it is necessary to put a timestamp at the beginning of all your posts whereas it is already written in the post header with the right timezone ?

Dje

[attachment deleted by admin]