Author Topic: Trouble shoot with codeblocks under Ubuntu 8.10 !  (Read 5493 times)

Offline WILL

  • Multiple posting newcomer
  • *
  • Posts: 25
Trouble shoot with codeblocks under Ubuntu 8.10 !
« on: December 20, 2008, 09:26:40 am »
I just got some automatic updates from Ubuntu 8.10 but then I was unable to use CB anymore. Then I tried to reinstall CB follow this link : http://www.futuredesktop.org/codeblocks_on_ubuntu_8.04.html
Then from the terminal I got these error messages :
Quote
sudo apt-get install codeblocks
bash: codeblocks: command not found
[email protected]:~$ sudo apt-get install codeblocks
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  codeblocks: Depends: codeblocks-common (= 8.02svn5340-0ubuntu1~feisty) but it is not going to be installed
              Recommends: codeblocks-contrib (= 8.02svn5340-0ubuntu1~feisty) but it is not going to be installed
E: Broken packages

What is the problem that I'm having ? Anyone could help me out ? Thanks in advance !

« Last Edit: December 20, 2008, 09:45:35 am by WILL »

Offline jens

  • Administrator
  • Lives here!
  • *****
  • Posts: 7265
    • Jens' unofficial debian-repository for the Code::Blocks - IDE
Re: Trouble shoot with codeblocks under Ubuntu 8.10 !
« Reply #1 on: December 20, 2008, 10:11:13 am »
Something seems to be messed up with your configuration or with the package dependencies.

If you install for intrepid ibex, you should not have dependencies against feisty.
After looking in the package pool and the "Packages.gz"-file the packages for intrepid (8.10) seem to be the same like the packages for hardy (8.04).

Make sure you have the correct line in "/etc/apt/sources.list", most likely
Code: [Select]
deb http://lgp203.free.fr/ubuntu/ intrepid universe.

You can also try my repo (see sig), but packages are normaly at the same revision then last "official" nightly of C::B (see http://forums.codeblocks.org/index.php/board,20.0.html.
The packages in my repo are build in a debian edge chroot, but are widely used on ubuntu-systems too.

Offline pasgui

  • Almost regular
  • **
  • Posts: 165
    • LGP
Re: Trouble shoot with codeblocks under Ubuntu 8.10 !
« Reply #2 on: December 20, 2008, 01:28:36 pm »
I have updated, version 5340 (http://lgp203.free.fr/spip/spip.php?article1) the repo with the last structure provided by Jens into the trunk. To update from the version 5322 or older, you need to uninstall Codeblocks and after try:
Code: [Select]
sudo apt-get install libcodeblocks0 codeblocks libwxsmithlib0 codeblocks-contrib-common codeblocks-contrib
Let's me now if you succeed or not !

Best regards, pasgui

mopslik

  • Guest
Re: Trouble shoot with codeblocks under Ubuntu 8.10 !
« Reply #3 on: December 20, 2008, 06:14:20 pm »
I also got the auto-update notification in my system tray yesterday evening, and I'm having the same troubles installing Code::Blocks. Worked fine for months, but now is borked. I'm using Ubuntu 7.10. Here's the output doing a plain old apt-get install codeblocks (the old version has been removed):

Code: [Select]
The following packages have unmet dependencies:
  codeblocks: Depends: codeblocks-common (= 8.02svn5340-0ubuntu1~feisty) but it is not going to be installed
E: Broken packages

And here's the code when trying the above suggestion, after apt-get update:

Code: [Select]
The following packages have unmet dependencies:
  codeblocks: Depends: codeblocks-common (= 8.02svn5340-0ubuntu1~feisty) but it is not going to be installed
  codeblocks-contrib: Depends: codeblocks-contrib-common (= 8.02svn5340-0ubuntu1~feisty) but 8.02svn5340-0ubuntu1~hardy is to be installed
  codeblocks-contrib-common: Conflicts: codeblocks-contrib (< 8.02svn5340-0ubuntu1~hardy) but 8.02svn5340-0ubuntu1~feisty is to be installed
E: Broken packages

Offline pasgui

  • Almost regular
  • **
  • Posts: 165
    • LGP
Re: Trouble shoot with codeblocks under Ubuntu 8.10 !
« Reply #4 on: December 20, 2008, 09:52:10 pm »
It should work now. Sorry for the trouble.

Best regards, pasgui

mopslik

  • Guest
Re: Trouble shoot with codeblocks under Ubuntu 8.10 !
« Reply #5 on: December 21, 2008, 01:47:42 am »
No worries, works like a charm now. Thanks for looking after that.  Cheers!

Offline WILL

  • Multiple posting newcomer
  • *
  • Posts: 25
Re: Trouble shoot with codeblocks under Ubuntu 8.10 !
« Reply #6 on: December 21, 2008, 08:58:11 am »
Sorry guys for my English, but I couldn't understand how mopslik and pasgui could solve the problem ?
From here :
Quote
I also got the auto-update notification in my system tray yesterday evening, and I'm having the same troubles installing Code::Blocks. Worked fine for months, but now is borked. I'm using Ubuntu 7.10. Here's the output doing a plain old apt-get install codeblocks (the old version has been removed):

Code:

The following packages have unmet dependencies:
  codeblocks: Depends: codeblocks-common (= 8.02svn5340-0ubuntu1~feisty) but it is not going to be installed
E: Broken packages


And here's the code when trying the above suggestion, after apt-get update:

Code:

The following packages have unmet dependencies:
  codeblocks: Depends: codeblocks-common (= 8.02svn5340-0ubuntu1~feisty) but it is not going to be installed
  codeblocks-contrib: Depends: codeblocks-contrib-common (= 8.02svn5340-0ubuntu1~feisty) but 8.02svn5340-0ubuntu1~hardy is to be installed
  codeblocks-contrib-common: Conflicts: codeblocks-contrib (< 8.02svn5340-0ubuntu1~hardy) but 8.02svn5340-0ubuntu1~feisty is to be installed
E: Broken packages
You got the same error messages like I did but then how could you solve it ?
@Jen : Is it your signature ? http://apt.jenslody.de/-the one that you mentioned above ? Since I have to work the whole day, I haven't had time to try it, I will try and reply as soon as I can. Thanks a lot for your help !

Offline jens

  • Administrator
  • Lives here!
  • *****
  • Posts: 7265
    • Jens' unofficial debian-repository for the Code::Blocks - IDE
Re: Trouble shoot with codeblocks under Ubuntu 8.10 !
« Reply #7 on: December 21, 2008, 10:49:30 am »
@Jen : Is it your signature ? http://apt.jenslody.de/-the one that you mentioned above ? Since I have to work the whole day, I haven't had time to try it, I will try and reply as soon as I can. Thanks a lot for your help !

Without th "-the" it's correct (http://apt.jenslody.de/) .

But you should try pasgui's repo first.

If I understand right, there was something wrong with his control-file, that leads to wrong dependencies, you should try an apt-get update and a reinstall of codeblocks first, before you use mine.

Pasgui's repo is build on and for ubuntu, mine is build on and for debian. There should normally be any problem with that, but I cannot guarantee that it works in all cases.

Never change a running system !

Offline WILL

  • Multiple posting newcomer
  • *
  • Posts: 25
Re: Trouble shoot with codeblocks under Ubuntu 8.10 !
« Reply #8 on: December 22, 2008, 07:55:23 am »
Thanks Jens, got it worked :D ! Just reinstall cb then it work normally ! I'd appreciate that ;) !

Offline WILL

  • Multiple posting newcomer
  • *
  • Posts: 25
Re: Trouble shoot with codeblocks under Ubuntu 8.10 !
« Reply #9 on: January 07, 2009, 11:53:08 am »
I got a new problem :( ! I've just bought a new PC then I tried to install CB but the same error message occurred :( ! Now I haven't had CB installed so how could I reinstall it to solve the problem ? Any help ?

Offline MortenMacFly

  • Administrator
  • Lives here!
  • *****
  • Posts: 9496
Re: Trouble shoot with codeblocks under Ubuntu 8.10 !
« Reply #10 on: January 07, 2009, 02:11:24 pm »
how could I reinstall it to solve the problem ?
...running the installer again?
Compiler logging: Settings->Compiler & Debugger->tab "Other"->Compiler logging="Full command line"
C::B Manual: http://www.codeblocks.org/docs/main_codeblocks_en.html
C::B FAQ: http://wiki.codeblocks.org/index.php?title=FAQ

Offline jens

  • Administrator
  • Lives here!
  • *****
  • Posts: 7265
    • Jens' unofficial debian-repository for the Code::Blocks - IDE
Re: Trouble shoot with codeblocks under Ubuntu 8.10 !
« Reply #11 on: January 07, 2009, 02:21:17 pm »
If you use my repo and "apt-get update" or any other package-manager (I prefer synaptic) all the dependencies should be set (and fullfilled) automatically.

If you install the .deb-files manually (from pasgui's repo) you have to install everything "dpkg" or "apt-get" wants (most likely some wxWidgets-packages).

I'm on windows at the moment, because I work at home today, so I can't tell you the packages needed for C::B.

Offline WILL

  • Multiple posting newcomer
  • *
  • Posts: 25
Re: Trouble shoot with codeblocks under Ubuntu 8.10 !
« Reply #12 on: January 08, 2009, 10:52:27 am »
Just work around, I used all the link follow your signature( Jens ) and it worked :D ! Thanks anyways ;) !