Author Topic: Wrong OS Build.  (Read 4147 times)

tk421

  • Guest
Wrong OS Build.
« on: December 06, 2008, 05:50:27 pm »
I am trying build an OS X application for wxWidgets on CodeBlocks 8.02 . I am running 10.5.5 Intel version. Every time I build with it a classic app is generated which is useless to me as I don't have classic and have no desire to target this platform. Is there something in Code::Blocks that causes this? :?
« Last Edit: December 06, 2008, 05:54:07 pm by tk421 »

Offline afb

  • Developer
  • Lives here!
  • *****
  • Posts: 884
Re: Wrong OS Build.
« Reply #1 on: December 07, 2008, 11:28:25 pm »
The "classic" app is with a resource fork so it can receive events when started up from the commandline...
/Developer/Tools/Rez -d __DARWIN__ -t APPL Carbon.r -o $(TARGET_OUTPUT_FILE)
The script in the wizard should be changed to make an application bundle instead, which is the alternative.

It's not really a Classic application but Carbon, so once you make the bundle structure it should be OK.
See http://wiki.wxwidgets.org/WxMac_Issues#Building_a_MacOSX_application_bundle for some details.
Eventually the wxWidgets wizard should do the same eleventeen mkdir/xml plist steps, that it does.
« Last Edit: December 07, 2008, 11:30:46 pm by afb »

tk421

  • Guest
Re: Wrong OS Build.
« Reply #2 on: December 08, 2008, 06:16:10 pm »
Thanks. I am made a little shell script to do the steps.

Eyeez84

  • Guest
Re: Wrong OS Build.
« Reply #3 on: April 22, 2010, 09:09:40 am »
I think Xtravo OS is designed to compete with Google Chrome OS before its release as Google Chrome OS is going to be the same what we have to offer infact better.