Author Topic: make install on non-standard directory  (Read 4117 times)

Offline charlie

  • Single posting newcomer
  • *
  • Posts: 7
make install on non-standard directory
« on: September 22, 2005, 11:53:39 am »
Hi!

I'm trying to build the latest cvs version of codeblocks. I ran:

1. ./configure --prefix=/home/karol/usr/codeblocks

2. make

and

3. make install

returns error:

make[4]: Entering directory `/mnt/suse/home/karol/var/cvs/codeblocks/src/sdk'
test -z "/home/karol/usr/codeblocks/lib" || mkdir -p -- "/home/karol/usr/codeblocks/lib"
 /bin/sh ../../libtool --mode=install /usr/bin/install -c  'libcodeblocks.la' '/home/karol/usr/codeblocks/lib/libcodeblocks.la'
libtool: install: error: cannot install `libcodeblocks.la' to a directory not ending in /usr/local/lib
make[4]: *** [install-libLTLIBRARIES] Error 1
make[4]: Leaving directory `/mnt/suse/home/karol/var/cvs/codeblocks/src/sdk'
make[3]: *** [install-am] Error 2
make[3]: Leaving directory `/mnt/suse/home/karol/var/cvs/codeblocks/src/sdk'
make[2]: *** [install-recursive] Error 1
make[2]: Leaving directory `/mnt/suse/home/karol/var/cvs/codeblocks/src/sdk'
make[1]: *** [install-recursive] Error 1
make[1]: Leaving directory `/mnt/suse/home/karol/var/cvs/codeblocks/src'
make: *** [install-recursive] Error 1

is it possible to install codeblocks in directory prefix other than /usr/local/?

Regards,
Charlie

Offline mandrav

  • Project Leader
  • Administrator
  • Lives here!
  • *****
  • Posts: 4291
    • Code::Blocks IDE
Re: make install on non-standard directory
« Reply #1 on: September 22, 2005, 12:42:55 pm »
You have already built codeblocks without specifying --prefix to configure (defaults to /usr/local).
Now you just re-ran configure with a new --prefix (and no compilation because it was already up-to-date) and expect it to work?

Anyway, I 've provided a custom target for this case.
Run "make clean-bins" and then "make". This will force relinking (only), taking into account the new prefix. "make install" should work afterwards...
Be patient!
This bug will be fixed soon...

Offline charlie

  • Single posting newcomer
  • *
  • Posts: 7
Re: make install on non-standard directory
« Reply #2 on: September 22, 2005, 01:18:26 pm »
OK. I ran "make clean-bin" and "make". After it "make install" worked fine. Thanks.
So I successfuly compiled CodeBlocks on gentoo,wxwidgets-2.6 and amd64 box.

Offline mandrav

  • Project Leader
  • Administrator
  • Lives here!
  • *****
  • Posts: 4291
    • Code::Blocks IDE
Re: make install on non-standard directory
« Reply #3 on: September 22, 2005, 01:32:50 pm »
Since you 're using gentoo, you might be interested in an ebuild floating around here (and tell us if it worked ok).
It's here.
Be patient!
This bug will be fixed soon...