Author Topic: new problemn on suse 64bit version!Thank you very much!  (Read 6155 times)

Offline zouyu

  • Single posting newcomer
  • *
  • Posts: 7
new problemn on suse 64bit version!Thank you very much!
« on: September 06, 2005, 10:02:11 am »
/usr/lib64/gcc-lib/x86_64-suse-linux/3.3.3/../../../../x86_64-suse-linux/bin/ld: skipping incompatible /usr/lib/libstdc++.so when searching for -lstdc++
/usr/lib64/gcc-lib/x86_64-suse-linux/3.3.3/../../../../x86_64-suse-linux/bin/ld: skipping incompatible /usr/lib/libstdc++.a when searching for -lstdc++
/usr/lib64/gcc-lib/x86_64-suse-linux/3.3.3/../../../../x86_64-suse-linux/bin/ld: skipping incompatible /usr/lib/libm.so when searching for -lm
/usr/lib64/gcc-lib/x86_64-suse-linux/3.3.3/../../../../x86_64-suse-linux/bin/ld: skipping incompatible /usr/lib/libm.a when searching for -lm
/usr/lib64/gcc-lib/x86_64-suse-linux/3.3.3/../../../../x86_64-suse-linux/bin/ld: skipping incompatible /usr/lib/libgcc_s.so when searching for -lgcc_s
/usr/lib64/gcc-lib/x86_64-suse-linux/3.3.3/../../../../x86_64-suse-linux/bin/ld: skipping incompatible /usr/lib/libpthread.so when searching for -lpthread
/usr/lib64/gcc-lib/x86_64-suse-linux/3.3.3/../../../../x86_64-suse-linux/bin/ld: skipping incompatible /usr/lib/libpthread.a when searching for -lpthread
/usr/lib64/gcc-lib/x86_64-suse-linux/3.3.3/../../../../x86_64-suse-linux/bin/ld: skipping incompatible /usr/lib/libc.so when searching for -lc
/usr/lib64/gcc-lib/x86_64-suse-linux/3.3.3/../../../../x86_64-suse-linux/bin/ld: skipping incompatible /usr/lib/libc.a when searching for -lc
/usr/lib64/gcc-lib/x86_64-suse-linux/3.3.3/../../../../x86_64-suse-linux/bin/ld: skipping incompatible /usr/lib/libgcc_s.so when searching for -lgcc_s
Compiling src/app.cpp...
src/resources/icons/app.xpm:2: warning: `char*app[44]' defined but not used
Compiling src/dlgabout.cpp...
Compiling src/dlgaboutplugin.cpp...
Compiling src/environmentsettingsdlg.cpp...
Compiling src/impexpconfig.cpp...
Compiling src/main.cpp...
Compiling src/prefix.c...
Compiling src/printdlg.cpp...
Compiling src/startherepage.cpp...
Linking executable devel/codeblocks.exe...
/usr/lib64/gcc-lib/x86_64-suse-linux/3.3.3/../../../../x86_64-suse-linux/bin/ld: skipping incompatible /usr/lib/libstdc++.so when searching for -lstdc++
/usr/lib64/gcc-lib/x86_64-suse-linux/3.3.3/../../../../x86_64-suse-linux/bin/ld: skipping incompatible /usr/lib/libstdc++.a when searching for -lstdc++
/usr/lib64/gcc-lib/x86_64-suse-linux/3.3.3/../../../../x86_64-suse-linux/bin/ld: skipping incompatible /usr/lib/libm.so when searching for -lm
/usr/lib64/gcc-lib/x86_64-suse-linux/3.3.3/../../../../x86_64-suse-linux/bin/ld: skipping incompatible /usr/lib/libm.a when searching for -lm
/usr/lib64/gcc-lib/x86_64-suse-linux/3.3.3/../../../../x86_64-suse-linux/bin/ld: skipping incompatible /usr/lib/libgcc_s.so when searching for -lgcc_s
/usr/lib64/gcc-lib/x86_64-suse-linux/3.3.3/../../../../x86_64-suse-linux/bin/ld: skipping incompatible /usr/lib/libpthread.so when searching for -lpthread
/usr/lib64/gcc-lib/x86_64-suse-linux/3.3.3/../../../../x86_64-suse-linux/bin/ld: skipping incompatible /usr/lib/libpthread.a when searching for -lpthread
/usr/lib64/gcc-lib/x86_64-suse-linux/3.3.3/../../../../x86_64-suse-linux/bin/ld: skipping incompatible /usr/lib/libc.so when searching for -lc
/usr/lib64/gcc-lib/x86_64-suse-linux/3.3.3/../../../../x86_64-suse-linux/bin/ld: skipping incompatible /usr/lib/libc.a when searching for -lc
/usr/lib64/gcc-lib/x86_64-suse-linux/3.3.3/../../../../x86_64-suse-linux/bin/ld: skipping incompatible /usr/lib/libgcc_s.so when searching for -lgcc_s
/usr/lib64/libwx_gtk2_core-2.5.so: undefined reference to `gtk_icon_theme_load_icon'
/usr/lib64/libwx_gtk2_core-2.5.so: undefined reference to `gtk_icon_theme_get_default'
/usr/lib64/libwx_gtk2_core-2.5.so: undefined reference to `gdk_display_get_default_cursor_size'
/usr/lib64/libwx_gtk2_core-2.5.so: undefined reference to `pango_font_family_is_monospace'
/usr/lib64/libwx_gtk2_core-2.5.so: undefined reference to `gtk_button_set_alignment'
/usr/lib64/libwx_gtk2_core-2.5.so: undefined reference to `gtk_entry_set_alignment'
/usr/lib64/libwx_gtk2_adv-2.5.so: undefined reference to `g_return_if_fail_warning'
collect2: ld returned 1 exit status
make: *** [devel/codeblocks.exe] Error 1

Offline zouyu

  • Single posting newcomer
  • *
  • Posts: 7
Re: new problemn on suse 64bit version!Thank you very much!
« Reply #1 on: September 09, 2005, 04:19:24 pm »
Please help me to soluve this problemn.
how to fix it. which package is associate with libwx_gtk2_core-2.5.so?


Thank you very much!!

Offline mandrav

  • Project Leader
  • Administrator
  • Lives here!
  • *****
  • Posts: 4291
    • Code::Blocks IDE
Re: new problemn on suse 64bit version!Thank you very much!
« Reply #2 on: September 09, 2005, 06:30:34 pm »
Try downloading codeblocks from CVS directly. It is now using autotools for building so it 'll be as simple as "./configure && make && make install" to get it working :)
Be patient!
This bug will be fixed soon...

Offline fiammy

  • Multiple posting newcomer
  • *
  • Posts: 46
    • Nebulagame
Re: new problemn on suse 64bit version!Thank you very much!
« Reply #3 on: September 13, 2005, 03:40:49 pm »
Ah! that's good news. I'll have a go at it this evening then. I've been trying to get it to work properly these last few days, but I was blocked again and again with problems... On to Automake!

Just a question : is there a reason for choosing automake and family, contrary to Scons?

Thanks

Offline takeshi miya

  • Lives here!
  • ****
  • Posts: 1487
Re: new problemn on suse 64bit version!Thank you very much!
« Reply #4 on: September 13, 2005, 10:41:53 pm »
RShadow was creating some SCons files

See here http://forums.codeblocks.org/index.php/topic,489.0.html and here http://forums.codeblocks.org/index.php/topic,525.0.html

However the autotools are more widely used, so they are the official supported ones (for now).

Offline fiammy

  • Multiple posting newcomer
  • *
  • Posts: 46
    • Nebulagame
Re: new problemn on suse 64bit version!Thank you very much!
« Reply #5 on: September 14, 2005, 06:12:04 pm »
I admit I'm not really a guru when it comes to automake and autoconf and configure, but there seem to be files missing. Or I didn't do it right.

Could somebody describe step by step what to do to get the Linux version working all right? I'm using SuSE 9.3 AMD64

Thanks,
David

Offline grv575

  • Official tester
  • Regular
  • ***
  • Posts: 381
Re: new problemn on suse 64bit version!Thank you very much!
« Reply #6 on: September 15, 2005, 05:56:35 am »
If you downloaded CVS files, then start with
./bootstrap
This sets up the autotools environment.

Offline fiammy

  • Multiple posting newcomer
  • *
  • Posts: 46
    • Nebulagame
Re: new problemn on suse 64bit version!Thank you very much!
« Reply #7 on: September 20, 2005, 05:08:54 pm »
Thanks. It seems that's normal behaviour for Autotools  :oops:

Well, I've learned something new :-)

Thanks