Author Topic: help in linking  (Read 1906 times)

jui

  • Guest
help in linking
« on: August 30, 2008, 09:31:10 pm »
-------------- Build: Debug in recording ---------------

[100.0%] Linking executable: record
Undefined symbols:
  "_AudioStreamGetProperty", referenced from:
      RtApiCore::probeDeviceOpen(unsigned int, RtApi::StreamMode, unsigned int, unsigned int, unsigned int, unsigned long, unsigned int*, RtAudio::StreamOptions*)in librtaudio.a(RtAudio.o)
      RtApiCore::probeDeviceOpen(unsigned int, RtApi::StreamMode, unsigned int, unsigned int, unsigned int, unsigned long, unsigned int*, RtAudio::StreamOptions*)in librtaudio.a(RtAudio.o)
      RtApiCore::probeDeviceOpen(unsigned int, RtApi::StreamMode, unsigned int, unsigned int, unsigned int, unsigned long, unsigned int*, RtAudio::StreamOptions*)in librtaudio.a(RtAudio.o)
  "_AudioHardwareSetProperty", referenced from:
      RtApiCore::probeDeviceOpen(unsigned int, RtApi::StreamMode, unsigned int, unsigned int, unsigned int, unsigned long, unsigned int*, RtAudio::StreamOptions*)in librtaudio.a(RtAudio.o)
  "_AudioStreamSetProperty", referenced from:
      RtApiCore::probeDeviceOpen(unsigned int, RtApi::StreamMode, unsigned int, unsigned int, unsigned int, unsigned long, unsigned int*, RtAudio::StreamOptions*)in librtaudio.a(RtAudio.o)
      RtApiCore::probeDeviceOpen(unsigned int, RtApi::StreamMode, unsigned int, unsigned int, unsigned int, unsigned long, unsigned int*, RtAudio::StreamOptions*)in librtaudio.a(RtAudio.o)
      RtApiCore::probeDeviceOpen(unsigned int, RtApi::StreamMode, unsigned int, unsigned int, unsigned int, unsigned long, unsigned int*, RtAudio::StreamOptions*)in librtaudio.a(RtAudio.o)
      RtApiCore::probeDeviceOpen(unsigned int, RtApi::StreamMode, unsigned int, unsigned int, unsigned int, unsigned long, unsigned int*, RtAudio::StreamOptions*)in librtaudio.a(RtAudio.o)
      RtApiCore::probeDeviceOpen(unsigned int, RtApi::StreamMode, unsigned int, unsigned int, unsigned int, unsigned long, unsigned int*, RtAudio::StreamOptions*)in librtaudio.a(RtAudio.o)
      RtApiCore::probeDeviceOpen(unsigned int, RtApi::StreamMode, unsigned int, unsigned int, unsigned int, unsigned long, unsigned int*, RtAudio::StreamOptions*)in librtaudio.a(RtAudio.o)
  "_AudioDeviceStart", referenced from:
      RtApiCore::startStream()      in librtaudio.a(RtAudio.o)
      RtApiCore::startStream()      in librtaudio.a(RtAudio.o)
  "_AudioDeviceGetPropertyInfo", referenced from:
      hasProperty(unsigned long, unsigned long, bool, unsigned long)in librtaudio.a(RtAudio.o)
      RtApiCore::getDeviceInfo(unsigned int)in librtaudio.a(RtAudio.o)
      RtApiCore::getDeviceInfo(unsigned int)in librtaudio.a(RtAudio.o)
      RtApiCore::getDeviceInfo(unsigned int)in librtaudio.a(RtAudio.o)
      RtApiCore::probeDeviceOpen(unsigned int, RtApi::StreamMode, unsigned int, unsigned int, unsigned int, unsigned long, unsigned int*, RtAudio::StreamOptions*)in librtaudio.a(RtAudio.o)
  "_AudioDeviceGetProperty", referenced from:
      RtApiCore::getDeviceInfo(unsigned int)in librtaudio.a(RtAudio.o)
      RtApiCore::getDeviceInfo(unsigned int)in librtaudio.a(RtAudio.o)
      RtApiCore::getDeviceInfo(unsigned int)in librtaudio.a(RtAudio.o)
      RtApiCore::getDeviceInfo(unsigned int)in librtaudio.a(RtAudio.o)
      RtApiCore::getDeviceInfo(unsigned int)in librtaudio.a(RtAudio.o)
      RtApiCore::probeDeviceOpen(unsigned int, RtApi::StreamMode, unsigned int, unsigned int, unsigned int, unsigned long, unsigned int*, RtAudio::StreamOptions*)in librtaudio.a(RtAudio.o)
      RtApiCore::probeDeviceOpen(unsigned int, RtApi::StreamMode, unsigned int, unsigned int, unsigned int, unsigned long, unsigned int*, RtAudio::StreamOptions*)in librtaudio.a(RtAudio.o)
      RtApiCore::probeDeviceOpen(unsigned int, RtApi::StreamMode, unsigned int, unsigned int, unsigned int, unsigned long, unsigned int*, RtAudio::StreamOptions*)in librtaudio.a(RtAudio.o)
      RtApiCore::probeDeviceOpen(unsigned int, RtApi::StreamMode, unsigned int, unsigned int, unsigned int, unsigned long, unsigned int*, RtAudio::StreamOptions*)in librtaudio.a(RtAudio.o)
  "_AudioDeviceSetProperty", referenced from:
      RtApiCore::probeDeviceOpen(unsigned int, RtApi::StreamMode, unsigned int, unsigned int, unsigned int, unsigned long, unsigned int*, RtAudio::StreamOptions*)in librtaudio.a(RtAudio.o)
  "_AudioHardwareGetProperty", referenced from:
      RtApiCore::getDeviceInfo(unsigned int)in librtaudio.a(RtAudio.o)
      RtApiCore::getDefaultOutputDevice()      in librtaudio.a(RtAudio.o)
      RtApiCore::getDefaultOutputDevice()      in librtaudio.a(RtAudio.o)
      RtApiCore::getDefaultInputDevice()      in librtaudio.a(RtAudio.o)
      RtApiCore::getDefaultInputDevice()      in librtaudio.a(RtAudio.o)
      RtApiCore::probeDeviceOpen(unsigned int, RtApi::StreamMode, unsigned int, unsigned int, unsigned int, unsigned long, unsigned int*, RtAudio::StreamOptions*)in librtaudio.a(RtAudio.o)
  "_AudioDeviceRemoveIOProc", referenced from:
      RtApiCore::closeStream()      in librtaudio.a(RtAudio.o)
      RtApiCore::closeStream()      in librtaudio.a(RtAudio.o)
  "_AudioDeviceAddPropertyListener", referenced from:
      RtApiCore::probeDeviceOpen(unsigned int, RtApi::StreamMode, unsigned int, unsigned int, unsigned int, unsigned long, unsigned int*, RtAudio::StreamOptions*)in librtaudio.a(RtAudio.o)
  "_AudioHardwareGetPropertyInfo", referenced from:
      RtApiCore::getDeviceCount()      in librtaudio.a(RtAudio.o)
  "_AudioDeviceAddIOProc", referenced from:
      RtApiCore::probeDeviceOpen(unsigned int, RtApi::StreamMode, unsigned int, unsigned int, unsigned int, unsigned long, unsigned int*, RtAudio::StreamOptions*)in librtaudio.a(RtAudio.o)
  "_AudioDeviceStop", referenced from:
      RtApiCore::closeStream()      in librtaudio.a(RtAudio.o)
      RtApiCore::closeStream()      in librtaudio.a(RtAudio.o)
      RtApiCore::stopStream()      in librtaudio.a(RtAudio.o)
      RtApiCore::stopStream()      in librtaudio.a(RtAudio.o)
ld: symbol(s) not found
collect2: ld returned 1 exit status
Process terminated with status 1 (0 minutes, 0 seconds)
0 errors, 0 warnings

I am alwasys find this error. Please help me how to solve this.