Author Topic: Trouble Debugging after Compiling  (Read 4405 times)

Anonymous

  • Guest
Trouble Debugging after Compiling
« on: February 02, 2005, 03:36:01 pm »
I'm using the beta-5 release, and I didn't notice this problem in beta-4. Whenever I compile the entire project, and then hit F8 for debug, the compiler hangs with the message:
Quote
Calculating dependencies: main.cpp
Switching to target: default
Compiling: main.cpp

It uses of 99% of the CPU and doesn't do anything at all. I eventually have hit  "clean" after a few minutes, which stops the debugger. I can run the program using F9, but I would really like to Debug.

I am running Windows XP Pro and have 512 MB Ram. Do you know what the problem could be? Could it have something to do with the removal of make being used as the default to compile from beta-5? Is there a way I can make code::blocks just use make instead? My compiler of choise is MinGW.

-Mike

Offline mandrav

  • Project Leader
  • Administrator
  • Lives here!
  • *****
  • Posts: 4291
    • Code::Blocks IDE
Re: Trouble Debugging after Compiling
« Reply #1 on: February 02, 2005, 04:06:58 pm »
Quote from: Anonymous
Do you know what the problem could be? Could it have something to do with the removal of make being used as the default to compile from beta-5? Is there a way I can make code::blocks just use make instead? My compiler of choise is MinGW.
-Mike


Yes, go to "Settings/Configure plugins/Compiler", select your compiler of choice. Switch to the "Other" tab and change the build method.

HTH,
Yiannis.
Be patient!
This bug will be fixed soon...

Anonymous

  • Guest
Re: Trouble Debugging after Compiling
« Reply #2 on: February 02, 2005, 07:42:24 pm »
Quote from: mandrav
Quote from: Anonymous
Do you know what the problem could be? Could it have something to do with the removal of make being used as the default to compile from beta-5? Is there a way I can make code::blocks just use make instead? My compiler of choise is MinGW.
-Mike


Yes, go to "Settings/Configure plugins/Compiler", select your compiler of choice. Switch to the "Other" tab and change the build method.

HTH,
Yiannis.

Thanks, that worked. I have one other quick question. Under "Settings/Configure plugins/Compiler" there is a tab labeled "Programs" that specifies where the debugger, compiler, linker, ect. are. However, when I click the ... button next to the debugger and specify "gdb.exe" (its in the same folder as the other executables) the option isn't retained after I close the compiler settings. Every time I go back to verify the debugger was set, it shows that it was not.

I remember that GDB gave me useful debugging info when my program crashed in beta-4, but all I get now is something like "0x004c5e59__gnu_cxx::__exchange_and_add(int volatile*, int)". Do you know how I can specify the debugger so that it stays set in the Options? Thanks.

-Mike

Anonymous

  • Guest
Trouble Debugging after Compiling
« Reply #3 on: February 02, 2005, 07:44:13 pm »
Also, I do have the "produce debugging symbols" set in the compiler options, but it doesn't seem to make much of a difference whether or not I have that set.

-Mike

Offline mandrav

  • Project Leader
  • Administrator
  • Lives here!
  • *****
  • Posts: 4291
    • Code::Blocks IDE
Re: Trouble Debugging after Compiling
« Reply #4 on: February 02, 2005, 10:53:38 pm »
Quote from: Anonymous
Do you know how I can specify the debugger so that it stays set in the Options?

Hmm, the fact that it's not keeping the setting is a bug... I 'll fix it.
But gdb.exe is the default debugger, so it wouldn't make any difference. I plan to check out the debugger thoroughly these days, anyway. So stay tuned...

Greetings,
Yiannis.
Be patient!
This bug will be fixed soon...