Author Topic: wxSmith editor messes with markings of selected object  (Read 2157 times)

Offline frithjofh

  • Regular
  • ***
  • Posts: 373
wxSmith editor messes with markings of selected object
« on: August 25, 2008, 06:52:41 pm »
Hello,

I'm using c::b under SuSE 11.0 x86_64 with a wxWidgets project under KDE environment. Sometimes, I can't specify when exactly, the following happens: the black squares of a selected object are shown displaced, that is they no longer appear on the selected item but normally in the above left corner of the editor. This happens for example after changing the image of a image button after that the above happens, no matter which object is chosen from then on. The editor reverts to correct behavior sometimes by selecting an object and changing its proportion value or its expand characteristic, but I can't confirm that it always does. Closing the wxs file and opening it again restores correct behavior.

Selecting an object in the editor gets quite strange once the effect has taken place: selecting it in the resource panel works all right, but in the editor one has to click select (with the left mouse button, as usual) with exactly the offset shown by the misplaced handles. If for instance the handles are 1 cm to the left and up, you have to click with this offset to the wanted object to activate it ...

Curious thing, that the above effect only happens in one wxs file. If there is another wxs file open at the same time the handles there are in the right places. On can even have three files open with all working fine, two working fine and one not, or any other combination possible.

I attach a screen shot to show the effect. In the shot the selected item is the white field, a treectrl, its handles appear misplaced. Worse happens when choosing the button right beneath (see second attachment): its handles appear way above misplaced.

Seems to be a bug.

Another thing, which I find a little annoying is the behavior when I open a wxs file: Always the corresponding *.cpp file gets marked as modified when it is open in the editor, although there haven't been any changes at all, the wxs file hasn't been modified, just opened. Similar is the fact that compiling a project saves all files, but it doesn't save the wxs files if they were modified ...

But please, these are no harsh critics or complaints. C::B is great and its wxSmith module the same.

Regards

Nausea

[attachment deleted by admin]
« Last Edit: August 26, 2008, 01:04:35 pm by nausea »
architect with some spare time  -  c::b compiled from last svn  -   openSuSE leap x86_64  -  AMD FX-4100

Offline byo

  • Plugin developer
  • Lives here!
  • ****
  • Posts: 837
Re: wxSmith editor messes with markings of selected object
« Reply #1 on: September 03, 2008, 10:27:33 pm »
Hi

This is a known bug. I tried to find proper workaround but none seems to work.

The problem is indeed inside wxWidgets which returns wrong position of item in a short period of time just after it has been moved. I have some solution on my mind right now but it will require much new code so I didn't want to start it till I know I'll be able to do it quickly.


Regards
   BYO