Author Topic: Can't compile usingt qt 4.0.1  (Read 3690 times)

Itim

  • Guest
Can't compile usingt qt 4.0.1
« on: September 13, 2005, 05:59:14 am »
Well, i installed code blocks normally, created a new qt project, and with the qt 4.0 i was able to compile my program perfectly, but when i moved to qt 4.0.1, this kind of error started to appear:

In file included from C:/Qt/4.0.1/include/QtGui/qabstractbutton.h:1,
                 from C:/Qt/4.0.1/include/Qt/../../src/gui/widgets/qpushbutton.h:27,
                 from C:/Qt/4.0.1/include/Qt/qpushbutton.h:1,
                 from main.cpp:3:
C:/Qt/4.0.1/include/QtGui/../../src/gui/widgets/qabstractbutton.h:31: error: `QtValidLicenseForGuiModule' does not name a type

Oh, by the way, the program a tried to compile was the example that came with qt
Any ideas of how to fix it?

Offline rickg22

  • Lives here!
  • ****
  • Posts: 2283
Re: Can't compile usingt qt 4.0.1
« Reply #1 on: September 13, 2005, 06:21:05 am »
So the problem began when you switched to 4.01?
Are you sure you have the right libs / includes?
Did you check the QT manual to see what had changed? Perhaps you need a #define or something.
If that doesn't work, try google. I'm sure you're not the first one with that problem.

Hope that helps :) Now, if everything else fails... can anyone here help him? :P

jimknopf

  • Guest
Re: Can't compile usingt qt 4.0.1
« Reply #2 on: September 13, 2005, 09:34:18 am »
Hi!

More information about this problem with Qt4.0.1 can be found here:

http://lists.trolltech.com/qt-interest/2005-08/msg00936.html

I solved this problem by changing in the file C:\Qt\4.0.1\src\corelib\global\qconfig.h ,line  13

#  define QT_EDITION QT_EDITION_

to

#  define QT_EDITION QT_EDITION_DESKTOP

Bye,

Jim

Itim

  • Guest
Re: Can't compile usingt qt 4.0.1
« Reply #3 on: September 13, 2005, 04:48:28 pm »
Holyshit, problem solved! Hohoho, that was a great tip, thanks a lot jim and rick