Author Topic: The 02 August 2008 build (5177) is out.  (Read 27969 times)

Offline killerbot

  • Administrator
  • Lives here!
  • *****
  • Posts: 5193
The 02 August 2008 build (5177) is out.
« on: August 02, 2008, 09:48:45 pm »
Get quick announcements through the RSS feed http://www.codeblocks.org/nightly/CodeBlock_RSS.xml

Before you use a nightly make sure you understand how it works.

A link to the unicode windows wxWidget dll for Code::Blocks : http://prdownload.berlios.de/codeblocks/wxmsw28u_gcc_cb_wx288.7z

For those who might need this one (when no MingW installed on your system) : the mingw10m.dll : http://prdownload.berlios.de/codeblocks/mingwm10_gcc421.7z

The 02 August 2008 build is out.
  - Windows :
   http://prdownload.berlios.de/codeblocks/CB_20080802_rev5177_win32.7z
  - Linux :
   none

Resolved Fixed:

  • Fixed bug causing C::B to rejest closing when using editor other than the internal one
  • HexEditor: Added "Open with HexEditor" option into the "File" menu
  • HexEditor: Implemented goto functionality (ctrl+g)
  • HexEditor: Implemented inserting new bytes (INSERT key) and deleteing current (DELETE key)
  • CodeSnippets 1 3.80
    - Center find dlg in parent frame
    - Invoke CheckForModifiedFiles in EditSnippetFrame EVT_ACTIVATE
    - Invoke CheckForModifiedFiles in ThreadSearchFrame EVT_ACTIVATE
    - Pass URL/URI in dragndrop as file for browsers
    - App:Fix activating first instance when starting secondary instances, then exit
    - {enter} in snippets properties label simulates OK
    - Fixed: App: CodeSnippets XML Index is not being saved OnClose
    • .(2008/07/30)

    - Fixed: Loop caused by cross-frame event posting in EVT_ACTIVATE routines
    - Speed up .cbp compile time by sharing obj directory betwn plugin & standalone
  • HexEditor: Applied patch by dmoore - integration with ShellExplorer plugin
  • OnReload does not re-establish margin numbers and width (Bug #014298, patch number #002536)

Regressions/Confirmed/Annoying/Common bugs:

  • toolbar-images-not-changing-state (is a wx problem/Win XP problem)


Offline L_O_J

  • Multiple posting newcomer
  • *
  • Posts: 10
Re: The 02 August 2008 build (5177) is out.
« Reply #1 on: August 03, 2008, 04:18:52 am »
This might be a bug...
Since the July 22 build everytime I try to use Ctrl + Delete, it doesn't delete the word, instead searching for it  :shock:. Is it a new behaviour or what ? Since I use Ctrl + Delete a lot, it's pretty hard to change habit :D

Offline killerbot

  • Administrator
  • Lives here!
  • *****
  • Posts: 5193
Re: The 02 August 2008 build (5177) is out.
« Reply #2 on: August 03, 2008, 10:43:37 am »
this seems to be a bug of wxwidgets --> ctrl + .   ; but ./del is the same physical key :-(

workaround : choose different binding for the ctrl+ .

Offline berte

  • Single posting newcomer
  • *
  • Posts: 9
Re: The 02 August 2008 build (5177) is out.
« Reply #3 on: August 03, 2008, 10:51:26 am »
hello everbody,

thanks for new version but internationalization problem still continuing.


Offline killerbot

  • Administrator
  • Lives here!
  • *****
  • Posts: 5193
Re: The 02 August 2008 build (5177) is out.
« Reply #4 on: August 03, 2008, 11:49:35 am »
hello everbody,

thanks for new version but internationalization problem still continuing.



Could you file this as a bug report please at berlios ??

Offline berte

  • Single posting newcomer
  • *
  • Posts: 9
Re: The 02 August 2008 build (5177) is out.
« Reply #5 on: August 03, 2008, 01:40:13 pm »
Yes killerbot, I reported this bug long long time ago.
It's not important native users but it's not a good look :-)

cheers.

Offline jens

  • Administrator
  • Lives here!
  • *****
  • Posts: 7265
    • Jens' unofficial debian-repository for the Code::Blocks - IDE
Re: The 02 August 2008 build (5177) is out.
« Reply #6 on: August 03, 2008, 02:28:19 pm »
I just uploaded svn r5177 to my server.

Important notice (please read carefully):
I changed the package- and directory-structure of my Code::Blocks build to make it more debian-compliant.
I also split off the architecture-independent files from the codeblocks-package and put them into codeblocks-common.
The architecture-dependent libraries, that are parts of the contrib-plugins are now in "/usr/lib/codeblocks" and only the architecture-independent parts remain in "/usr/share/codeblocks".
The changes are based on a patch provided by "daniel2000".
More details can be found here.
I posted a patch in this thread. I modified this patch for the actual nightly, to make lintian run without errors.

If you get any errors caused by this changes, please send me a PN or a mail.
I will be out for work the next week (most times without internet), except for the wednesday.
So I can look for mails from time to time from late tuesday to early thursday.

The changes work for me without any problems, so I hope they will also do it for other users.

Please have in mind, that these changes are not part of the official svn-code, so if anything does not work due to the changes, don't blame C::B.

Offline Loaden

  • Lives here!
  • ****
  • Posts: 1014
Re: The 02 August 2008 build (5177) is out.
« Reply #7 on: August 04, 2008, 04:30:47 pm »
Please look 'Screenshot.png' first:
in 1: the default encoding is 'Windows 936',
in 2: createdb.cpp include some chinese char, when i open it use CB,
in 3: CB open it use ISO-8895-1, so, i can't show chinese char.

payout.cpp include chinese char also. but it's can opened by CB to use 'Windows 936'.

Why two files include the same chinese code, but it opened use 'Default encoding', it's auto changed to 'ISO-8895-1'.

I need help, because i am a china developer, i can't use chinese to program, it's made my headache.

Thanks! please fix this bug.

[attachment deleted by admin]

Offline Biplab

  • Developer
  • Lives here!
  • *****
  • Posts: 1874
    • Biplab's Blog
Re: The 02 August 2008 build (5177) is out.
« Reply #8 on: August 04, 2008, 05:25:54 pm »
Please look 'Screenshot.png' first:
in 1: the default encoding is 'Windows 936',
in 2: createdb.cpp include some chinese char, when i open it use CB,
in 3: CB open it use ISO-8895-1, so, i can't show chinese char.

Save your file in UTF-8 encoding. C::B can't detect Windows 936 encoding and it sets a fallback encoding for it.
Be a part of the solution, not a part of the problem.

Offline Acki

  • Multiple posting newcomer
  • *
  • Posts: 100
Re: The 02 August 2008 build (5177) is out.
« Reply #9 on: August 05, 2008, 01:26:13 am »
still the double click problem !!!  :?  :(

Offline Loaden

  • Lives here!
  • ****
  • Posts: 1014
Re: The 02 August 2008 build (5177) is out.
« Reply #10 on: August 05, 2008, 05:37:40 am »
Please look 'Screenshot.png' first:
in 1: the default encoding is 'Windows 936',
in 2: createdb.cpp include some chinese char, when i open it use CB,
in 3: CB open it use ISO-8895-1, so, i can't show chinese char.

Save your file in UTF-8 encoding. C::B can't detect Windows 936 encoding and it sets a fallback encoding for it.
It's can't compile use VC2003, because VC2003 can't support UTF-8 format.
But my project must support cross platform. In Linux, use GCC, and use VC2003 under Windows.
I muse use Windows 936 encoding to support chinese code.

and in windows OS, set default encoding to Windows 936, it work fine!
this problem only appear in linux.
« Last Edit: August 05, 2008, 05:39:39 am by Loaden »

Offline Etienne

  • Multiple posting newcomer
  • *
  • Posts: 14
Re: The 02 August 2008 build (5177) is out.
« Reply #11 on: August 05, 2008, 10:01:37 am »
Hello,

Thanks to continue making nightly builds!

I have two bug:

- This one started after the 5106svn version, when double clicking on a workspace, its tells a file is missing  (please see attached file)...(even with every plugin disabled), ( its works with cb5106)

- This one was from 5106svn to now, I can't say when its started: sometime CB show it is in Debug mode, but compile in Release, and so on ; a workaround is to change Debug/Release mode, twice, in the menu to set it correctly...

Thanks for all.

See you

Etienne de Foras


[attachment deleted by admin]

Offline Loaden

  • Lives here!
  • ****
  • Posts: 1014
Re: The 02 August 2008 build (5177) is out.
« Reply #12 on: August 05, 2008, 10:52:26 am »
Hello,

Thanks to continue making nightly builds!

I have two bug:

- This one started after the 5106svn version, when double clicking on a workspace, its tells a file is missing  (please see attached file)...(even with every plugin disabled), ( its works with cb5106)

- This one was from 5106svn to now, I can't say when its started: sometime CB show it is in Debug mode, but compile in Release, and so on ; a workaround is to change Debug/Release mode, twice, in the menu to set it correctly...

Thanks for all.

See you

Etienne de Foras


I find this problem too.

Offline thomas

  • Administrator
  • Lives here!
  • *****
  • Posts: 3979
Re: The 02 August 2008 build (5177) is out.
« Reply #13 on: August 05, 2008, 11:20:21 am »
It's can't compile use VC2003, because VC2003 can't support UTF-8 format.
Well, use UTF-16 instead then.
"We should forget about small efficiencies, say about 97% of the time: Premature quotation is the root of public humiliation."

Offline Loaden

  • Lives here!
  • ****
  • Posts: 1014
Re: The 02 August 2008 build (5177) is out.
« Reply #14 on: August 06, 2008, 03:37:53 am »
It's can't compile use VC2003, because VC2003 can't support UTF-8 format.
Well, use UTF-16 instead then.

If i select UTF16-LE, i can't use _T() or _(). example:
Code: [Select]
wxButton* pShow = new wxButton(this, ID_BTN_SHOW, _T("开始"));or:
Code: [Select]
wxButton* pShow = new wxButton(this, ID_BTN_SHOW, _("开始"));show error info when compile:
Code: [Select]
src\main.cpp|23|error C2001: newline in constant|
src\main.cpp|23|fatal error C1057: unexpected end of file in macro expansion|
||=== Build finished: 2 errors, 0 warnings ===|

but if i changed this code to:
Code: [Select]
wxButton* pShow = new wxButton(this, ID_BTN_SHOW, L"开始");it's compile success.

how to use _T() or _() ?