Author Topic: The application failed to initialize properly (0xc0000005). Click on OK...  (Read 10142 times)

martan

  • Guest
Hi all,

I have installed CB (svn 5093) and wxWidgets-2.8.7 according this tutorial -> http://www.avrportal.com/?page=codeblocks

There is no problem if I build debug version of project, but if I build release version, application doesn't work with message:
"The application failed to initialize properly (0xc0000005). Click on OK to terminate the application.

I read some threads with similar problem with "The application failed to initialize properly (0xc0000005). Click on OK to terminate the application message, but I didn't find solution.

Where is the problem???

thanks
m.

Offline stahta01

  • Lives here!
  • ****
  • Posts: 6674
    • My Best Post
I just had the same error last week traced it to more than one copy of different version of mingwm10.dll in my path.

Look for copies of mingwm10.dll that are under the minGW folder and Code::Blocks project folder; they should be the same version of the DLL. The safest way to insure this is copy the one from MinGW bin folder to your project folder.

My problem was caused by installing an program that added it own copy of mingwm10.dll and updated the PATH environment variable to make it visible; so you may have to search your hard drive for other copies of mingwm10.dll.

Edit: Found another possible cause an bad strip.exe being in the path.

Tim S
« Last Edit: December 03, 2008, 12:59:22 pm by stahta01 »
C Programmer working to learn more about C++ and Git.
On Windows 7 64 bit and Windows 10 32 bit.
On Debian Stretch, compiling CB Trunk against wxWidgets 3.0.
--
When in doubt, read the CB WiKi FAQ. http://wiki.codeblocks.org