Author Topic: wxWidgets problem  (Read 3514 times)

fig

  • Guest
wxWidgets problem
« on: June 05, 2008, 07:51:18 pm »
I'm trying to start a wxWidgets project using the new project wizard on Windows.

It works up until the "Please select various configuration options" page, where I get this error dialog..

Code: [Select]
---------------------------
Warning
---------------------------
A matching Debug configuration cannot be found in the wxWidgets directory you specified.
This means that Debug target of your project will not build.

Are you sure you want to continue with these settings?
---------------------------
Yes   No   
---------------------------

I get the same message for Release configuration too.

As far as I know, everything is installed and set up correctly, but I'm still a bit of a noob with C++.  I just did the same thing in Ubuntu last night and everything went smoothly once I had installed all dependencies.. I was hoping to use wxSmith in Windows since it doesn't seem to be supported in Linux..

Anyone had this problem before or knows how I can fix it?
« Last Edit: June 05, 2008, 07:59:50 pm by fig »

Offline jens

  • Administrator
  • Lives here!
  • *****
  • Posts: 7265
    • Jens' unofficial debian-repository for the Code::Blocks - IDE
Re: wxWidgets problem
« Reply #1 on: June 05, 2008, 08:38:54 pm »
Code: [Select]
A matching Debug configuration cannot be found in the wxWidgets directory you specified.
I get the same message for Release configuration too.

It looks like you did not build/install wxwidgets on your computer.

You can have a look here: http://wiki.codeblocks.org/index.php?title=Nightly_Cookbook#wxWidgets

or you have not setup the global wx-variable in C::B correctly to your base wx-directory.

I was hoping to use wxSmith in Windows since it doesn't seem to be supported in Linux..

WxSmith works fine on linux and windows and as far as I know on Mac.

fig

  • Guest
Re: wxWidgets problem
« Reply #2 on: June 05, 2008, 09:19:09 pm »
Quote
It looks like you did not build/install wxwidgets on your computer.

Yeah, I think that's the problem.  I'm building it now. :p

Quote
WxSmith works fine on linux and windows and as far as I know on Mac.

Where could I find out how to get it working on Linux?

Thanks for your help..

Offline jens

  • Administrator
  • Lives here!
  • *****
  • Posts: 7265
    • Jens' unofficial debian-repository for the Code::Blocks - IDE
Re: wxWidgets problem
« Reply #3 on: June 05, 2008, 09:43:26 pm »
Create a new wxWidgets project, if the wizard asks for the preferred gui-builder chose wxSmith.
That's it.

As I see you are on Ubuntu.

Do you use a self-compiled C::B, or binary packages.

If self-compiled, you have to configure the sources for building wxSmith or any other of the contrib-plugins.
Type "./configure --help" in the root-dir of the C::B source-tree for information how to do this.

If you use prebuild binary-packages, you need to install the "codeblocks-contrib" and the "libwxsmithlib0"-package (the first depends on the second).

rawatlike

  • Guest
Re: wxWidgets problem
« Reply #4 on: August 19, 2008, 09:51:23 am »
please tell me how to set global variables in codeblocks

Offline MortenMacFly

  • Administrator
  • Lives here!
  • *****
  • Posts: 9493
Re: wxWidgets problem
« Reply #5 on: August 19, 2008, 01:01:14 pm »
Compiler logging: Settings->Compiler & Debugger->tab "Other"->Compiler logging="Full command line"
C::B Manual: http://www.codeblocks.org/docs/main_codeblocks_en.html
C::B FAQ: http://wiki.codeblocks.org/index.php?title=FAQ