Author Topic: Ubuntu (hoary) make error  (Read 4613 times)

Offline SWAT

  • Single posting newcomer
  • *
  • Posts: 5
Ubuntu (hoary) make error
« on: September 03, 2005, 03:42:51 pm »
When I do a "make -f Makefile.unix", the make command exits right here:
Code: [Select]
.........
Calculating dependencies for sdk/editorlexerloader.cpp...
Calculating dependencies for sdk/editormanager.cpp...
sdk/editormanager.cpp:127:107: pasting "LL" and "L"ID_EditorManagerCloseButton"" does not give a valid preprocessing token
make: *** [.deps/sdk/editormanager.d] Error 1

Offline rickg22

  • Lives here!
  • ****
  • Posts: 2283
Re: Ubuntu (hoary) make error
« Reply #1 on: September 03, 2005, 05:27:01 pm »
Heh :lol: that was a unicode error... version RC1 doesn't support unicode yet. You need to compile wxGTK with unicode disabled (see the wiki)
On the other hand, unicode IS supported in the upcoming RC2 :)

Offline SWAT

  • Single posting newcomer
  • *
  • Posts: 5
Re: Ubuntu (hoary) make error
« Reply #2 on: September 04, 2005, 02:15:18 am »
When will the RC2 be released? If you don't really know, just give me a 'probabilty' date. This is crucial for me, because it's the choice between using Codeblocks or another IDE. (I'm too lazy to apt-get remove wxwidgets and then compile/install it manually)
« Last Edit: September 04, 2005, 02:41:21 am by SWAT »

Offline rickg22

  • Lives here!
  • ****
  • Posts: 2283
Re: Ubuntu (hoary) make error
« Reply #3 on: September 04, 2005, 04:55:45 am »
Two weeks max. With any luck, only one week! :)

Offline SWAT

  • Single posting newcomer
  • *
  • Posts: 5
Re: Ubuntu (hoary) make error
« Reply #4 on: September 20, 2005, 12:33:10 pm »
What is the current ETA?

Offline st3vie

  • Multiple posting newcomer
  • *
  • Posts: 41
Re: Ubuntu (hoary) make error
« Reply #5 on: September 21, 2005, 03:18:35 pm »
perhaps you can try out CB-cvs? That one already has unicode support in it.

although the new version might be very close! :)

-st3vie