Author Topic: Ubuntu update to Hardy Heron leads to key space not working anymore  (Read 10892 times)

Offline Funto

  • Multiple posting newcomer
  • *
  • Posts: 81
Hi all,

I've just upgraded my Linux distribution from Ubuntu Gutsy to Hardy (which did not change the Code::Blocks package apparently), and now when using the source code editor, a press on the space bar is understood by Code::Blocks as a Ctrl+space key press !

I tried to remove ~/.codeblocks but it did not change anything...

On the other hand, when I use the "Default code editor" in the settings, my space key is correctly recognized, but even disabling code completion doesn't make it recognized in the normal source code editor...

Thanks for your help ^^

gafatoa

  • Guest
Re: Ubuntu update to Hardy Heron leads to key space not working anymore
« Reply #1 on: April 25, 2008, 09:50:52 pm »
Hello,

I got the same problem after a fresh Ubuntu 8.04 install.
This problem seems to occur only in the editor. In other text fields (search for example) all is fine.
Ctrl+Alt+Space is "understood" as a standard space key press.

Bye
« Last Edit: April 25, 2008, 09:52:59 pm by gafatoa »

Offline JGM

  • Lives here!
  • ****
  • Posts: 518
  • Got to practice :)
Re: Ubuntu update to Hardy Heron leads to key space not working anymore
« Reply #2 on: April 26, 2008, 04:32:32 am »
maybe is a bug related to scintilla

Offline Funto

  • Multiple posting newcomer
  • *
  • Posts: 81
Re: Ubuntu update to Hardy Heron leads to key space not working anymore
« Reply #3 on: April 26, 2008, 11:39:08 am »
That's possible, but doesn't solve the problem lol :p

gafatoa >> same for me, Ctrl+Alt+Backspace is recognized as a space key press...


Offline Barking_Mad

  • Multiple posting newcomer
  • *
  • Posts: 47
Re: Ubuntu update to Hardy Heron leads to key space not working anymore
« Reply #5 on: April 26, 2008, 03:28:18 pm »
I notice both those xorg.conf posting use the XkbVariant "oss", this is not defined in my xorg.conf which doesnt exhibit the spacebar problem.

My xorg.conf:
Code: [Select]
....
Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection
....
« Last Edit: April 26, 2008, 03:36:44 pm by Barking_Mad »
WooF! WooF! - Ubuntu 8.10 & CB 5432 & GCC 4.3.2
To see the world in a grain of sand and heaven in a wild flower
To hold infinity in the palm of your hand and eternity in an hour - W.B

Offline Funto

  • Multiple posting newcomer
  • *
  • Posts: 81
Barking_Mad >> You were right :) I did as specified in the topic pointed by jens' link, that is to say, I commented out the XkbVariant "oss" and it works like a charm, thanks a lot :)

ameirhaeghe

  • Guest
Ubuntu update Ubuntu 9.04 key space not working anymore
« Reply #7 on: March 08, 2009, 04:29:29 pm »
there is no section keyboard in xorg.conf. In this Ubuntu release  !
And Y have space problem
 :shock:

ameirhaeghe

  • Guest
Re: Ubuntu update to Hardy Heron leads to key space not working anymore
« Reply #8 on: March 08, 2009, 04:40:20 pm »
My solution in this version is to change keyboard to france and pc generique 104 touches (not france autre) (menu system/preferences/clavier)
It's work for the moment.
 :D

Offline jens

  • Administrator
  • Lives here!
  • *****
  • Posts: 7265
    • Jens' unofficial debian-repository for the Code::Blocks - IDE
Re: Ubuntu update Ubuntu 9.04 key space not working anymore
« Reply #9 on: March 08, 2009, 04:42:28 pm »
there is no section keyboard in xorg.conf. In this Ubuntu release  !
And Y have space problem
 :shock:

The more recent xservers have to be configured with the hal-daemon and fdi-files.
Maybe you find some help here:

https://wiki.ubuntu.com/X/Config
and / or here:
http://ubuntuforums.org/showthread.php?t=948154

Offline wilbefast

  • Multiple posting newcomer
  • *
  • Posts: 16
Re: Ubuntu update to Hardy Heron leads to key space not working anymore
« Reply #10 on: September 10, 2009, 07:03:52 pm »
My solution in this version is to change keyboard to france and pc generique 104 touches (not france autre) (menu system/preferences/clavier)
It's work for the moment.
 :D

In English: I changed "france alternative" to "france" and chose a Dell laptop layout (not actually my laptop, which wasn't on the list, but close enough). Apparently everything works - fingers cross :-S


William

Removed non-english portions.
« Last Edit: September 10, 2009, 08:27:10 pm by MortenMacFly »

Offline Fabyen

  • Single posting newcomer
  • *
  • Posts: 4
Re: Ubuntu update to Hardy Heron leads to key space not working anymore
« Reply #11 on: October 08, 2009, 08:47:05 am »
I fix this issue by changing keyboard layout. (french keyboard)

1 - Menu System => Preferences => Keyboard
2 - Select Tab layout
3 - Click "Layout options..."
4 - Expand last option "Using space key to input non-breakable space character"
5 - Select the last choice "Usual Space at any level"

I know it's not system wide, just for the current user (well I suppose) but...

That's it.


A french guy in Bucharest using Ubtuntu 9.10 (beta at the moment)