Author Topic: Problem when running an application from inside code::blocks (ubuntu 7.10)  (Read 1619 times)

joyrider

  • Guest
Hi,

i've got a little problem with the new code::blocks 8.02 which i just installed. Everything works fine up to the point when i run my (sdl) application from inside code::blocks, by pressing "play" button. The application starts but then falls asleep and doesn't respond to keypresses or a quit signal. I have to kill it with kill -kill <pid of program> . I first thought this was a bug in my application, but when i run the same application outside code::blocks everything works fine and the program doesn't fall asleep. Also this only happens when i define the application as a gui application, if i change it to a console application it runs fine from within code blocks. It also runs fine if i choose to debug it (even when it's set to a gui application). I'm running code blocks on ubuntu 7.10 gutsy.

Any idea's what could be wrong here ?

As a test i created a new SDL application and ran that from within code blocks and that doesn't give me a problem.