Author Topic: [solved] Install on OpenSuse 10.2 x86_64  (Read 1981 times)

Leduc08

  • Guest
[solved] Install on OpenSuse 10.2 x86_64
« on: March 05, 2008, 04:07:18 pm »
Hello,
I try to install codeblocks with the rpm: codeblocks-8.02-0.suse1020.x86_64.rpm
I have a library dependance error:
libwx_gtk2u-2.8.so.0(WXU_2.8)(64bit) needs by codeblocks-8.02-0.suse1020.x86_64

But if I verify the provides, I have:

sterec:/download/rpm # rpm -q --provides wxWidgets-2.8.6-6.1
libwx_gtk2u-2.8.so.0()(64bit)
libwx_gtk2u_fl-2.8.so.0()(64bit)
libwx_gtk2u_gizmos-2.8.so.0()(64bit)
libwx_gtk2u_gizmos_xrc-2.8.so.0()(64bit)
libwx_gtk2u_mmedia-2.8.so.0()(64bit)
libwx_gtk2u_ogl-2.8.so.0()(64bit)
libwx_gtk2u_plot-2.8.so.0()(64bit)
libwx_gtk2u_stc-2.8.so.0()(64bit)
libwx_gtk2u_svg-2.8.so.0()(64bit)
wxWidgets = 2.8.6-6.1


Do you thinks that the problem comes from pattern WXU_2.8 ?
If you have some idea?
Thanks in advance.

LeDuc

[solved]
It should be added some complementary widget's rpm (but i don't know which exactly ;-)):
wxWidgets-devel-2.8.7-0.pm.1
wxWidgets-gl-compat-2.8.7-0.pm.1
wxWidgets-gl-2.8.7-0.pm.1
wxWidgets-debuginfo-2.8.7-0.pm.1
wxWidgets-2.8.7-0.pm.1
wxWidgets-compat-2.8.7-0.pm.1
« Last Edit: March 07, 2008, 02:09:29 pm by Leduc08 »