Author Topic: Feature Request / Bug report  (Read 5400 times)

Isometric God

  • Guest
Feature Request / Bug report
« on: January 22, 2005, 12:56:59 am »
hi,
The DDE server does not work on my winXP machine with codeblocks beta4 and mingw32. The option Settings->Environment->View->On Project Open is not saved at all.
When I close a project CB asks whether to save changes in the project file despite the fact that I didnt change anything.

The standard project with a couple of files added refuses to create symbol tables for GDB even when I turn "generate debug info" on.

And in case of an compiler error it would be very nice if the editor would jump into that line where the error occured.

nonetheless you guys did a fantastic job with that IDE !!

Isometric God

  • Guest
Feature Request / Bug report
« Reply #1 on: January 22, 2005, 12:29:32 pm »
I found the reason for the debugger bug.  GDB needs an absolute path and the one in project options was relative. The problem is that you canīt make the path absolute in CodeBlocks. I did it with notepad and itīs working perfectly fine now.

Offline mike

  • Multiple posting newcomer
  • *
  • Posts: 53
Feature Request / Bug report
« Reply #2 on: January 22, 2005, 01:59:13 pm »
Quote

GDB needs an absolute path


This is actually a problem, as if you want the project to be shared between different people, the paths MUST be relative. Yannis, is there a way C::B stores the paths as relative ones, and changes to the absolute ones for the tools?

Offline mandrav

  • Project Leader
  • Administrator
  • Lives here!
  • *****
  • Posts: 4291
    • Code::Blocks IDE
Feature Request / Bug report
« Reply #3 on: January 22, 2005, 11:05:21 pm »
No, GDB works with relative paths just fine...
It only seems that a chdir is needed somewhere. I 'll check it and fix it.

Yiannis.
Be patient!
This bug will be fixed soon...

Offline mike

  • Multiple posting newcomer
  • *
  • Posts: 53
Feature Request / Bug report
« Reply #4 on: February 06, 2005, 01:30:12 pm »
Hi,

It seems it is not fixed in 1.0b5, is it? I get this message and cannot debug :-(

Quote

Selecting target: mingw-debug
Starting debugger: done
No source file named ..\testcases\test.c.
error
exited 1
Debugger finished with status 0

Offline mandrav

  • Project Leader
  • Administrator
  • Lives here!
  • *****
  • Posts: 4291
    • Code::Blocks IDE
Feature Request / Bug report
« Reply #5 on: February 06, 2005, 06:28:38 pm »
Is this a project you can send me, so that I can test it?
Because with the tests I run, it works fine...

Yiannis.
Be patient!
This bug will be fixed soon...