Author Topic: Code completion not working  (Read 6540 times)

Offline Freddy

  • Single posting newcomer
  • *
  • Posts: 4
Code completion not working
« on: January 10, 2006, 11:12:36 pm »
Hi!
I was using Dev-c++. Now I see that Code::Blocks can use Mingw and dev-c++'s auto-update.
So I decided to use Code::Blocks now.
But I can't get code completion to work.
In other editors like SciTE I type something like "Mess" and it shows "MessageBox(HWND, LPCSTR, LPCSTR, UINT)".
I've heard that Code::Blocks is based on Scintilla, so it should work too.
How to get auto-completion to work on Code::Blocks?

Thanks!
And sorry for my poor english...


sethjackson

  • Guest
Re: Code completion not working
« Reply #1 on: January 10, 2006, 11:45:44 pm »
Settings->PluginSettings->Code completion. Check follow LOCAL and check follow GLOBAL includes. I'm not sure if you need to use the cache option, since I don''t use this plugin much..... Umm go to the cache tab and check Use cache just in case......

HTH

Offline TDragon

  • Lives here!
  • ****
  • Posts: 936
    • Twilight Dragon Media
Re: Code completion not working
« Reply #2 on: January 11, 2006, 12:37:30 am »
Also note that the current code-completion plugin is incomplete and has a bug or two. Basically, no templated classes and pretty much no stdlib/stdc++lib. YMMV. It is in the process of being upgraded.
http://tdm-gcc.tdragon.net/ - TDM-GCC compiler suite for Windows (GCC 5.1.0 2015-06-28, 32/64-bit, no extra DLLs)

Offline Michael

  • Lives here!
  • ****
  • Posts: 1608
Re: Code completion not working
« Reply #3 on: January 11, 2006, 10:47:03 am »
Code Completion is WIP. AFAIK some progress has been done and updated (SVN rev1711) by rickg22 :). Anyway, it seems that there is a issue with the class browser and therefore the cache should not be enabled.

I think that these progresses should be available in the nightly build of today (11 jan 2006).

The code completion is actually limited. You can search in the forum for further information.

Michael