Author Topic: Downloading Code::Blocks  (Read 4897 times)

Offline Big Brother

  • Single posting newcomer
  • *
  • Posts: 5
Downloading Code::Blocks
« on: January 23, 2008, 12:09:51 am »
I just want to have a direct link to the file that I have to download to have Code::Blocks on Linux : Ubuntu 7.10 amd 64 bits.
I have try to download it, but when I tried to download it, it was not the good version.
Thank you in advance.

P.S. Before I was using Code::Blocks on Windows, but I changed to Linux!  :D 8)

Je voudrais juste avoir un lien directe sur le fichier qu'il faut que je download pour avoir Code::Blocks sur Linus : Ubuntu 7.10 amd 64 bits.
J'ai déjà essayer de le downloader, mais je n'ai pas downloader la bonne version.
Merci d'avance.

P.S. Avant j'utilisais Code::Blocks sur Windows, mais j'ai changé pour Linux! :D 8)

Offline orel

  • Multiple posting newcomer
  • *
  • Posts: 96
Re: Downloading Code::Blocks
« Reply #1 on: January 23, 2008, 01:51:49 am »
CB nighlty builds are not hosted here, on CB website. For windows users it is possible to go directly at berlios but for linux users you can go to Xaviou's Ubuntu 64bits binaries page http://www.esnips.com/web/CodeBlocks

There you have a list with the latest built ones

Orl
windows XP SP2
mingw gcc 3.4.5
svn Code::Blocks and M$ Visual Studio 2005 and .NET to eat!! SVNInside plugin :http://forums.codeblocks.org/index.php/topic,7063.0.html

Offline Big Brother

  • Single posting newcomer
  • *
  • Posts: 5
Re: Downloading Code::Blocks
« Reply #2 on: January 23, 2008, 02:24:49 pm »
Tank's, I see that's the good version and more: the version I'm downloading was put there 4 min ago.

Offline Big Brother

  • Single posting newcomer
  • *
  • Posts: 5
Re: Downloading Code::Blocks
« Reply #3 on: January 25, 2008, 02:46:08 am »
Now that I'm trying to install C::B, I have an errors and I need help.

Code: [Select]
Fatal Error: Mismatch between the program and library build versions detected.
The library used 2.8 (no debug,Unicode,compiler with C++ ABI 1002,wx containers,compatible with 2.4,compatible with 2.6),
and your program used 2.8 (no debug,Unicode,compiler with C++ ABI 1002,wx containers,compatible with 2.6).
Abandon (core dumped)

I try to download some versions (like libwxgtku2.6-2.6.3-8mdv2007.1.i586.rpm) but it seems that it dont work.

Thank to your reply.

Offline stahta01

  • Lives here!
  • ****
  • Posts: 6664
    • My Best Post
Re: Downloading Code::Blocks
« Reply #4 on: January 25, 2008, 05:06:39 am »
You need to use the same library in your project and the one on your system.

Did you compile the Library yourself?

If so, what was the configure command?

What does the following commands return?

Code: [Select]
which wx-config

Code: [Select]
wx-config --cflags

Tim S
C Programmer working to learn more about C++ and Git.
On Windows 7 64 bit and Windows 10 32 bit.
On Debian Stretch, compiling CB Trunk against wxWidgets 3.0.
--
When in doubt, read the CB WiKi FAQ. http://wiki.codeblocks.org

Offline Big Brother

  • Single posting newcomer
  • *
  • Posts: 5
Re: Downloading Code::Blocks
« Reply #5 on: January 28, 2008, 02:42:43 am »
I try to install a library myself, I don't know if it worked (maybe no because this problem is not solves) but I don't compile it, I haved just install the files myself.

The first command return nothing, the second this :
Code: [Select]
Le programme 'wx-config' peut être trouvé dans les paquets suivants :
 * libwxbase2.6-dbg
 * libwxgtk2.6-dbg
 * libwxbase2.6-dev
 * libwxgtk2.4-dbg
 * libwxgtk2.6-dev
 * libwxgtk2.8-dev
 * libwxbase2.8-dev
 * libwxgtk2.8-dbg
 * libwxbase2.4-dev
 * libwxbase2.4-dbg
 * libwxgtk2.4-dev
 * libwxbase2.8-dbg
Essayez : sudo apt-get install <paquet sélectionné>
bash: wx-config : commande introuvable
« Last Edit: February 06, 2008, 04:29:54 am by Big Brother »

Offline Biplab

  • Developer
  • Lives here!
  • *****
  • Posts: 1874
    • Biplab's Blog
Re: Downloading Code::Blocks
« Reply #6 on: February 02, 2008, 06:40:17 am »
Code: [Select]
Fatal Error: Mismatch between the program and library build versions detected.
The library used 2.8 (no debug,Unicode,compiler with C++ ABI 1002,wx containers,compatible with 2.4,compatible with 2.6),
and your program used 2.8 (no debug,Unicode,compiler with C++ ABI 1002,wx containers,compatible with 2.6).
Abandon (core dumped)

Try compiling wxWidgets with --enable-compat26 --disable-compat24 (Use this while configuring wx) and then install it. Please do check for the correct options in case configure returns any error message. It should solve your problem.
Be a part of the solution, not a part of the problem.

Offline Big Brother

  • Single posting newcomer
  • *
  • Posts: 5
Re: Downloading Code::Blocks
« Reply #7 on: February 06, 2008, 02:24:08 pm »
Thank for all, I installed libwxgtk2.8-dev and it works then!