Author Topic: The 03 January 2008 build (4771) is out.  (Read 40773 times)

Offline Darck

  • Multiple posting newcomer
  • *
  • Posts: 16
Re: The 03 January 2008 build (4771) is out.
« Reply #30 on: January 06, 2008, 07:46:13 pm »
Which version of Ubuntu do you use ?
There are wxWidgets2.8.7 packages for dapper, feisty and gutsy and 2.8.6 packages for edgy on the wxWidgets-server (look here how to install them).
If none of the versions work you can try to build it from source.
The Ubuntu-sources are on the same server.
If you have build-dependency problems when you use "dpkg-buildpackage", install all the missing packages in the newest version you get for your Ubuntu-version.
And if you have done this (don't try it without) you can run "dpkg-buildpackage -d" to override the dependencies on special versions. This might work. You can also try to fix the "debian/control"-file to work with your Ubuntu-suite.
Normally a wxWidgets-version for an older Ubuntu-suite should work with yours.
I use wxWidgets for debian-edge on edge, lenny, sid and experimental without problems.

I'm using Ubuntu 7.1 - Gutsy. I partially resolved problemm installing older Code::Blocks from
http://prdownload.berlios.de/codeblocks/CB_20070907_rev4439_Ubuntu6.10+7.04_wx2.8.4.tar.gz


I've found info how to add wxWidgets to repository:

build against wxWidgets 2.8.7.1 from:
deb http://apt.wxwidgets.org/ gutsy-wx main

key-import to apt's trusted keys:
wget -q http://apt.wxwidgets.org/key.asc -O- | sudo apt-key add -

But problem is, that, when i tray to install wxWidgets, it says that i have too old libpango. There isn't any newer in repository. There is newer for Ubuntu Hardy. and here:http://ftp.debian.org/debian/pool/main/p/pango1.0/ I downloaded it, tried to install and the same - it says me i have too old libc6 and libdatrie, i tried install newer libdatrie and the same. ENDLESS CIRCLE !!!

How to simply install wxWidgets 2.8.7.1 without all this complications.

It's not a problem that i have to install wxWidgets from source, but problem that every library need another newer library (or more than one) on lowel level. I would have to do big tree of upgrades to finally install wxWidgets.

Or maybe i can ignore wxWidgets dependency to libpango in some way and install it anyway.
It needs libpango 1.18.3 and I have 1.18.2 version, so maybe 0.00.1 isn't big deal?

If yes can I install it by :
sudo apt-get --force-yes upgrade libwxgtk2.8
« Last Edit: January 06, 2008, 07:48:11 pm by Darck »

Offline jens

  • Administrator
  • Lives here!
  • *****
  • Posts: 7265
    • Jens' unofficial debian-repository for the Code::Blocks - IDE
Re: The 03 January 2008 build (4771) is out.
« Reply #31 on: January 06, 2008, 08:23:55 pm »
Or maybe i can ignore wxWidgets dependency to libpango in some way and install it anyway.
It needs libpango 1.18.3 and I have 1.18.2 version, so maybe 0.00.1 isn't big deal?

If yes can I install it by :
sudo apt-get --force-yes upgrade libwxgtk2.8

You can try to do so.
Or you can try wxWidgets-packages for feisty, they depend on libpango >= 1.16.2.

Offline Darck

  • Multiple posting newcomer
  • *
  • Posts: 16
Re: The 03 January 2008 build (4771) is out.
« Reply #32 on: January 06, 2008, 08:46:28 pm »
You can try to do so.
Or you can try wxWidgets-packages for feisty, they depend on libpango >= 1.16.2.

Great thanks. That solved all problems and installed Code::Blocks smoothly. They should note ad wxWidgets page that packages for gutsy are really in folder fo feisty.

Offline jens

  • Administrator
  • Lives here!
  • *****
  • Posts: 7265
    • Jens' unofficial debian-repository for the Code::Blocks - IDE
Re: The 03 January 2008 build (4771) is out.
« Reply #33 on: January 06, 2008, 09:03:30 pm »
They should note ad wxWidgets page that packages for gutsy are really in folder fo feisty.
I think the gutsy packages are in the right place, but the package-maintainer does not only use the gutsy standard libraries, what of course should never happen.

Ryen_Lee

  • Guest
Re: The 03 January 2008 build (4771) is out.
« Reply #34 on: January 07, 2008, 11:14:47 am »
I just can not get the file.When I click the link,I only get a file of 3.2kb,and it's a htm file.I think there is something wrong on the server!Can anybody help me?
(PS:I'm from China)

Offline jens

  • Administrator
  • Lives here!
  • *****
  • Posts: 7265
    • Jens' unofficial debian-repository for the Code::Blocks - IDE
Re: The 03 January 2008 build (4771) is out.
« Reply #35 on: January 07, 2008, 11:22:30 am »
I just can not get the file.When I click the link,I only get a file of 3.2kb,and it's a htm file.I think there is something wrong on the server!Can anybody help me?
(PS:I'm from China)

Don't try to save the link target, it points to a download page only (that means you should only left-click on it).
direct link:
http://download.berlios.de/codeblocks/CB_20080103_rev4771_win32.7z or
http://download2.berlios.de/codeblocks/CB_20080103_rev4771_win32.7z

Offline Grom

  • Almost regular
  • **
  • Posts: 206
Re: The 03 January 2008 build (4771) is out.
« Reply #36 on: January 07, 2008, 07:38:00 pm »
Would be grate to have in wxSmith a set of tools for work with DB. Say similar to the Borland's components. I have tried in wxSmith to repeat the GUI of one my old project, which was done long long time ago in Borlands IDE. It almost work!!! So I believe, that after official release of C::B will come up - the users will implement all necessary items.
gcc+winXP+suse.

Offline byo

  • Plugin developer
  • Lives here!
  • ****
  • Posts: 837
Re: The 03 January 2008 build (4771) is out.
« Reply #37 on: January 07, 2008, 10:11:10 pm »
Would be grate to have in wxSmith a set of tools for work with DB. Say similar to the Borland's components. I have tried in wxSmith to repeat the GUI of one my old project, which was done long long time ago in Borlands IDE. It almost work!!! So I believe, that after official release of C::B will come up - the users will implement all necessary items.

Please don't start...

Offline Darck

  • Multiple posting newcomer
  • *
  • Posts: 16
Re: The 03 January 2008 build (4771) is out.
« Reply #38 on: January 08, 2008, 02:06:20 am »
yes, probably official release would be easier to promote.