Author Topic: The 03 January 2008 build (4771) is out.  (Read 40759 times)

Offline killerbot

  • Administrator
  • Lives here!
  • *****
  • Posts: 5193
The 03 January 2008 build (4771) is out.
« on: January 04, 2008, 12:47:06 am »
Get quick announcements through the RSS feed http://www.codeblocks.org/nightly/CodeBlock_RSS.xml

Before you use a nightly make sure you understand how it works.

A link to the unicode windows wxWidget dll for Code::Blocks : http://prdownload.berlios.de/codeblocks/wxmsw28u_gcc_cb_wx287.7z

For those who might need this one (when no MingW installed on your system) : the mingw10m.dll : http://prdownload.berlios.de/codeblocks/mingwm10_gcc421.7z

The 03 January 2008 build is out.
  - Windows :
   http://prdownload.berlios.de/codeblocks/CB_20080103_rev4771_win32.7z
  - Linux :
   none

Resolved Fixed:

  • CodeSnippets 1.2.110 2008/01/2 : Change GetMessageManager to GetLogManager for wxMAC.
  • lib_finder:
    * Switched naming from "global var" to "short code" (lib_finder doesn't use global vars only so the name was incorrect), NOTE: this change require rescanning libraries
    * Added support for predefined results (stored in xml files simillarily to search filters) - when installing library it may be easily registered inside lib_finder by simply adding xml file with description of it, it also support relative paths (so it can be used on pen-drives etc)
    * Fixed bug in generation of defines while updating compile options
  • fixed several crashes of help plugin if no help files are defined
  • applied patch by jens to enable opening source files via double-click in explorer again
list]

Regressions/Confirmed/Annoying/Common bugs:

  • toolbar-images-not-changing-state (is a wx problem/Win XP problem)

[/list]

Offline pasgui

  • Almost regular
  • **
  • Posts: 165
    • LGP
Re: The 03 January 2008 build (4771) is out.
« Reply #1 on: January 04, 2008, 02:08:17 am »
Build for Ubuntu i386 can be found here

Best regards, pasgui

Offline Acki

  • Multiple posting newcomer
  • *
  • Posts: 100
Re: The 03 January 2008 build (4771) is out.
« Reply #2 on: January 04, 2008, 03:10:54 am »
Yeah, now the double clicking works for all file types again, thx !!! :)
But there is still a little problem with this:
as usual C::B is not loaded and you open a file by double click (.workspace, .cbp, .cpp and .h tested)
now the file/project is loaded and everything works fine with C::B
but the folder containing the file is still blocked (no reactions, no updating, just white screen) and after closing C::B this "file not found" error message still appears !!!
this is for any folder and also for the desktop when I open a file there by double click...

Offline jens

  • Administrator
  • Lives here!
  • *****
  • Posts: 7265
    • Jens' unofficial debian-repository for the Code::Blocks - IDE
Re: The 03 January 2008 build (4771) is out.
« Reply #3 on: January 04, 2008, 07:06:35 am »
Binaries for the three debian main-suites and sources can be found on my server (see signature).
I just put svn4770 into my repo. The only difference between svn4770 and svn4771 is one startup-tip.
I uploaded the version yesterday from work via DSL and don't want to upload the newer version from at home, because I only have ISDN  :( here.

Offline jens

  • Administrator
  • Lives here!
  • *****
  • Posts: 7265
    • Jens' unofficial debian-repository for the Code::Blocks - IDE
Re: The 03 January 2008 build (4771) is out.
« Reply #4 on: January 04, 2008, 07:14:28 am »
Yeah, now the double clicking works for all file types again, thx !!! :)
But there is still a little problem with this:
as usual C::B is not loaded and you open a file by double click (.workspace, .cbp, .cpp and .h tested)
now the file/project is loaded and everything works fine with C::B
but the folder containing the file is still blocked (no reactions, no updating, just white screen) and after closing C::B this "file not found" error message still appears !!!
this is for any folder and also for the desktop when I open a file there by double click...


Does the "file not found" message appear in a C::B related window, or imight there be a hook to another application that should look at opened files (virus-scanner for example) but is missing?
Have you tried to minimize all windows one by one (with the minimize-button of the windows, not the show-desktop button from quickstart)?
Sometimes modal dialogs are opened and wait for user-action (and of course block their parent-window/-application), but are not visible, because other applications (in your case C::B) are in the foreground.

I ask because I don't have this problem. Neither on W2K nor on XP-Professional SP2.

Offline alchemist

  • Multiple posting newcomer
  • *
  • Posts: 38
    • My Blog
Re: The 03 January 2008 build (4771) is out.
« Reply #5 on: January 04, 2008, 11:37:26 am »
Hello,

I have a problem when i double-click on a .cbp file from Windows exporer or any explorer-like (Total Commander) : it seems C::B doesn't reply to the DDE message "open", such that the caller (the explorer windows) doesn't respond until C::B closes and we get an error message "file not found" on the caller explorer window.

I tested and observed that with all the recent releases, but I don't know if this is a bug or regression (before, I opened the projects from C::B)

[attachment deleted by admin]
Kind Regards,
Xavier Miller.
http://xaviermiller.be

Offline obijohn

  • Single posting newcomer
  • *
  • Posts: 4
Re: The 03 January 2008 build (4771) is out.
« Reply #6 on: January 04, 2008, 12:32:03 pm »
Hello,

I have a problem when i double-click on a .cbp file from Windows exporer or any explorer-like (Total Commander) : it seems C::B doesn't reply to the DDE message "open", such that the caller (the explorer windows) doesn't respond until C::B closes and we get an error message "file not found" on the caller explorer window.

I tested and observed that with all the recent releases, but I don't know if this is a bug or regression (before, I opened the projects from C::B)

Right, this hasn't worked for me for a while now, at least since the 4719 build which is when I first noticed it. If C::B is already open, clicking on an associated file does open it properly. But it doesn't if C::B is *not* already open.

Offline lobby

  • Multiple posting newcomer
  • *
  • Posts: 10
Re: The 03 January 2008 build (4771) is out.
« Reply #7 on: January 04, 2008, 03:16:54 pm »
the DDE bug should be added to the Regressions/Confirmed/Annoying/Common bugs

Offline Acki

  • Multiple posting newcomer
  • *
  • Posts: 100
Re: The 03 January 2008 build (4771) is out.
« Reply #8 on: January 04, 2008, 03:44:54 pm »
Does the "file not found" message appear in a C::B related window, or imight there be a hook to another application that should look at opened files (virus-scanner for example) but is missing?
Have you tried to minimize all windows one by one (with the minimize-button of the windows, not the show-desktop button from quickstart)?
Sometimes modal dialogs are opened and wait for user-action (and of course block their parent-window/-application), but are not visible, because other applications (in your case C::B) are in the foreground.

I ask because I don't have this problem. Neither on W2K nor on XP-Professional SP2.
no, the only app that is running is Norton firewall, nothing else...
and even if I disable the firewall the problem presists...
and my system is WXP-pro (sp2)

Offline Albenejean

  • Multiple posting newcomer
  • *
  • Posts: 65
Re: The 03 January 2008 build (4771) is out.
« Reply #9 on: January 04, 2008, 03:49:13 pm »
Quote
Quote from: Acki on Today at 02:10:54 AM
Yeah, now the double clicking works for all file types again, thx !!! Smile
But there is still a little problem with this:
as usual C::B is not loaded and you open a file by double click (.workspace, .cbp, .cpp and .h tested)
now the file/project is loaded and everything works fine with C::B
but the folder containing the file is still blocked (no reactions, no updating, just white screen) and after closing C::B this "file not found" error message still appears !!!
this is for any folder and also for the desktop when I open a file there by double click...
As I said many times before, you have to disable the symbol browser! There is probably a bug with it.

Offline dannyyy

  • Multiple posting newcomer
  • *
  • Posts: 23
Re: The 03 January 2008 build (4771) is out.
« Reply #10 on: January 04, 2008, 04:55:09 pm »
I can't connect to the Berlios SVN...

Offline stahta01

  • Lives here!
  • ****
  • Posts: 6671
    • My Best Post
Re: The 03 January 2008 build (4771) is out.
« Reply #11 on: January 04, 2008, 05:00:15 pm »
I can't connect to the Berlios SVN...

EDIT: The status page is backup, I suggest trying to download again.

I can not connect either,I can not even see this page this is normally up

http://monitor.berlios.de/berlios-status/index.php

I was thinking it was a local DNS issue, my ISP, Verizon DSL, seems to have DNS problems a lot more than you would think a big company should. But, it looks like something is wrong out the USA.

Tim S
« Last Edit: January 04, 2008, 06:11:13 pm by stahta01 »
C Programmer working to learn more about C++ and Git.
On Windows 7 64 bit and Windows 10 32 bit.
On Debian Stretch, compiling CB Trunk against wxWidgets 3.0.
--
When in doubt, read the CB WiKi FAQ. http://wiki.codeblocks.org

Offline jens

  • Administrator
  • Lives here!
  • *****
  • Posts: 7265
    • Jens' unofficial debian-repository for the Code::Blocks - IDE
Re: The 03 January 2008 build (4771) is out.
« Reply #12 on: January 04, 2008, 07:29:49 pm »
I was thinking it was a local DNS issue, my ISP, Verizon DSL, seems to have DNS problems a lot more than you would think a big company should. But, it looks like something is wrong out the USA.

Tim S

I wasn't even able to connect from germany, so I think it was a local problem.

Offline Acki

  • Multiple posting newcomer
  • *
  • Posts: 100
Re: The 03 January 2008 build (4771) is out.
« Reply #13 on: January 04, 2008, 08:22:55 pm »
As I said many times before, you have to disable the symbol browser! There is probably a bug with it.
"many times before" is nice, it was just the last thread (release)... :lol:
Well, OK this works, but this is a crappy solution (as I said many times before, too), I just wanted to mention that this error still exists !!! ;)

Offline Albenejean

  • Multiple posting newcomer
  • *
  • Posts: 65
Re: The 03 January 2008 build (4771) is out.
« Reply #14 on: January 04, 2008, 08:59:19 pm »
Quote
I just wanted to mention that this error still exists !!! Wink
The best way would be to fill a bug report.