Author Topic: MSVCP71D.dll not found in debug mode  (Read 4684 times)

cive

  • Guest
MSVCP71D.dll not found in debug mode
« on: January 03, 2008, 12:19:39 am »
Hi all,

I am new to Code::Blocks and have just started porting my codes from wxDevC++.  I have configured Code::blocks to use the Visual C++ Express 2008 compiler.  I am finding that my codes compile properly.  However, when I try to run in debug mode I get the following error message:

This application has failed to start because MSVCP71D.dll was not found.

However, the application is able to run without this error in release mode.  Can someone tell me how to solve this error?  I was not able to find the .dll file anywhere.

Any help is greatly appreciated!!   

Offline Albenejean

  • Multiple posting newcomer
  • *
  • Posts: 65
Re: MSVCP71D.dll not found in debug mode
« Reply #1 on: January 03, 2008, 12:41:28 am »
This Dll is for Microsoft Visual C++ 2003 and not Visual C++ 2005. Check your linker settings.

cive

  • Guest
Re: MSVCP71D.dll not found in debug mode
« Reply #2 on: January 03, 2008, 01:16:56 am »
Thanks for your reply! 

What would I need to change in the linker settings?  By the way, these were the steps I used to setup to use Visual C++ express 2008

Under Toolchain executables tab, installation directory to:
C:\Program Files\Microsoft Visual Studio 9.0\VC

Under Additional Paths:
C:\Program Files\Microsoft SDKs\Windows\v6.0A\bin
C:\Program Files\Debugging Tools for Windows (cdb.exe)
C:\Program Files\Microsoft Visual Studio 9.0\Common7\IDE

Search Directories tab compiler search paths set to:
C:\Program Files\Microsoft Visual Studio 9.0\VC\include
C:\Program Files\Microsoft SDKs\Windows\v6.0A\Include
Set the linker search paths to:
C:\Program Files\Microsoft Visual Studio 9.0\VC\lib
C:\Program Files\Microsoft SDKs\Windows\v6.0A\Lib

resource compiler search paths to:
C:\Program Files\Microsoft Visual Studio 9.0\VC\include
C:\Program Files\Microsoft SDKs\Windows\v6.0A\Include


Thanks a lot for your help!