Author Topic: building with codeblocks - unnecessary error messages  (Read 1900 times)

Offline darthdespotism

  • Almost regular
  • **
  • Posts: 163
    • Coder's Nemesis
building with codeblocks - unnecessary error messages
« on: November 20, 2007, 06:34:41 pm »
I'm trying to change some settings in an C::B project. By doing this I triggered the following error
Code: [Select]
-------------- Build: ServerDebug in TBRTS ---------------

g++ -Wall  -g    -I/home/darthdespotism/dev/TBRTS/src -I/usr/include/c++/4.1/tr1 -I/usr/include/c++/4.1 -I/usr/bin/include  -c /home/darthdespotism/dev/TBRTS/src/server.cpp -o obj/SDebug/src/server.o
g++ -L/usr/bin/lib  -o bin/Debug/server obj/SDebug/src/ai/AStar.o obj/SDebug/src/net/common/ANetwork.o obj/SDebug/src/net/common/CMailDroid.o obj/SDebug/src/server.o obj/SDebug/src/utf8enc/utf8enc.o obj/SDebug/src/util/threads/locks.o obj/SDebug/src/xml/ticpp.o obj/SDebug/src/xml/tinystr.o obj/SDebug/src/xml/tinyxml.o obj/SDebug/src/xml/tinyxmlerror.o obj/SDebug/src/xml/tinyxmlparser.o   -pthread 
/usr/include/c++/4.1/tr1/functional: In member function »size_t std::tr1::hash<std::basic_string<char, std::char_traits<char>, std::allocator<char> > >::operator()(const std::string&) const«:
/usr/include/c++/4.1/tr1/functional:1194: Fehler: invalid use of undefined type »const struct std::basic_string<char, std::char_traits<char>, std::allocator<char> >«
/usr/lib/gcc/i486-linux-gnu/4.1.2/../../../../include/c++/4.1.2/bits/stringfwd.h:56: Fehler: declaration of »const struct std::basic_string<char, std::char_traits<char>, std::allocator<char> >«
/usr/include/c++/4.1/tr1/functional:1194: Fehler: invalid use of undefined type »const struct std::basic_string<char, std::char_traits<char>, std::allocator<char> >«
/usr/lib/gcc/i486-linux-gnu/4.1.2/../../../../include/c++/4.1.2/bits/stringfwd.h:56: Fehler: declaration of »const struct std::basic_string<char, std::char_traits<char>, std::allocator<char> >«
/usr/include/c++/4.1/tr1/functional: In member function »size_t std::tr1::hash<std::basic_string<wchar_t, std::char_traits<wchar_t>, std::allocator<wchar_t> > >::operator()(const std::wstring&) const«:
/usr/include/c++/4.1/tr1/functional:1205: Fehler: invalid use of undefined type »const struct std::basic_string<wchar_t, std::char_traits<wchar_t>, std::allocator<wchar_t> >«
/usr/lib/gcc/i486-linux-gnu/4.1.2/../../../../include/c++/4.1.2/bits/stringfwd.h:56: Fehler: declaration of »const struct std::basic_string<wchar_t, std::char_traits<wchar_t>, std::allocator<wchar_t> >«
/usr/include/c++/4.1/tr1/functional:1206: Fehler: invalid use of undefined type »const struct std::basic_string<wchar_t, std::char_traits<wchar_t>, std::allocator<wchar_t> >«
/usr/lib/gcc/i486-linux-gnu/4.1.2/../../../../include/c++/4.1.2/bits/stringfwd.h:56: Fehler: declaration of »const struct std::basic_string<wchar_t, std::char_traits<wchar_t>, std::allocator<wchar_t> >«
Process terminated with status 1 (0 minutes, 1 seconds)
8 errors, 0 warnings
 

which is strange as the line compiles frome the terminal just fine.

EDIT://
Looking a bit deeper into this I'm about to suggest that this is a multithreading problem in C::B as the first command that seems to execute yust fine in Code::Blocks build LOG actually fails on my terminal (I configured C::B to use both of my cores for build)

As of now this is either a feature request or a bug report depending on how this behaviour is seen by the C::B devs
« Last Edit: November 20, 2007, 07:11:58 pm by darthdespotism »