Author Topic: HelloWorld plugin problems installing  (Read 10961 times)

Offline ankurnigam18

  • Single posting newcomer
  • *
  • Posts: 4
Re: HelloWorld plugin problems installing
« Reply #15 on: May 17, 2011, 06:10:38 pm »
Hi everyone,
I find that nobody is answering the original question:

Can you guys help me out by telling me where to find out the application log?

Does the application log really exist? And if yes, where is it?

Thanks,
Ankur

Offline stahta01

  • Lives here!
  • ****
  • Posts: 6667
    • My Best Post
Re: HelloWorld plugin problems installing
« Reply #16 on: May 17, 2011, 06:39:52 pm »
Hi everyone,
I find that nobody is answering the original question:

Can you guys help me out by telling me where to find out the application log?

Does the application log really exist? And if yes, where is it?

Thanks,
Ankur

I find that you have trouble reading; and, you open many years old threads for little reason.

Tim S.

The lower window with build log and build messages; right click on its title bar and see if you can turn it on.

The last few builds, I think it might have been called "Code::Blocks" under toggle option.

Tim S
« Last Edit: May 17, 2011, 06:42:16 pm by stahta01 »
C Programmer working to learn more about C++ and Git.
On Windows 7 64 bit and Windows 10 32 bit.
On Debian Stretch, compiling CB Trunk against wxWidgets 3.0.
--
When in doubt, read the CB WiKi FAQ. http://wiki.codeblocks.org

Offline ankurnigam18

  • Single posting newcomer
  • *
  • Posts: 4
Re: HelloWorld plugin problems installing
« Reply #17 on: May 17, 2011, 11:57:32 pm »
Hi everyone,
My apologies to Tim S. (stahta01), for rousing his ire over a seemingly dumb question.
Thanks a lot for going through the trouble for finding an answer for it, and the prompt reply.

Anyone trying to find "application log" should do the following:
1) In Menus (File, Edit, etc.), go to View and make sure that 'Logs' is enabled.
2) Now, there would be a lower window with the name "Logs & others" with many tabs.
3) There is a tab in it with the name "Code::Blocks", it is actually what you were actually looking for (the application log).
4) If you don't find it, just right-click a tab, go to 'Toggle' and ensure that "Code::Blocks" is enabled.

It seems so clean in the beginning that nobody gives it a second thought.
But, hang on friend, there is a scroll bar on the right.
Once you start scrolling, now it seems more like a log with lots of lines.

Hope it is clear to everyone and nobody has any problem with it.

Note: This holds true for Code::Blocks version 10.05.

Thanks,
Ankur

Offline Pecan

  • Plugin developer
  • Lives here!
  • ****
  • Posts: 2178
Re: HelloWorld plugin problems installing
« Reply #18 on: May 18, 2011, 12:50:14 pm »
I confirm. On startup, the log does not show up until the user scrolls in the CodeBlocks log window.

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 12090
    • Travis build status
Re: HelloWorld plugin problems installing
« Reply #19 on: May 18, 2011, 01:54:17 pm »
This is windows only problem, happens, too, for the debugger's debug log
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Offline MortenMacFly

  • Administrator
  • Lives here!
  • *****
  • Posts: 9508
Re: HelloWorld plugin problems installing
« Reply #20 on: May 18, 2011, 08:24:40 pm »
I confirm. On startup, the log does not show up until the user scrolls in the CodeBlocks log window.
This "bug" is there for ages is is IMHO actually a WX issue. I have the same in several other wx apps.
Compiler logging: Settings->Compiler & Debugger->tab "Other"->Compiler logging="Full command line"
C::B Manual: http://www.codeblocks.org/docs/main_codeblocks_en.html
C::B FAQ: http://wiki.codeblocks.org/index.php?title=FAQ