Author Topic: Trying to install codeblocks on lubuntu. Cant get it done  (Read 1852 times)

somerandomdude

  • Guest
Trying to install codeblocks on lubuntu. Cant get it done
« on: April 14, 2016, 09:55:45 pm »
Hi so im trying to install code::blocks for learning to program c. Ive gotten the file and go to codeblocks-16.01-1.el5.x86_64 in mij terminal.

When I try to install (rpm -ivh codeblocks-16.01-1.el5.x86_64.rpm )it it says:

waarschuwing: codeblocks-16.01-1.el5.x86_64.rpm: Header V3 RSA/SHA1 Signature, key ID b83c5c98: NOKEY
fout: Failed dependencies:
   /bin/sh is needed by codeblocks-16.01-1.el5.x86_64
   codeblocks-libs = 16.01 is needed by codeblocks-16.01-1.el5.x86_64
   libatk-1.0.so.0()(64bit) is needed by codeblocks-16.01-1.el5.x86_64
   libc.so.6()(64bit) is needed by codeblocks-16.01-1.el5.x86_64
   libc.so.6(GLIBC_2.2.5)(64bit) is needed by codeblocks-16.01-1.el5.x86_64
   libc.so.6(GLIBC_2.3)(64bit) is needed by codeblocks-16.01-1.el5.x86_64
   libc.so.6(GLIBC_2.3.4)(64bit) is needed by codeblocks-16.01-1.el5.x86_64
   libc.so.6(GLIBC_2.4)(64bit) is needed by codeblocks-16.01-1.el5.x86_64
   libcairo.so.2()(64bit) is needed by codeblocks-16.01-1.el5.x86_64
   libcodeblocks.so.0()(64bit) is needed by codeblocks-16.01-1.el5.x86_64
   libdl.so.2()(64bit) is needed by codeblocks-16.01-1.el5.x86_64
   libgcc_s.so.1()(64bit) is needed by codeblocks-16.01-1.el5.x86_64
   libgcc_s.so.1(GCC_3.0)(64bit) is needed by codeblocks-16.01-1.el5.x86_64
   libgdk-x11-2.0.so.0()(64bit) is needed by codeblocks-16.01-1.el5.x86_64
   libgdk_pixbuf-2.0.so.0()(64bit) is needed by codeblocks-16.01-1.el5.x86_64
   libglib-2.0.so.0()(64bit) is needed by codeblocks-16.01-1.el5.x86_64
   libgmodule-2.0.so.0()(64bit) is needed by codeblocks-16.01-1.el5.x86_64
   libgobject-2.0.so.0()(64bit) is needed by codeblocks-16.01-1.el5.x86_64
   libgtk-x11-2.0.so.0()(64bit) is needed by codeblocks-16.01-1.el5.x86_64
   libm.so.6()(64bit) is needed by codeblocks-16.01-1.el5.x86_64
   libm.so.6(GLIBC_2.2.5)(64bit) is needed by codeblocks-16.01-1.el5.x86_64
   libpango-1.0.so.0()(64bit) is needed by codeblocks-16.01-1.el5.x86_64
   libpangocairo-1.0.so.0()(64bit) is needed by codeblocks-16.01-1.el5.x86_64
   libpthread.so.0()(64bit) is needed by codeblocks-16.01-1.el5.x86_64
   libpthread.so.0(GLIBC_2.2.5)(64bit) is needed by codeblocks-16.01-1.el5.x86_64
   libstdc++.so.6()(64bit) is needed by codeblocks-16.01-1.el5.x86_64
   libstdc++.so.6(CXXABI_1.3)(64bit) is needed by codeblocks-16.01-1.el5.x86_64
   libstdc++.so.6(CXXABI_1.3.1)(64bit) is needed by codeblocks-16.01-1.el5.x86_64
   libstdc++.so.6(GLIBCXX_3.4)(64bit) is needed by codeblocks-16.01-1.el5.x86_64
   libwx_baseu-2.8.so.0()(64bit) is needed by codeblocks-16.01-1.el5.x86_64
   libwx_baseu-2.8.so.0(WXU_2.8)(64bit) is needed by codeblocks-16.01-1.el5.x86_64
   libwx_baseu-2.8.so.0(WXU_2.8.2)(64bit) is needed by codeblocks-16.01-1.el5.x86_64
   libwx_baseu_net-2.8.so.0()(64bit) is needed by codeblocks-16.01-1.el5.x86_64
   libwx_baseu_net-2.8.so.0(WXU_2.8)(64bit) is needed by codeblocks-16.01-1.el5.x86_64
   libwx_baseu_xml-2.8.so.0()(64bit) is needed by codeblocks-16.01-1.el5.x86_64
   libwx_baseu_xml-2.8.so.0(WXU_2.8)(64bit) is needed by codeblocks-16.01-1.el5.x86_64
   libwx_gtk2u_adv-2.8.so.0()(64bit) is needed by codeblocks-16.01-1.el5.x86_64
   libwx_gtk2u_adv-2.8.so.0(WXU_2.8)(64bit) is needed by codeblocks-16.01-1.el5.x86_64
   libwx_gtk2u_aui-2.8.so.0()(64bit) is needed by codeblocks-16.01-1.el5.x86_64
   libwx_gtk2u_aui-2.8.so.0(WXU_2.8)(64bit) is needed by codeblocks-16.01-1.el5.x86_64
   libwx_gtk2u_aui-2.8.so.0(WXU_2.8.5)(64bit) is needed by codeblocks-16.01-1.el5.x86_64
   libwx_gtk2u_core-2.8.so.0()(64bit) is needed by codeblocks-16.01-1.el5.x86_64
   libwx_gtk2u_core-2.8.so.0(WXU_2.8)(64bit) is needed by codeblocks-16.01-1.el5.x86_64
   libwx_gtk2u_core-2.8.so.0(WXU_2.8.5)(64bit) is needed by codeblocks-16.01-1.el5.x86_64
   libwx_gtk2u_html-2.8.so.0()(64bit) is needed by codeblocks-16.01-1.el5.x86_64
   libwx_gtk2u_html-2.8.so.0(WXU_2.8)(64bit) is needed by codeblocks-16.01-1.el5.x86_64
   libwx_gtk2u_qa-2.8.so.0()(64bit) is needed by codeblocks-16.01-1.el5.x86_64
   libwx_gtk2u_qa-2.8.so.0(WXU_2.8)(64bit) is needed by codeblocks-16.01-1.el5.x86_64
   libwx_gtk2u_richtext-2.8.so.0()(64bit) is needed by codeblocks-16.01-1.el5.x86_64
   libwx_gtk2u_xrc-2.8.so.0()(64bit) is needed by codeblocks-16.01-1.el5.x86_64
   libwx_gtk2u_xrc-2.8.so.0(WXU_2.8)(64bit) is needed by codeblocks-16.01-1.el5.x86_64
   rtld(GNU_HASH) is needed by codeblocks-16.01-1.el5.x86_64
   wxGTK >= 2.8.0 is needed by codeblocks-16.01-1.el5.x86_64
   xterm is needed by codeblocks-16.01-1.el5.x86_64
[email protected]:~/Downloads/epel-5/x86_64$ ^C
[email protected]:~/Downloads/epel-5/x86_64$ rpm -ivh codeblocks-16.01-1.el5.x86_64.rpm^C
[email protected]:~/Downloads/epel-5/x86_64$ ^C
[email protected]:~/Downloads/epel-5/x86_64$ rpm -ivh codeblocks-16.01-1.el5.x86_64.rpm
rpm: RPM should not be used directly install RPM packages, use Alien instead!
rpm: However assuming you know what you are doing...
waarschuwing: codeblocks-16.01-1.el5.x86_64.rpm: Header V3 RSA/SHA1 Signature, key ID b83c5c98: NOKEY
fout: Failed dependencies:
   /bin/sh is needed by codeblocks-16.01-1.el5.x86_64
   codeblocks-libs = 16.01 is needed by codeblocks-16.01-1.el5.x86_64
   libatk-1.0.so.0()(64bit) is needed by codeblocks-16.01-1.el5.x86_64
   libc.so.6()(64bit) is needed by codeblocks-16.01-1.el5.x86_64
   libc.so.6(GLIBC_2.2.5)(64bit) is needed by codeblocks-16.01-1.el5.x86_64
   libc.so.6(GLIBC_2.3)(64bit) is needed by codeblocks-16.01-1.el5.x86_64
   libc.so.6(GLIBC_2.3.4)(64bit) is needed by codeblocks-16.01-1.el5.x86_64
   libc.so.6(GLIBC_2.4)(64bit) is needed by codeblocks-16.01-1.el5.x86_64
   libcairo.so.2()(64bit) is needed by codeblocks-16.01-1.el5.x86_64
   libcodeblocks.so.0()(64bit) is needed by codeblocks-16.01-1.el5.x86_64
   libdl.so.2()(64bit) is needed by codeblocks-16.01-1.el5.x86_64
   libgcc_s.so.1()(64bit) is needed by codeblocks-16.01-1.el5.x86_64
   libgcc_s.so.1(GCC_3.0)(64bit) is needed by codeblocks-16.01-1.el5.x86_64
   libgdk-x11-2.0.so.0()(64bit) is needed by codeblocks-16.01-1.el5.x86_64
   libgdk_pixbuf-2.0.so.0()(64bit) is needed by codeblocks-16.01-1.el5.x86_64
   libglib-2.0.so.0()(64bit) is needed by codeblocks-16.01-1.el5.x86_64
   libgmodule-2.0.so.0()(64bit) is needed by codeblocks-16.01-1.el5.x86_64
   libgobject-2.0.so.0()(64bit) is needed by codeblocks-16.01-1.el5.x86_64
   libgtk-x11-2.0.so.0()(64bit) is needed by codeblocks-16.01-1.el5.x86_64
   libm.so.6()(64bit) is needed by codeblocks-16.01-1.el5.x86_64
   libm.so.6(GLIBC_2.2.5)(64bit) is needed by codeblocks-16.01-1.el5.x86_64
   libpango-1.0.so.0()(64bit) is needed by codeblocks-16.01-1.el5.x86_64
   libpangocairo-1.0.so.0()(64bit) is needed by codeblocks-16.01-1.el5.x86_64
   libpthread.so.0()(64bit) is needed by codeblocks-16.01-1.el5.x86_64
   libpthread.so.0(GLIBC_2.2.5)(64bit) is needed by codeblocks-16.01-1.el5.x86_64
   libstdc++.so.6()(64bit) is needed by codeblocks-16.01-1.el5.x86_64
   libstdc++.so.6(CXXABI_1.3)(64bit) is needed by codeblocks-16.01-1.el5.x86_64
   libstdc++.so.6(CXXABI_1.3.1)(64bit) is needed by codeblocks-16.01-1.el5.x86_64
   libstdc++.so.6(GLIBCXX_3.4)(64bit) is needed by codeblocks-16.01-1.el5.x86_64
   libwx_baseu-2.8.so.0()(64bit) is needed by codeblocks-16.01-1.el5.x86_64
   libwx_baseu-2.8.so.0(WXU_2.8)(64bit) is needed by codeblocks-16.01-1.el5.x86_64
   libwx_baseu-2.8.so.0(WXU_2.8.2)(64bit) is needed by codeblocks-16.01-1.el5.x86_64
   libwx_baseu_net-2.8.so.0()(64bit) is needed by codeblocks-16.01-1.el5.x86_64
   libwx_baseu_net-2.8.so.0(WXU_2.8)(64bit) is needed by codeblocks-16.01-1.el5.x86_64
   libwx_baseu_xml-2.8.so.0()(64bit) is needed by codeblocks-16.01-1.el5.x86_64
   libwx_baseu_xml-2.8.so.0(WXU_2.8)(64bit) is needed by codeblocks-16.01-1.el5.x86_64
   libwx_gtk2u_adv-2.8.so.0()(64bit) is needed by codeblocks-16.01-1.el5.x86_64
   libwx_gtk2u_adv-2.8.so.0(WXU_2.8)(64bit) is needed by codeblocks-16.01-1.el5.x86_64
   libwx_gtk2u_aui-2.8.so.0()(64bit) is needed by codeblocks-16.01-1.el5.x86_64
   libwx_gtk2u_aui-2.8.so.0(WXU_2.8)(64bit) is needed by codeblocks-16.01-1.el5.x86_64
   libwx_gtk2u_aui-2.8.so.0(WXU_2.8.5)(64bit) is needed by codeblocks-16.01-1.el5.x86_64
   libwx_gtk2u_core-2.8.so.0()(64bit) is needed by codeblocks-16.01-1.el5.x86_64
   libwx_gtk2u_core-2.8.so.0(WXU_2.8)(64bit) is needed by codeblocks-16.01-1.el5.x86_64
   libwx_gtk2u_core-2.8.so.0(WXU_2.8.5)(64bit) is needed by codeblocks-16.01-1.el5.x86_64
   libwx_gtk2u_html-2.8.so.0()(64bit) is needed by codeblocks-16.01-1.el5.x86_64
   libwx_gtk2u_html-2.8.so.0(WXU_2.8)(64bit) is needed by codeblocks-16.01-1.el5.x86_64
   libwx_gtk2u_qa-2.8.so.0()(64bit) is needed by codeblocks-16.01-1.el5.x86_64
   libwx_gtk2u_qa-2.8.so.0(WXU_2.8)(64bit) is needed by codeblocks-16.01-1.el5.x86_64
   libwx_gtk2u_richtext-2.8.so.0()(64bit) is needed by codeblocks-16.01-1.el5.x86_64
   libwx_gtk2u_xrc-2.8.so.0()(64bit) is needed by codeblocks-16.01-1.el5.x86_64
   libwx_gtk2u_xrc-2.8.so.0(WXU_2.8)(64bit) is needed by codeblocks-16.01-1.el5.x86_64
   rtld(GNU_HASH) is needed by codeblocks-16.01-1.el5.x86_64
   wxGTK >= 2.8.0 is needed by codeblocks-16.01-1.el5.x86_64
   xterm is needed by codeblocks-16.01-1.el5.x86_64


I dont what to do. Its a really old computer. And i bought it so i can learn program. I am stuck. Its a x32 computer but the file says x64. Is that it? Please help.

Offline jens

  • Administrator
  • Lives here!
  • *****
  • Posts: 7265
    • Jens' unofficial debian-repository for the Code::Blocks - IDE
Re: Trying to install codeblocks on lubuntu. Cant get it done
« Reply #1 on: April 14, 2016, 10:15:51 pm »
First:
please use code- (or in your case quote-)tags to post log-content or source-code (the button with the hash-sign or the one with the text- balloon).

As far as I knolubuntu is based on ubuntu, so you should use packages for ubuntu and not for CentOS/RedHat.
And on a 32-bit system (aka i386 or i686) you can only use 32-bit packages.

Have closer look at http://codeblocks.org/downloads/26#linux go to the ubutu section and follow the instructions.