Author Topic: Linker Errors  (Read 21705 times)

Offline mspoerr

  • Single posting newcomer
  • *
  • Posts: 9
    • wktools
Linker Errors
« on: October 21, 2007, 11:07:12 pm »
Hello,

I am fighting now since three days with CB and wxWidgets. I am new to both of them, but before I start with the problem, here is my environment:
WinXP; Code::Blocks Build 4545; MS Visual Studio 2005 (I want to switch to Code::Blocks but use the VS compiler); wxWidgets 2.8.6 (wxPack for VS)

--

Problem: I start a new wxWidgets project with the wizard and add some controls with wxSmith. After that I build the project and get lots of LNK2001 linker errors. Which libs do I need? Are there any needed settings, the wizard does not set?

Thanks,
/mspoerr


testApp.obj:: error LNK2001: unresolved external symbol "public: virtual bool __thiscall wxApp::Initialize(int &,wchar_t * *)" (?Initialize@wxApp@@UAE_NAAHPAPA_W@Z)
testMain.obj:: error LNK2019: unresolved external symbol "wchar_t const * const wxEmptyString" (?wxEmptyString@@3PB_WB) referenced in function "protected: void __thiscall wxStringBase::Init(void)" (?Init@wxStringBase@@IAEXXZ)
testMain.obj:: error LNK2019: unresolved external symbol "protected: bool __thiscall wxStringBase::ConcatSelf(unsigned int,wchar_t const *,unsigned int)" (?ConcatSelf@wxStringBase@@IAE_NIPB_WI@Z) referenced in function "protected: bool __thiscall wxStringBase::ConcatSelf(unsigned int,wchar_t const *)" (?ConcatSelf@wxStringBase@@IAE_NIPB_W@Z)
testMain.obj:: error LNK2019: unresolved external symbol "protected: void __thiscall wxStringBase::InitWith(wchar_t const *,unsigned int,unsigned int)" (?InitWith@wxStringBase@@IAEXPB_WII@Z) referenced in function "public: __thiscall wxStringBase::wxStringBase(wchar_t const *)" (??0wxStringBase@@QAE@PB_W@Z)
wxpng.lib(wxpng_pngrutil.obj):: error LNK2019: unresolved external symbol __iob referenced in function _png_handle_pCAL
wxjpeg.lib(wxjpeg_jerror.obj):: error LNK2001: unresolved external symbol __iob
wxmsw28u.lib(monolib_log.obj):: error LNK2001: unresolved external symbol __iob
wxmsw28u.lib(monolib_msgout.obj):: error LNK2001: unresolved external symbol __iob
wxpng.lib(wxpng_pngerror.obj):: error LNK2001: unresolved external symbol __iob
wxpng.lib(wxpng_pngwutil.obj):: error LNK2001: unresolved external symbol __iob
wxmsw28u.lib(monolib_stopwatch.obj):: error LNK2019: unresolved external symbol _ftime referenced in function "class wxLongLongNative __cdecl wxGetLocalTimeMillis(void)" (?wxGetLocalTimeMillis@@YA?AVwxLongLongNative@@XZ)
wxmsw28u.lib(monolib_datetime.obj):: error LNK2019: unresolved external symbol _timezone referenced in function "int __cdecl GetTimeZone(void)" (?GetTimeZone@@YAHXZ)
wxmsw28u.lib(monolib_strconv.obj):: error LNK2019: unresolved external symbol _strdup referenced in function "public: __thiscall wxCharBuffer::wxCharBuffer(char const *)" (??0wxCharBuffer@@QAE@PBD@Z)
wxmsw28u.lib(monolib_xpmdecod.obj):: error LNK2001: unresolved external symbol _strdup
wxmsw28u.lib(monolib_textfile.obj):: error LNK2001: unresolved external symbol _strdup
bin\Release\test.exe:: fatal error LNK1120: 8 unresolved externals
:: === Build finished: 16 errors, 0 warnings ===

Offline TDragon

  • Lives here!
  • ****
  • Posts: 936
    • Twilight Dragon Media
Re: Linker Errors
« Reply #1 on: October 21, 2007, 11:42:42 pm »
Enable full command-line logging in your global compiler settings and post the build log.
http://tdm-gcc.tdragon.net/ - TDM-GCC compiler suite for Windows (GCC 5.1.0 2015-06-28, 32/64-bit, no extra DLLs)

Offline mspoerr

  • Single posting newcomer
  • *
  • Posts: 9
    • wktools
Re: Linker Errors
« Reply #2 on: October 22, 2007, 08:40:07 am »
Hi TDragon,

thank you for your answer.

LOG:
 
Code: [Select]
-------------- Build: Release in test ---------------
link.exe /nologo /subsystem:windows /LIBPATH:D:\wxWidgets2.8\lib\vc_lib /LIBPATH:"C:\Program Files\Microsoft Visual Studio 8\VC\lib" /LIBPATH:"C:\Program Files\Microsoft Visual Studio 8\VC\PlatformSDK\Lib" /LIBPATH:D:\wxWidgets2.8 /LIBPATH:D:\wxWidgets2.8\lib\vc_dll /LIBPATH:D:\wxWidgets2.8\lib\vc_lib  /out:bin\Release\test.exe msvcrt.lib wxmsw28u.lib wxpng.lib wxjpeg.lib wxtiff.lib wxzlib.lib winmm.lib rpcrt4.lib kernel32.lib user32.lib gdi32.lib winspool.lib comdlg32.lib advapi32.lib shell32.lib ole32.lib oleaut32.lib uuid.lib comctl32.lib wsock32.lib odbc32.lib  obj\Release\testApp.obj obj\Release\testMain.obj  obj\Release\resource.res  /NODEFAULTLIB /INCREMENTAL:NO /SUBSYSTEM:WINDOWS
testApp.obj : error LNK2001: unresolved external symbol "public: virtual bool __thiscall wxApp::Initialize(int &,wchar_t * *)" (?Initialize@wxApp@@UAE_NAAHPAPA_W@Z)
testMain.obj : error LNK2019: unresolved external symbol "wchar_t const * const wxEmptyString" (?wxEmptyString@@3PB_WB) referenced in function "protected: void __thiscall wxStringBase::Init(void)" (?Init@wxStringBase@@IAEXXZ)
testMain.obj : error LNK2019: unresolved external symbol "protected: bool __thiscall wxStringBase::ConcatSelf(unsigned int,wchar_t const *,unsigned int)" (?ConcatSelf@wxStringBase@@IAE_NIPB_WI@Z) referenced in function "protected: bool __thiscall wxStringBase::ConcatSelf(unsigned int,wchar_t const *)" (?ConcatSelf@wxStringBase@@IAE_NIPB_W@Z)
testMain.obj : error LNK2019: unresolved external symbol "protected: void __thiscall wxStringBase::InitWith(wchar_t const *,unsigned int,unsigned int)" (?InitWith@wxStringBase@@IAEXPB_WII@Z) referenced in function "public: __thiscall wxStringBase::wxStringBase(wchar_t const *)" (??0wxStringBase@@QAE@PB_W@Z)
wxpng.lib(wxpng_pngrutil.obj) : error LNK2019: unresolved external symbol __iob referenced in function _png_handle_pCAL
wxjpeg.lib(wxjpeg_jerror.obj) : error LNK2001: unresolved external symbol __iob
wxmsw28u.lib(monolib_log.obj) : error LNK2001: unresolved external symbol __iob
wxmsw28u.lib(monolib_msgout.obj) : error LNK2001: unresolved external symbol __iob
wxpng.lib(wxpng_pngerror.obj) : error LNK2001: unresolved external symbol __iob
wxpng.lib(wxpng_pngwutil.obj) : error LNK2001: unresolved external symbol __iob
wxmsw28u.lib(monolib_stopwatch.obj) : error LNK2019: unresolved external symbol _ftime referenced in function "class wxLongLongNative __cdecl wxGetLocalTimeMillis(void)" (?wxGetLocalTimeMillis@@YA?AVwxLongLongNative@@XZ)
wxmsw28u.lib(monolib_datetime.obj) : error LNK2019: unresolved external symbol _timezone referenced in function "int __cdecl GetTimeZone(void)" (?GetTimeZone@@YAHXZ)
wxmsw28u.lib(monolib_strconv.obj) : error LNK2019: unresolved external symbol _strdup referenced in function "public: __thiscall wxCharBuffer::wxCharBuffer(char const *)" (??0wxCharBuffer@@QAE@PBD@Z)
wxmsw28u.lib(monolib_xpmdecod.obj) : error LNK2001: unresolved external symbol _strdup
wxmsw28u.lib(monolib_textfile.obj) : error LNK2001: unresolved external symbol _strdup
bin\Release\test.exe : fatal error LNK1120: 8 unresolved externals
Process terminated with status 1120 (0 minutes, 5 seconds)
16 errors, 0 warnings
 

Offline mspoerr

  • Single posting newcomer
  • *
  • Posts: 9
    • wktools
Re: Linker Errors
« Reply #3 on: October 23, 2007, 10:35:29 pm »
Hello again,

any ideas for this problem?

Thanks,
/mspoerr

Offline TDragon

  • Lives here!
  • ****
  • Posts: 936
    • Twilight Dragon Media
Re: Linker Errors
« Reply #4 on: October 23, 2007, 10:49:27 pm »
I recently deleted my MSVC build of wxWidgets, so I'm rebuilding it. In the meantime, you might try choosing a DLL configuration (check the "Use wxWidgets DLL" box in the wizard) as opposed to a static and see if that works.
http://tdm-gcc.tdragon.net/ - TDM-GCC compiler suite for Windows (GCC 5.1.0 2015-06-28, 32/64-bit, no extra DLLs)

Offline mspoerr

  • Single posting newcomer
  • *
  • Posts: 9
    • wktools
Re: Linker Errors
« Reply #5 on: October 23, 2007, 11:12:20 pm »
Hi TDragon,

it's nearly the same - see log for details. How can I find out, which libs are missing?

/mspoerr

Quote
:: === test, Debug ===
testApp.obj:: error LNK2001: unresolved external symbol "public: virtual bool __thiscall wxApp::Initialize(int &,wchar_t * *)" (?Initialize@wxApp@@UAE_NAAHPAPA_W@Z)
testApp.obj:: error LNK2001: unresolved external symbol "public: virtual void __thiscall wxAppConsole::OnAssertFailure(wchar_t const *,int,wchar_t const *,wchar_t const *,wchar_t const *)" (?OnAssertFailure@wxAppConsole@@UAEXPB_WH000@Z)
testApp.obj:: error LNK2001: unresolved external symbol "public: virtual void __thiscall wxAppConsole::OnAssert(wchar_t const *,int,wchar_t const *,wchar_t const *)" (?OnAssert@wxAppConsole@@UAEXPB_WH00@Z)
testMain.obj:: error LNK2019: unresolved external symbol "__declspec(dllimport) public: class wxString & __thiscall wxString::operator<<(wchar_t const *)" (__imp_??6wxString@@QAEAAV0@PB_W@Z) referenced in function "class wxString __cdecl wxbuildinfo(enum wxbuildinfoformat)" (?wxbuildinfo@@YA?AVwxString@@W4wxbuildinfoformat@@@Z)
testMain.obj:: error LNK2019: unresolved external symbol "__declspec(dllimport) public: __thiscall wxString::wxString(wchar_t const *)" (__imp_??0wxString@@QAE@PB_W@Z) referenced in function "class wxString __cdecl wxbuildinfo(enum wxbuildinfoformat)" (?wxbuildinfo@@YA?AVwxString@@W4wxbuildinfoformat@@@Z)
testMain.obj:: error LNK2001: unresolved external symbol "__declspec(dllimport) wchar_t const * const wxEmptyString" (__imp_?wxEmptyString@@3PB_WB)
bin\Debug\test.exe:: fatal error LNK1120: 6 unresolved externals
:: === Build finished: 7 errors, 0 warnings ===

Offline TDragon

  • Lives here!
  • ****
  • Posts: 936
    • Twilight Dragon Media
Re: Linker Errors
« Reply #6 on: October 23, 2007, 11:27:51 pm »
All right, now I see what I missed earlier. You can see what's happening in the link.exe command line from the build log:
Code: [Select]
link.exe [...] /LIBPATH:D:\wxWidgets2.8\lib\vc_lib [...] /LIBPATH:D:\wxWidgets2.8 /LIBPATH:D:\wxWidgets2.8\lib\vc_dll /LIBPATH:D:\wxWidgets2.8\lib\vc_lib [...]
You've got library search directories for both the static version (vc_lib) and the DLL version (vc_dll) in your search path, so the compiler is picking the wrong wxmsw28u.lib to go with your configuration. Re-run the wxWidgets project wizard and don't add any extraneous search paths. If that's not an option, remove any inappropriate paths. Also, make sure that no wxWidgets paths are in your global (not project specific) compiler settings.
http://tdm-gcc.tdragon.net/ - TDM-GCC compiler suite for Windows (GCC 5.1.0 2015-06-28, 32/64-bit, no extra DLLs)

Offline mspoerr

  • Single posting newcomer
  • *
  • Posts: 9
    • wktools
Re: Linker Errors
« Reply #7 on: October 24, 2007, 12:11:43 am »
I now started a new project with debug and relase output, wxwidgets in a static lib and no unicode support. I deleted all wx paths at the global settings and checked the paths in the project settings and they seem to be ok, but the nothing changed at all. The log is slightly different because of the changed settings in the wizard. Attached is the new error log.

/mspoerr


Quote
-------------- Build: Debug in test1 ---------------
link.exe /nologo /subsystem:windows /LIBPATH:D:\wxWidgets2.8\lib\vc_lib /LIBPATH:"C:\Program Files\Microsoft Visual Studio 8\VC\lib" /LIBPATH:"C:\Program Files\Microsoft Visual Studio 8\VC\PlatformSDK\Lib"  /out:bin\Debug\test1.exe msvcrtd.lib wxmsw28d.lib wxpngd.lib wxjpegd.lib wxtiffd.lib wxzlibd.lib winmm.lib rpcrt4.lib kernel32.lib user32.lib gdi32.lib winspool.lib comdlg32.lib advapi32.lib shell32.lib ole32.lib oleaut32.lib uuid.lib comctl32.lib wsock32.lib odbc32.lib  obj\Debug\test1App.obj obj\Debug\test1Main.obj  obj\Debug\resource.res  /DEBUG /NODEFAULTLIB:libcmtd.lib /NODEFAULTLIB:msvcrt.lib /INCREMENTAL:NO /SUBSYSTEM:WINDOWS
wxpngd.lib(wxpng_pngwutil.obj) : error LNK2001: unresolved external symbol __iob
wxjpegd.lib(wxjpeg_jerror.obj) : error LNK2001: unresolved external symbol __iob
wxmsw28d.lib(monolib_log.obj) : error LNK2001: unresolved external symbol __iob
wxmsw28d.lib(monolib_msgout.obj) : error LNK2001: unresolved external symbol __iob
wxpngd.lib(wxpng_pngerror.obj) : error LNK2001: unresolved external symbol __iob
wxpngd.lib(wxpng_pngrutil.obj) : error LNK2001: unresolved external symbol __iob
wxmsw28d.lib(monolib_datetime.obj) : error LNK2001: unresolved external symbol _timezone
OLDNAMES.lib(timezone.obj) : error LNK2001: unresolved external symbol _timezone
OLDNAMES.lib(timezone.obj) : error LNK2001: unresolved external symbol __timezone
bin\Debug\test1.exe : fatal error LNK1120: 3 unresolved externals
Process terminated with status 1120 (0 minutes, 0 seconds)
10 errors, 0 warnings
 

Offline TDragon

  • Lives here!
  • ****
  • Posts: 936
    • Twilight Dragon Media
Re: Linker Errors
« Reply #8 on: October 24, 2007, 12:25:27 am »
I can't reproduce your error with an identical link command-line, so I wonder if doing a full rebuild (Ctrl+F11) will solve the problem?
http://tdm-gcc.tdragon.net/ - TDM-GCC compiler suite for Windows (GCC 5.1.0 2015-06-28, 32/64-bit, no extra DLLs)

Offline stahta01

  • Lives here!
  • ****
  • Posts: 6636
    • My Best Post
Re: Linker Errors
« Reply #9 on: October 24, 2007, 07:30:56 am »
Does wxPack have msvc 8.0 built binaries?
The web site mentions 7.1 not 8.0.

I have never been able to mix wxWidgets built with MSVC 7.1 (2003) with client code assembled with MSVC 8.0 (2005). I think it should be possible, but I have never found the way to do it.

Tim S
C Programmer working to learn more about C++ and Git.
On Windows 7 64 bit and Windows 10 32 bit.
On Debian Stretch, compiling CB Trunk against wxWidgets 3.0.
--
When in doubt, read the CB WiKi FAQ. http://wiki.codeblocks.org

Offline mspoerr

  • Single posting newcomer
  • *
  • Posts: 9
    • wktools
Re: Linker Errors
« Reply #10 on: October 24, 2007, 08:34:45 am »
Tim,
this is a good hint -> I will check this, but it will take some time. I will come back with the results.

/mspoerr

Offline mspoerr

  • Single posting newcomer
  • *
  • Posts: 9
    • wktools
Re: Linker Errors
« Reply #11 on: November 03, 2007, 09:47:24 pm »
Hello,

I now compiled wxwidgets with VS2005 and I am now able to build the samples, but with new projects I still have problems. It seems that the wizard does something wrong - the linker wants to have wxmsw28d.lib but I cannot find it on my system. I have a lot of wxmsw28d_xxxxx libs...

/mspoerr

Offline stahta01

  • Lives here!
  • ****
  • Posts: 6636
    • My Best Post
Re: Linker Errors
« Reply #12 on: November 03, 2007, 09:56:37 pm »
Hello,

I now compiled wxwidgets with VS2005 and I am now able to build the samples, but with new projects I still have problems. It seems that the wizard does something wrong - the linker wants to have wxmsw28d.lib but I cannot find it on my system. I have a lot of wxmsw28d_xxxxx libs...

/mspoerr

wxmsw28d.lib is for Monolithic debug builds; you seem to have a Multilib build. MultiLib is the opposite of Monolithic.

In the wizard un-check Monolithic or you need to build wxWidgets as a Monolithic build.

Tim S
C Programmer working to learn more about C++ and Git.
On Windows 7 64 bit and Windows 10 32 bit.
On Debian Stretch, compiling CB Trunk against wxWidgets 3.0.
--
When in doubt, read the CB WiKi FAQ. http://wiki.codeblocks.org

Offline mspoerr

  • Single posting newcomer
  • *
  • Posts: 9
    • wktools
Re: Linker Errors
« Reply #13 on: November 03, 2007, 10:06:20 pm »
oh - now it works :oops:

Thank you all for your help!

/mspoerr

Offline uelkfr

  • Single posting newcomer
  • *
  • Posts: 4
Re: Linker Errors
« Reply #14 on: June 15, 2008, 02:24:36 pm »
Please, can you help me too.
Config: Windows XP SP2, Code Blocks 8.0.2 (C:\Program Files\CodeBlocks), MinGW was inside CodeBlocks setup package codeblocks-8.02mingw-setup.exe but I will not use it because MinGW don't like spaces, especially windres.exe (C:\Program Files\CodeBlocks\MinGW), wxWidgets 2.8.7 been setup from wxMSW-2.8.7-Setup.exe (C:\Program Files\wxWidgets-2.8.7) I wonder why wxMSW-2.8.7-Setup.exe haven't added environment variable %WXWIN%, which I've done myself, Microsoft Visual C++ 2008 Express Edition (C:\Program Files\Microsoft Visual Studio 9.0), no wxPack

Building wxWidgets. Start > Programs> Visual C++ 9.0 Express Edition > Visual Studio Tools > Visual Studio 2008 Command Prompt.
cd %WXWIN%\build\msw
nmake -f makefile.vc USE_XRC=1 SHARED=1 MONOLITHIC=1 BUILD=debug UNICODE=1
nmake -f makefile.vc USE_XRC=1 SHARED=1 MONOLITHIC=1 BUILD=release UNICODE=1

Trying clean
nmake -f makefile.vc clean USE_XRC=1 SHARED=1 MONOLITHIC=1 BUILD=debug UNICODE=1
gives some error :( I'm starting to hate bakefile.

I'm creating my first wxWidgets project using wizard:
1) Next
2) wxWidgets 2.8.x
3) Project Title: wxTest, Folder: C:\Program Files\CodeBlocks\Projects
4) Next
5) wxSmith and Dialog Based
6) $(#wx), where #wx is CB's global variable base=C:\Program Files\wxWidgets-2.8.7, include=C:\Program Files\wxWidgets-2.8.7\include, lib=C:\Program Files\wxWidgets-2.8.7\lib
7) Microsoft Visual C++ 2005/2008, Create Debug and Release configurations
8) Use wxWidgets DLL, wxWidgets is built as monolithic library, Enable unicode, Configure Advanced Options
9) unchecked "Use __WXDEBUG__ and Debug wxWidgets lib" (GCC Only), Debug Target "GUI Mode Application", Release Target "GUI Mode Application"

Building debug gives this error (with full command line report):
-------------- Build: Debug in wxTest ---------------

cl.exe /nologo /DWIN32 /D__WIN32__ /D__WXMSW__ /DWXUSINGDLL /DwxUSE_UNICODE /D_WINDOWS /TP /Gd /GF /EHsc /D_CRT_SECURE_DEPRECATE /D_CRT_NONSTDC_NO_DEPRECATE /Zc:wchar_t /D_VC80_UPGRADE=0x0600 /W3  /Zi /D_DEBUG /D__WXDEBUG__ /MDd    /I"C:\Program Files\wxWidgets-2.8.7\include" /I"C:\Program Files\wxWidgets-2.8.7\contrib\include" /I"C:\Program Files\wxWidgets-2.8.7\lib\vc_dll\mswud" /I"C:\Program Files\Microsoft SDKs\Windows\v6.0A\include" /I"C:\Program Files\Microsoft Visual Studio 9.0\VC\include"  /c wxTestApp.cpp /FoDebug\wxTestApp.obj
wxTestApp.cpp
cl.exe /nologo /DWIN32 /D__WIN32__ /D__WXMSW__ /DWXUSINGDLL /DwxUSE_UNICODE /D_WINDOWS /TP /Gd /GF /EHsc /D_CRT_SECURE_DEPRECATE /D_CRT_NONSTDC_NO_DEPRECATE /Zc:wchar_t /D_VC80_UPGRADE=0x0600 /W3  /Zi /D_DEBUG /D__WXDEBUG__ /MDd    /I"C:\Program Files\wxWidgets-2.8.7\include" /I"C:\Program Files\wxWidgets-2.8.7\contrib\include" /I"C:\Program Files\wxWidgets-2.8.7\lib\vc_dll\mswud" /I"C:\Program Files\Microsoft SDKs\Windows\v6.0A\include" /I"C:\Program Files\Microsoft Visual Studio 9.0\VC\include"  /c wxTestMain.cpp /FoDebug\wxTestMain.obj
wxTestMain.cpp
rc.exe /I"C:\Program Files\wxWidgets-2.8.7\include" /I"C:\Program Files\wxWidgets-2.8.7\lib\vc_dll\mswud" /I"C:\Program Files\Microsoft SDKs\Windows\v6.0A\include" /I"C:\Program Files\Microsoft Visual Studio 9.0\VC\include"  -foDebug\resource.res resource.rc
Microsoft (R) Windows (R) Resource Compiler Version 6.0.5724.0
Copyright (C) Microsoft Corporation.  All rights reserved.
link.exe /nologo /subsystem:windows /LIBPATH:"C:\Program Files\wxWidgets-2.8.7\lib\vc_dll" /LIBPATH:"C:\Program Files\Microsoft SDKs\Windows\v6.0A\lib" /LIBPATH:"C:\Program Files\Microsoft Visual Studio 9.0\VC\lib"  /out:Debug\wxTest.exe msvcrtd.lib wxmsw28u.lib winmm.lib rpcrt4.lib  Debug\wxTestApp.obj Debug\wxTestMain.obj  Debug\resource.res  /DEBUG /NODEFAULTLIB:libcmtd.lib /NODEFAULTLIB:msvcrt.lib /INCREMENTAL:NO /SUBSYSTEM:WINDOWS
wxTestApp.obj : error LNK2001: unresolved external symbol "public: virtual void __thiscall wxAppConsole::OnAssertFailure(wchar_t const *,int,wchar_t const *,wchar_t const *,wchar_t const *)" (?OnAssertFailure@wxAppConsole@@UAEXPB_WH000@Z)
wxTestApp.obj : error LNK2001: unresolved external symbol "public: virtual void __thiscall wxAppConsole::OnAssert(wchar_t const *,int,wchar_t const *,wchar_t const *)" (?OnAssert@wxAppConsole@@UAEXPB_WH00@Z)
Debug\wxTest.exe : fatal error LNK1120: 2 unresolved externals
Process terminated with status 1120 (0 minutes, 6 seconds)
3 errors, 0 warnings
 
release version builds fine:
-------------- Build: Release in wxTest ---------------

cl.exe /nologo /DWIN32 /D__WIN32__ /D__WXMSW__ /DWXUSINGDLL /DwxUSE_UNICODE /D_WINDOWS /TP /Gd /GF /EHsc /D_CRT_SECURE_DEPRECATE /D_CRT_NONSTDC_NO_DEPRECATE /Zc:wchar_t /D_VC80_UPGRADE=0x0600 /W3  /Ox /DNDEBUG /MD /O2 /Ob1    /I"C:\Program Files\wxWidgets-2.8.7\include" /I"C:\Program Files\wxWidgets-2.8.7\contrib\include" /I"C:\Program Files\wxWidgets-2.8.7\lib\vc_dll\mswu" /I"C:\Program Files\Microsoft SDKs\Windows\v6.0A\include" /I"C:\Program Files\Microsoft Visual Studio 9.0\VC\include"  /c wxTestApp.cpp /FoRelease\wxTestApp.obj
wxTestApp.cpp
cl.exe /nologo /DWIN32 /D__WIN32__ /D__WXMSW__ /DWXUSINGDLL /DwxUSE_UNICODE /D_WINDOWS /TP /Gd /GF /EHsc /D_CRT_SECURE_DEPRECATE /D_CRT_NONSTDC_NO_DEPRECATE /Zc:wchar_t /D_VC80_UPGRADE=0x0600 /W3  /Ox /DNDEBUG /MD /O2 /Ob1    /I"C:\Program Files\wxWidgets-2.8.7\include" /I"C:\Program Files\wxWidgets-2.8.7\contrib\include" /I"C:\Program Files\wxWidgets-2.8.7\lib\vc_dll\mswu" /I"C:\Program Files\Microsoft SDKs\Windows\v6.0A\include" /I"C:\Program Files\Microsoft Visual Studio 9.0\VC\include"  /c wxTestMain.cpp /FoRelease\wxTestMain.obj
wxTestMain.cpp
rc.exe /I"C:\Program Files\wxWidgets-2.8.7\include" /I"C:\Program Files\wxWidgets-2.8.7\lib\vc_dll\mswu" /I"C:\Program Files\Microsoft SDKs\Windows\v6.0A\include" /I"C:\Program Files\Microsoft Visual Studio 9.0\VC\include"  -foRelease\resource.res resource.rc
Microsoft (R) Windows (R) Resource Compiler Version 6.0.5724.0
Copyright (C) Microsoft Corporation.  All rights reserved.
link.exe /nologo /subsystem:windows /LIBPATH:"C:\Program Files\wxWidgets-2.8.7\lib\vc_dll" /LIBPATH:"C:\Program Files\Microsoft SDKs\Windows\v6.0A\lib" /LIBPATH:"C:\Program Files\Microsoft Visual Studio 9.0\VC\lib"  /out:Release\wxTest.exe msvcrt.lib wxmsw28u.lib winmm.lib rpcrt4.lib  Release\wxTestApp.obj Release\wxTestMain.obj  Release\resource.res  /NODEFAULTLIB:libcmt.lib /INCREMENTAL:NO /SUBSYSTEM:WINDOWS
Output size is 61.00 KB
Running target post-build steps
mt.exe /nologo /manifest "Release\wxTest.exe.manifest" /outputresource:"Release\wxTest.exe";1
Process terminated with status 0 (0 minutes, 4 seconds)
0 errors, 0 warnings
« Last Edit: June 15, 2008, 03:06:15 pm by uelkfr »

Offline stahta01

  • Lives here!
  • ****
  • Posts: 6636
    • My Best Post
Re: Linker Errors
« Reply #15 on: June 15, 2008, 03:20:05 pm »
I think the Visual C++ Express Editions do not have the debug libraries/DLLs. So, try to only do release builds or research the issue using Google.

Tim S
C Programmer working to learn more about C++ and Git.
On Windows 7 64 bit and Windows 10 32 bit.
On Debian Stretch, compiling CB Trunk against wxWidgets 3.0.
--
When in doubt, read the CB WiKi FAQ. http://wiki.codeblocks.org

Offline uelkfr

  • Single posting newcomer
  • *
  • Posts: 4
Re: Linker Errors
« Reply #16 on: June 15, 2008, 03:27:44 pm »
Thank, you. I have found problem. This wxWidgets wizard in CodeBlocks links wrong library wxmsw28u.lib, which in debug version should be wxmsw28ud.lib.

Fix:
Project > Build Options... > Linker Settings > Link Libraries: i have changed wxmsw28u.lib to wxmsw28ud.lib and now it works fine

Now I'm looking solution for other issue. I don't want to return to MinGW, because it doesnt support spaces in paths e.g. C:\Program Files\, but I need some debugger. I will go now googling CDB debugger :)

« Last Edit: June 15, 2008, 04:33:51 pm by uelkfr »

Offline Biplab

  • Developer
  • Lives here!
  • *****
  • Posts: 1874
    • Biplab's Blog
Re: Linker Errors
« Reply #17 on: June 15, 2008, 05:17:13 pm »
9) unchecked "Use __WXDEBUG__ and Debug wxWidgets lib" (GCC Only), Debug Target "GUI Mode Application", Release Target "GUI Mode Application"

Please note the words in Red colour. That option is meant for GCC; not for any other compiler. It's clearly written there.
Be a part of the solution, not a part of the problem.