Author Topic: problem with wxWidgets 2.8.4 linker-libraries  (Read 2447 times)

Offline Joss

  • Single posting newcomer
  • *
  • Posts: 9
problem with wxWidgets 2.8.4 linker-libraries
« on: September 01, 2007, 08:13:42 pm »
hi to alll,

I think I have a problem with a linker-libraries.

I just compiled wxWidgets 2.8.4 with a new compiler GCC 4.2.1 and these buildings options:

mingw32-make -f makefile.gcc USE_XRC=1 SHARED=1 MONOLITHIC=1 BUILD=release UNICODE=1
everything compiled fine.

Than i download the new version of CB ( 4418) and I setup the following build options for target relase in a little project that i had:
Linker : wxmsw28u_gcc_custom (dll)

when i rebuild the project i got these errors :

Linking executable: bin\Release\Test_wx1.exe
obj\Release\Test_wx1Main.o:Test_wx1Main.cpp:(.text+0x26f): undefined reference to `_imp___ZN12wxStringBase8InitWithEPKcjj'
obj\Release\Test_wx1Main.o:Test_wx1Main.cpp:(.text+0x291): undefined reference to `_imp___ZN12wxStringBase10ConcatSelfEjPKcj'
obj\Release\Test_wx1Main.o:Test_wx1Main.cpp:(.text+0x333): undefined reference to `_imp___ZN12wxStringBase8InitWithEPKcjj'
obj\Release\Test_wx1Main.o:Test_wx1Main.cpp:(.text+0x41c): undefined reference to `_imp___ZN12wxStringBase8InitWithEPKcjj'
obj\Release\Test_wx1Main.o:Test_wx1Main.cpp:(.text+0x5d8): undefined reference to `_imp___ZN12wxStringBase8InitWithEPKcjj'
obj\Release\Test_wx1Main.o:Test_wx1Main.cpp:(.text+0x62b): undefined reference to `_imp___ZN12wxStringBase8InitWithEPKcjj'
obj\Release\Test_wx1Main.o:Test_wx1Main.cpp:(.text+0x73d): undefined reference to `_imp___ZN12wxStringBase8InitWithEPKcjj'
obj\Release\Test_wx1Main.o:Test_wx1Main.cpp:(.text+0x8bc): more undefined references to `_imp___ZN12wxStringBase8InitWithEPKcjj' follow
obj\Release\Test_wx1App.o:Test_wx1App.cpp:(.rdata$_ZTV11Test_wx1App[vtable for Test_wx1App]+0x44): undefined reference to `wxApp::Initialize(int&, char**)'
collect2: ld returned 1 exit status
Process terminated with status 1 (0 minutes, 4 seconds)
8 errors, 71 warnings

can someone suggest me what am i doing wrong ?

thanks ,Joss.

Offline Joss

  • Single posting newcomer
  • *
  • Posts: 9
Re: problem with wxWidgets 2.8.4 linker-libraries
« Reply #1 on: September 02, 2007, 04:22:47 pm »
hi,

I found the error by my self.  :D When I create  the new wxWidgets-2.8.4 with the UNICODE option in line

mingw32-make -f makefile.gcc USE_XRC=1 SHARED=1 MONOLITHIC=1 BUILD=release UNICODE=1

I forget to add  in  project -> Build options->#defines  tha flag wxUSE_UNICODE.  I put this entry in case could be usefull for guys with the same problem.

Joss.



P.S : The new compiler mingw4.2.1 dw2 seems to be better then th 3.4.5 version. I also hope the guys of  wxWidgets remove those warnings about wxWidgets when compiling.
Also let me say that is very hard to find this kind of error just reading the type and the string error produced by the compiler.