Author Topic: The 07 august 2007 build (4357) is out.  (Read 9543 times)

Offline killerbot

  • Administrator
  • Lives here!
  • *****
  • Posts: 5193
The 07 august 2007 build (4357) is out.
« on: August 07, 2007, 05:43:11 pm »
Get quick announcements through the RSS feed http://www.codeblocks.org/nightly/CodeBlock_RSS.xml

Before you use a nightly make sure you understand how it works.

A link to the unicode windows wxWidget dll for Code::Blocks : http://prdownload.berlios.de/codeblocks/wxmsw28u_gcc_cb_wx284.7z

For those who might need this one (when no MingW installed on your system) : the mingw10m.dll : http://prdownload.berlios.de/codeblocks/mingwm10.7z

The 07 August 2007 build is out.
  - Windows :
   http://prdownload.berlios.de/codeblocks/CB_20070807_rev4357_win32.7z
  - Linux :
   http://prdownload.berlios.de/codeblocks/CB_20070807_rev4357_Ubuntu6.10+7.04_wx2.8.4.tar.gz (not yet)
   http://prdownload.berlios.de/codeblocks/CB_20070807_rev4357_Debian4.0_wx2.8.4.tar.gz (not yet)
   http://prdownload.berlios.de/codeblocks/CB_20070807_rev4357_suse100-102.wx28.i586.rpm (not yet)
   http://prdownload.berlios.de/codeblocks/CB_20070807_rev4357_fc4+5.i586.rpm (not yet)


Resolved Fixed:

  • Fixed: [Bug #11720] Standard Header Highlighting problem
  • Fixed: Highlight mode was not applied when highlight mode is changed from a mode to 'Plain text'
  • add Mach IPC typedefs for Darwin
  • Fixed: Couple of assertion failures associated with wxDir
  • Some clean up in Intel compiler detection code

Regressions/Confirmed/Annoying/Common bugs:

  • toolbar-images-not-changing-state (is a wx problem/Win XP problem)

« Last Edit: August 09, 2007, 03:01:58 pm by killerbot »

Offline SR

  • Multiple posting newcomer
  • *
  • Posts: 22
    • My blog
Re: The 07 august 2007 build (4357) is out.
« Reply #1 on: August 07, 2007, 07:36:47 pm »
Slackware build updated to revision 4357
http://sr.mcdir.ru/blogs/index.php?blog=7&p=127&more=1

Offline RJP Computing

  • Almost regular
  • **
  • Posts: 135
    • RJP Computing
Re: The 07 august 2007 build (4357) is out.
« Reply #2 on: August 07, 2007, 07:42:09 pm »
Has anybody had any problems with the "Build Target" combo in the build toolbar. It is not setting the target for me. I have tried deleting the Code::Blocks program directory and the settings folder under App Data. I am using Windows XP SP2. It has been this way for a few builds now. Any help would be appreciated.
- Ryan

Ubuntu/WinXP, AMD Athlon 64 3000+, 1000MB RAM, AC 97 Audio, ATI Radeon 9600XT 256MB

Offline szczepan

  • Multiple posting newcomer
  • *
  • Posts: 42
Bug #11607 still not REALLY fixed
« Reply #3 on: August 07, 2007, 11:43:54 pm »
There are multiple instances of this bug pattern in the build system. Please reopen.




Offline marfi

  • Multiple posting newcomer
  • *
  • Posts: 27
Re: The 07 august 2007 build (4357) is out.
« Reply #4 on: August 08, 2007, 11:16:28 am »
Hi, another possible bug is that the debugger doesn't start anymore. I have deleted all folders and configuration files as required before installation of new nightly build, but the problem persists. I use Win XP 64-bit SP2.

Offline dje

  • Lives here!
  • ****
  • Posts: 683
Re: The 07 august 2007 build (4357) is out.
« Reply #5 on: August 08, 2007, 11:52:53 am »
Hi !

Hi, another possible bug is that the debugger doesn't start anymore. I have deleted all folders and configuration files as required before installation of new nightly build, but the problem persists. I use Win XP 64-bit SP2.

Quote
Does not start
or prints a Child process XXX... in the debugger log and does nothing ??

If it is the second case, I think this is the most important bug to fix before RC3 release. You can get rid of it by running your app (Build->Run) and stop it to wake up the debugger.

Dje

Offline marfi

  • Multiple posting newcomer
  • *
  • Posts: 27
Re: The 07 august 2007 build (4357) is out.
« Reply #6 on: August 08, 2007, 12:15:34 pm »
Yes, you are right; it is the second case. Exactly saying the debugger starts but finishes immediately without any effect. Here is a complete Debugger's log:

Code: [Select]
Building to ensure sources are up-to-date
Build succeeded
Selecting target: Debug
Adding source dir: D:\MyWork\Source\VC++\UMLDesigner\
Adding source dir: D:\MyWork\Source\VC++\UMLDesigner\
Adding file: bin\Debug\UMLDesigner.exe
Starting debugger: done
Registered new type: wxString
Registered new type: STL String
Registered new type: STL Vector
Setting breakpoints
Debugger name and version: GNU gdb 6.3
Child process PID: 2616
Debugger finished with status 0

Offline dje

  • Lives here!
  • ****
  • Posts: 683
Re: The 07 august 2007 build (4357) is out.
« Reply #7 on: August 08, 2007, 01:56:22 pm »
In fact, not exactly the same...
In my case (debugging my C::B plugin with C::B as host application on XP SP2), the debugger systematically hangs at line
Quote
Child process PID: 2616
but does not stop.

I already experiment this kind of situation (including Debugger finished with status 0) when a required binary is missing (a .so on Linux for example).

Dje

Offline morgan

  • Single posting newcomer
  • *
  • Posts: 9
Debian build not available
« Reply #8 on: August 09, 2007, 12:19:26 pm »
Can't download Debian build... Berlios sends me to an "object not found" error page

http://prdownload.berlios.de/codeblocks/CB_20070807_rev4357_Debian4.0_wx2.8.4.tar.gz


Offline cstudent

  • Almost regular
  • **
  • Posts: 159
    • Cstudent's Help Desk
Re: Debian build not available
« Reply #9 on: August 09, 2007, 02:50:41 pm »
Can't download Debian build... Berlios sends me to an "object not found" error page

http://prdownload.berlios.de/codeblocks/CB_20070807_rev4357_Debian4.0_wx2.8.4.tar.gz



That's an error in the killerbot's post. There was neither an Ubuntu or Debian build for this revision. There is a Debian tarball for 8.6.07.

Offline killerbot

  • Administrator
  • Lives here!
  • *****
  • Posts: 5193
Re: Debian build not available
« Reply #10 on: August 09, 2007, 03:02:16 pm »
Can't download Debian build... Berlios sends me to an "object not found" error page

http://prdownload.berlios.de/codeblocks/CB_20070807_rev4357_Debian4.0_wx2.8.4.tar.gz



That's an error in the killerbot's post. There was neither an Ubuntu or Debian build for this revision. There is a Debian tarball for 8.6.07.

fixed the post