Author Topic: Anyone have idea to use C::B for debug ARM7  (Read 6334 times)

Offline nooknikz

  • Single posting newcomer
  • *
  • Posts: 3
Anyone have idea to use C::B for debug ARM7
« on: August 01, 2007, 04:37:58 am »
from http://forums.codeblocks.org/index.php/topic,6190.0.html

now, i can Build , Clean my project with C::B. but when i try debug my source code, it same work but not show cursor (->) for run step info.

i add intialization command already

target remote localhost:3333
monitor reset
monitor sleep 500
monitor poll
monitor flash probe 0
monitor flash erase 0 0 0
monitor flash write 0 main.bin 0x0
monitor sleep 500
monitor soft_reset_halt
monitor arm7_9 force_hw_bkpts enable
break main
load
continue

I tested with Elipse ( setup same C::B ). it work ok

Thanks you

Offline mandrav

  • Project Leader
  • Administrator
  • Lives here!
  • *****
  • Posts: 4291
    • Code::Blocks IDE
Re: Anyone have idea to use C::B for debug ARM7
« Reply #1 on: August 01, 2007, 08:09:02 am »
There have been some improvements wrt remote debugging recently.
You can setup remote debugging per-target now in project properties (Debugger tab).

Note that you will have to move those initialization commands in the per-target remote debugging settings too.
Of course you will have to remove the "target remote" command as C::B sends it itself. Same goes for the "continue" command (and maybe "load" and "break main").

If it still doesn't work for you, enable the debugger's "debug log" in global debugger's settings and then paste its contents here.
Be patient!
This bug will be fixed soon...

Offline Joerg

  • Multiple posting newcomer
  • *
  • Posts: 100
Re: Anyone have idea to use C::B for debug ARM7
« Reply #2 on: August 01, 2007, 09:47:11 am »
Hi mandrav,

I recently put a similar question under the 'remote debugging' thread.
Maybe no good idea, I thought this was a permanent topic for this task.
Maybe you could have a look and give me some hints how to get further?
Thanks

There have been some improvements wrt remote debugging recently.
You can setup remote debugging per-target now in project properties (Debugger tab).
If it still doesn't work for you, enable the debugger's "debug log" in global debugger's settings and then paste its contents here.
It's never too late to fail!